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Preface

INTRODUCTION
This chapter contains general information that will be useful to know before using the 
LIN Serial Analyzer. Items discussed in this chapter include:
� Document Layout
� Conventions Used in this Guide
� Recommended Reading
� The Microchip Web Site
� Customer Support
� Document Revision History

DOCUMENT LAYOUT
This document describes how to use the LIN Serial Analyzer. The manual layout is as 
follows:
� Chapter 1. �LIN Serial Analyzer Overview� � What the LIN Serial Analyzer is, 

what makes it a desirable development tool and what features are available.
� Chapter 2. �Getting Started � Quick Setup� � Describes the supplies needed to 

set up and begin to use the LIN Serial Analyzer.
� Chapter 3. �LIN Serial Analyzer PC Program� � Describes the primary 

elements of the interface.
� Appendix A. �LIN Serial Analyzer Technical Information� � Provides the 

detailed schematic of the LIN Serial Analyzer.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a �DS� number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
�DSXXXXXA�, where �XXXXX� is the document number and �A� is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 
Select the Help menu, and then Topics to open a list of available on-line help files.
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CONVENTIONS USED IN THIS GUIDE
This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial font:
Italic characters Referenced books MPLAB® IDE User�s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

�Save project before build�

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

N�Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4�b0010, 2�hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New font:
Plain Courier New Sample source code #define START

File names autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, �A�

Italic Courier New A variable argument file.o, where file can be 
any valid file name

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}
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RECOMMENDED READING
This user�s guide describes how to use LIN Serial Analyzer. Other useful documents 
are listed below. The following Microchip documents are available and recommended 
as supplemental reference resources.
It is recommended that you become familiar with the documents listed below before 
using the LIN Serial Analyzer.
PICkit� Serial Analyzer User�s Guide (DS51647)
LIN Specification Package 2.1
© LIN Consortium, 2006. http://www.lin-subbus.org.
LIN Network for Vehicle Applications � Surface Vehicle Recommended Practice 
(J2602/1)
© SAE 2006. http://www.sae.org.

THE MICROCHIP WEB SITE
Microchip provides online support via our web site at www.microchip.com. This web 
site is used as a means to make files and information easily available to customers. 
Accessible by using your favorite Internet browser, the web site contains the following 
information:
� Product Support � Data sheets and errata, application notes and sample 

programs, design resources, user�s guides and hardware support documents, 
latest software releases and archived software

� General Technical Support � Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

� Business of Microchip � Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

CUSTOMER SUPPORT
Users of Microchip products can receive assistance through several channels:
� Distributor or Representative
� Local Sales Office
� Field Application Engineer (FAE)
� Technical Support
� Development Systems Information Line
Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.
Technical support is available through the web site at: http://support.microchip.com.

DOCUMENT REVISION HISTORY

Revision A (June 2007)
� Initial release of this document.

http://www.microchip.com
E:�y Hardware\USB2LIN\03-01983.pdf 
http://www.lin-subbus.org
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Chapter 1.  LIN Serial Analyzer Overview

1.1 INTRODUCTION
The LIN Serial Analyzer development system enables a Personal Computer (PC) to 
communicate with a LIN (Local Interface Network) bus. The PC program uses a graph-
ical user interface to enter and display message frames occurring on the target bus. 
The LIN Serial Analyzer connects to the system network using a three-position terminal 
block.
Chapter 2. �Getting Started� will guide you through installing the PC program, the 
Windows® operating system drivers and setting up the hardware.

1.2 HIGHLIGHTS
This chapter discusses:
� LIN Serial Analyzer Contents
� LIN Serial Analyzer Development Tool
� LIN Serial Analyzer Hardware
� LIN Serial Analyzer Software

1.3 LIN SERIAL ANALYZER CONTENTS
The LIN Serial Analyzer kit contains the following items:
� LIN Serial Analyzer
� Mini-B USB Cable
� LIN Serial Analyzer CD-ROM

1.4 LIN SERIAL ANALYZER DEVELOPMENT TOOL
The LIN Serial Analyzer consists of several components, that together, make a network 
debug and analysis tool. The user interface program runs on Microsoft® Windows® 
operating system compatible computers with a USB port.
The LIN Serial Analyzer connects to the PC using a mini-B USB cable. The LIN Serial 
Analyzer interfaces to the target network using a three-position, screw-type terminal 
block. Figure 1-1 illustrates the LIN Serial Analyzer tool connected to a network.
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FIGURE 1-1: LIN SERIAL ANALYZER DEVELOPMENT TOOL

1.5 LIN SERIAL ANALYZER HARDWARE
The LIN Serial Analyzer connects to a Microsoft® Windows® operating system 
compatible computer using a USB port. It interfaces to the target network using a 
three-position, screw-type terminal block.

FIGURE 1-2: LIN SERIAL ANALYZER

1.5.1 Status LEDs
The Status LEDs indicate the status of the LIN Serial Analyzer. An illuminated LED 
means:
� USB (green) � Power has been applied to the LIN Serial Analyzer by the USB 

port.
� Busy (yellow) � The LIN Serial Analyzer is communicating with the LIN network.
� LIN (blue) � The LIN Serial Analyzer is connected to the target bus.

Board Under Test

LIN Tool PC

Optional
Power
Supply

Status LEDs

USB Port
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1.5.2 USB Port Connection
The USB port connection is a USB mini-B connector. Connect the LIN Serial Analyzer 
to the PC using the cable supplied with the device.

FIGURE 1-3: LIN SERIAL ANALYZER NETWORK AND POWER

1.5.3 Network Communication Connector
The communication connector connects to the target device using a three-position, 
screw clamp terminal block. The pin assignments, labeled on the top of the device, are:
� VBAT � Positive battery connection for voltage supplied by the vehicle
� LIN � Bidirectional data I/O
� GND � Common chassis, power and serial ground

1.5.4 Power Jack
The device uses a standard, 6.5 x 2.5 DC power plug. The center pin is positive. Power 
can be supplied either through the power plug or the network connector as the two are 
internally connected.

Network
Connection

Terminal
Block
Screws

Auxiliary
Power
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1.6 LIN SERIAL ANALYZER SOFTWARE

1.6.1 User Interface Program
The LIN Serial Analyzer PC program displays all of the board�s bus activity via the 
software�s Transaction window, displayed on the connected PC. This is useful for 
�sniffing� the bus and tracking message frames.
Chapter 3. �LIN Serial Analyzer PC Program� explains the installation and operation 
of the program. 

1.6.2 Firmware
The LIN Serial Analyzer firmware is explained in the �PICkit� Serial Analyzer 
Firmware� section of the �PICkit� Serial Analyzer User�s Guide� (DS51647).

1.6.3 Dynamically Linked Library (DLL)
The LIN Serial Analyzer DLL is explained in the �PICkit� Serial Analyzer DLL� 
section of the �PICkit� Serial Analyzer User�s Guide� (DS51647).
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Chapter 2.  Getting Started � Quick Setup

2.1 HIGHLIGHTS
This chapter discusses:
� Using the LIN Serial Analyzer for the First Time
� Software Installation
� Running LIN Serial Analyzer Program

2.2 USING THE LIN SERIAL ANALYZER FOR THE FIRST TIME
The LIN Serial Analyzer is shipped preprogrammed and ready for use. The user needs 
to supply:
� A wiring harness with appropriate connections to its system network
� A power supply (nominal 13.8V)
Before making any connections, the software must be installed on the host system. The 
user must have administrator level rights to install some of the required programs. For 
more information, see Section 2.3 �Software Installation�.
Power is supplied either through the round, power plug or the terminal block. The 
positive and negative terminals and power plug are common. Supplied power must be 
in the range of 8.0V to 30.0V with a nominal value of 12.0-14.4V. Less than 5.0 mA of 
current is required to power the LIN transceiver section of the unit.
Internal jumper, E1, configures the unit as either a master or slave node. A 1.0 kΩ bus 
pull-up resistor is enabled when E1 is connected across A and B. With the jumper 
removed, an internal 30 kΩ resistor is retained.
The unit is configured as a master node as shipped.

2.3 SOFTWARE INSTALLATION
All necessary files are contained on the Compact Disc (CD) supplied with the device.

2.3.1 Installing the LIN Serial Analyzer Program
1. Run setup.exe from the CD.
2. Select Install when prompted and follow any instructions. 

The PC host program is uninstalled with the control panel�s add/remove utility.

2.4 RUNNING LIN SERIAL ANALYZER PROGRAM
Before starting the LIN Serial Analyzer software:
� The analyzer must be connected to the PC by a USB cable
� The analyzer must be powered up
The analyzer�s green USB and blue LIN lights will be on when these conditions are 
met.

Note: The LIN Serial Analyzer program requires the Microsoft® .NET Framework 
version 2.0.
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There is a hard-wired, loopback bus path, so connection to a network is not needed for 
testing the installation.
To start the software:
1. On the Windows operating system taskbar, click Start.
2. Click All Programs>Microchip Technology Inc.>LIN Serial Analyzer.
3. Click Setup>COM port.
4. From the pull-down menu, select the USB port to be used. 

5. In the menu�s text box, type the appropriate baud rate value.
6. Click OK.
7. Verify operation by selecting one of the preset messages from the Master 

Message area.
Bus activity is indicated by the analyzer�s yellow BUSY light flickering. 
A message will be displayed in the Bus Transaction window with:
� A time-stamp
� The correct ID parity bits
� The calculated checksum
� Any detected error conditions

Note: Only available, plugged in USB ports are displayed by the pull-down menu. 
If the correct serial port is not displayed, verify that the USB hardware is 
correctly installed.
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Chapter 3.  LIN Serial Analyzer PC Program

3.1 HIGHLIGHTS
This chapter discusses:
� Interface Overview
� Transaction Window
� File Functions
� Setup Functions
� Tools Functions
� Start/Stop Logging Button
� Master Message Group Box
� Status Bar

3.2 INTERFACE OVERVIEW 
When the LIN Serial Analyzer�s software program starts, the window, shown in 
Figure 3-1, appears. The commands are accessed through the pull-down menus at the 
top of the interface.

FIGURE 3-1: LIN SERIAL ANALYZER USER INTERFACE

Pull-Down
Menus

Start/Stop
Logging
Button

Transaction
Window

Master
Message
Group Box

Status Bar
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3.3 TRANSACTION WINDOW
This window, shown in Figure 3-2, constantly monitors and display bus traffic when in 
the �Display All� mode. Any message frames seen on the bus are shown, regardless of 
the source.
The data is displayed as it is seen on the bus without modification.
This section describes the window�s fields.

FIGURE 3-2: MESSAGE FRAMES DISPLAY

3.3.1 TimeStamp
This field of the Transaction window displays the time, in seconds, since the last frame 
was received. The value is reset to zero when the window is cleared.
The value can also be cleared by clicking on the �TimeStamp� column label.

3.3.2 ID (Identifier)
This field displays the ID byte, including the upper two parity bits.

3.3.3 Data
From zero to eight data bytes are displayed in this field. The data is in the hexadecimal 
format (without the leading characters, �0x�), with the bytes separated by spaces.

3.3.4 Checksum
The last field of a frame is the checksum. The checksum contains the inverted, eight-bit 
sum with carry, over all data bytes or all data bytes and the protected identifier.

3.3.5 ChkSumType
This field indicates whether a �classic� or �enhanced� equation was used for the check-
sum calculation. For messages sent via the Master Message group box, the type of 
calculation is configured in the checksum portion of the Master Message group box 
(see Section 3.8.3 �Checksum Group�).
� Classic � Checksum calculation over the data bytes only. Used for the master 

request frame, slave response frame and communications with LIN 1.x slaves.
An eight-bit sum with carry is equivalent to the sum of all values and subtracts 
255 every time the sum is greater than or equal to 256.

� Enhanced � Checksum calculation over the data bytes and the protected identifier 
byte. Used for communication with LIN 2.x slaves.

The checksum is calculated both ways when a message frame is received. A match is 
displayed either as �Classic� or �Enhanced�. If neither result matches the incoming 
data, �ERROR� is displayed.

3.3.6 Baud
This field shows the actual, calculated bit rate observed during the Auto-Baud Detect 
period of the current frame.
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3.3.7 Errors
This field displays any of the error types described in this section. If multiple errors are 
detected, only one is displayed.

3.3.7.1 PARITY

The parity is calculated on the frame identifier bits as shown in Equation 3-1.

EQUATION 3-1: PARITY CALCULATIONS� 

3.3.7.2 TX BIT 

A slave or master node that is transmitting a bit on the bus also monitors the bus. A TX 
bit error is when the bit or byte value that is received is different from the bit or byte 
value that is transmitted. 

3.3.7.3 CHECKSUM

A checksum error is when the inverted modulo-256 sum over all received data bytes 
and the protected identifier (when using enhanced checksum) and the received 
checksum byte field does not result in $FF.

3.3.7.4 FRAMING 

A byte field framing error is when the ninth bit after a valid Start bit is dominant. This 
check does not apply to the Break character. 

3.3.7.5 NO ANSWER

This value displays when a new Break/Sync/ID header was detected, but no data was 
received within the bus time-out period.

3.3.7.6 BREAK 

This displays when data characters were received before a valid Sync Break header 
was detected. 

3.3.7.7 BUS TIME-OUT

This value indicates that the time interval allocated for an eight-byte message expired. 
This time is set to approximately 140% of a single bit time. 
The time-out may also be configured to a fixed value not dependent on baud rate.

3.3.7.8 SWBREAK 

This value displays when a valid Sync Break is not detected by the UART. A Break was 
�assumed� because the first byte received was 0x00, but without a framing error. 

P0 = ID0 ⊕ ID1 ⊕ ID2 ⊕ ID4
P1 = - (ID1 ⊕ ID3 ⊕ ID4 ⊕ ID5)

� P0 is bit 6 and P1 is bit 7 of the ID byte.

Note: This function is not currently implemented.

Note: This function is not currently implemented.

Note: This function is not currently implemented.

Note: This function is not currently implemented.
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3.4 FILE FUNCTIONS

3.4.1 Open
The �Open� dialog box loads configuration and master message frames from a 
user-selected file into the �Master Frames� field, so that they can be sent (see 
Section 3.8.1 �Master Frames Field�).
By default, the dialog box, shown in Figure 3-3, displays the file that was last used in 
the previous session.
To display the dialog box, go to the pull-down menus at the top of the user interface and 
select File>Open.

FIGURE 3-3: FILE OPEN WINDOW   

3.4.2 Save
The �Save� dialog box saves configuration and master message frames, displayed 
in the �Master Frames� field, to a previously selected *.ini file (see 
Section 3.8.1 �Master Frames Field�.) By default, the dialog box populates the 
file name that was last used in the previous session.
To display the dialog box, go to the pull-down menus at the top of the user interface and 
select File>Save.
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3.4.3 Save As
The �Save As� dialog box saves or appends configuration and master message 
frames, displayed in the �Master Frames� field, to a preselected file (see 
Section 3.8.1 �Master Frames Field�). The default file name is the last used file from 
the previous session.
To display the dialog box, shown in Figure 3-4, go to the pull-down menus at the top of 
the user interface and select File>Save As.

FIGURE 3-4: FILE �Save As� WINDOW 

3.4.4 Print, Print Setup, Print Preview
These three functions relate to printing the contents of the Transaction window. 
Print Setup configures the printing attributes and Print Preview displays how the print 
will appear.
The printing function clears the contents of the Transaction window, but does not reset 
the time-stamp.
All of these functions are accessible through the File pull-down menu.

3.4.5 Exit
Selecting File>Exit terminates the LIN Serial Analyzer software program.
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3.5 SETUP FUNCTIONS
The Tools pull-down menu has the following commands.

3.5.1 Setup COM port
The �Setup COM port� function selects the USB communication port to use. 

The menu also sets the baud rate to apply to master transactions.
The �Timeout in mS� text box displays the current time-out value for a message frame 
and may be modified by the user. To enable the time-out value to vary with the baud 
rate, enter a value of 0.

FIGURE 3-5: �Setup COM port� WINDOW 

To display the dialog box, select Setup>COM port.

Note: The �COM port� drop-down list box displays only available, plugged-in USB 
ports. If the correct serial port is not displayed in the menu, verify that the 
USB hardware is correctly installed.
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3.5.2 Log File
The Log File setup function specifies the new or existing file that will store bus 
transactions.
If an existing file that already contains data is selected, any new messages will be 
appended to the end of the file.

FIGURE 3-6: LOG FILE SETUP WINDOW 

To display the dialog box, select Setup>Log File.
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3.6 TOOLS FUNCTIONS
This sections lists the commands on the Tools pull-down menu.

3.6.1 Debug Mode
Selecting Tools>Debug Mode enables the user to debug bus or slave operational 
issues.
One function forces a user-supplied checksum to be appended to a master message 
to check a slave for proper error handling. In this mode, the generation of identifier 
parity bits is inhibited and the identifier byte is transmitted without modification.

3.6.2 Suppress Bus Time-out Error
The current implementation of the master task cannot refer to a LIN descriptor file, so 
there is no way to determine the length of any received message. To calculate an 
appropriate time-out value, multiply the length of an eight-byte frame times 140% of the 
bit rate.
This value can be overridden by entering a fixed time-out value in the COM Setup 
window, described in Section 3.5.1 �Setup COM port�.

3.6.3 Clear Monitor Window
This function clears the Transaction window and resets the time-stamp.

3.6.4 Transmit
This option selects the Transmit Only mode. No received messages are displayed in 
the Transaction window.

3.6.5 Listen (Filter)
This option selects the Listen Only mode. Only non-duplicated messages are displayed 
in the Transaction window.
When �snooping� bus message frames, this prevents the Transaction window from 
becoming cluttered with repeated frames.

3.6.6 Display All (Snoop) Default
This function selects the Display All mode. All messages seen on the bus are 
displayed.
This mode is best used with the data logging feature to capture all bus traffic for later 
analysis.
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3.7 START/STOP LOGGING BUTTON
This button � located in the top, right corner of the interface � starts, pauses, or stops 
the capturing of messages to the log file. 
Before starting the logging process, select and open a log file (see Section 3.5.2 �Log 
File�).
To pause the logging process, click the button a second time.

3.8 MASTER MESSAGE GROUP BOX
This functions in the group box to act as a master node on the LIN bus, sending the 
previously constructed frames to the slaves on the bus.
This window will cause a bus conflict if another master appears on the network. Any 
conflict will be shown in an active Transaction window as a bus error.
The group box, shown in Figure 3-7, consists of the:
� �Master Frames� field
� �Checksum� group
� Message controls

FIGURE 3-7: MASTER MESSAGE GROUP BOX 

3.8.1 Master Frames Field
The �Master Frames� field is composed of 0 to n rows of one or more messages that 
can be sent over the bus for test purposes. These messages can be entered manually, 
loaded from a previously saved session, or both.
When the message is sent, it and any response is displayed in the Transaction window 
if it is open and active.
Messages in the �Master Frames� field can also be saved for reuse (see 
Section 3.4.2 �Save� and Section 3.4.3 �Save As�).

3.8.1.1 MESSAGE SYNTAX

Messages must consist of the ID byte without parity bits and the data bytes, all 
separated by spaces. All inputs are in hexadecimal radix.
The checksum is not included; it is calculated at send time.
Comments or notes may be attached to each frame by prefacing it with a 
semi-colon (;). Any text after the semi-colon will be disregarded and not transmitted. All 
notes will be saved in the selected .ini file and reloaded when reopened.

�Master Frames�
Field

�Checksum�
Group

Message
Controls
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3.8.1.2 DEVELOPING AND STORING MESSAGE CONTENT

To manually add message content to the �Master Frames� field: 
1. Click in an empty row in the �Master Frames� field. A second window displays for 

creation of the new message.
2. Type the message in the text box.
3. Click OK.
To load a pre-existing message to the �Master Frames� field:

1. From the pull-down menus, select File>Open. The �Open� dialog box appears.
2. In the dialog box�s list box, select the desired *.ini file.
3. Click Open.
To delete some message content: 
1. In the �Master Frames� field, select the content to be deleted by doing one of the 

following:
� To select adjacent rows of content � Click on the first row, scroll down to the 

last row and hold down <Shift> while clicking.
� To select non-adjacent rows of content � Hold down <Ctrl> while clicking each 

row.
2. Click Delete.
To send a message: 
1. In the �Master Frames� field, select the content to be sent by doing one of the 

following:
� To select adjacent rows of content � Click on the first row, scroll down to the 

last row and hold down <Shift> while clicking.
� To select non-adjacent rows of content � Hold down <Ctrl> while clicking each 

row.
2. Click Send.

The highlighted message content is sent, working top-to-bottom through the 
�Master Frames� field.
The message is sent once. (For information on continually sending the 
highlighted message content, see Section 3.8.2.3 �Continuous Button�.) 

To store a message:
1. See Section 3.4.2 �Save� and Section 3.4.3 �Save As�.

3.8.1.3 MASTER FRAMES FIELD ELEMENTS

This section describes the �Master Frames� field�s two elements.

3.8.1.3.1 ID
The �ID� element displays the identifier byte to be sent without the upper two parity bits. 
Parity is calculated and appended at send time unless the application is in the Debug 
mode (see Section 3.6.1 �Debug Mode�).
The acceptable range of values is 00 to 3F hex (0 to 63 decimal).

WARNING

Importing a file into the �Master Frames� field overwrites any content that previously 
had been in that field.
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3.8.1.3.2 DATA
The �Data� portion of the �Master Frames� field displays zero to eight-byte values, 
separated by spaces.

3.8.2 Message Controls

3.8.2.1 SEND BUTTON

Clicking this button transmits the message content that is highlighted in the �Master 
Frames� field (see the �Send� procedure in Section 3.8.1.2 �Developing and Storing 
Message Content�).
When the Send button is clicked, the message is sent once (see 
Section 3.8.2.3 �Continuous Button�). 
If the Transaction window is open and active, the message and any response will be 
displayed.

3.8.2.2 DELETE BUTTON

Clicking the Delete button deletes the content that is highlighted in the �Master Frames� 
field. (see the �Delete� procedure in Section 3.8.1.2 �Developing and Storing Message 
Content�).

3.8.2.3 CONTINUOUS BUTTON

Clicking the Continuous button sends the selected message entry or entries continu-
ously, at an interval defined in the time control text box, described next. A second click 
of the button stops the continuous transmissions.
Any number of messages may be selected for continuous broadcast. They will be 
transmitted in the order they appear in the �Master Frames� field.

3.8.2.4 TIME CONTROL

Used in conjunction with the Continuous button, this text box sets the interval, in 
milliseconds, between message frames being sent in the Continuous mode. 

Note: Due to service latency time in the Windows operating system environment, 
the minimum time interval may be as high as 200 ms, regardless of desired 
time set in the control box. Intervals less than 200 ms will be serviced as 
fast as possible, but may not be less than the operating system minimum.
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3.8.3 Checksum Group
The checksum value is computed at send time. Selecting one of the 
option buttons in the �Checksum� group, shown at right, determines 
the type of checksum that will be calculated for all transmitted 
master message frames, highlighted in the �Master Frames� field.
� classic � The checksum includes all data bytes.
� enhanced � The checksum includes identifier byte and all data 

bytes.
� forced � (Enabled only in Debug mode.) The last byte in the message string is 

sent in place of the calculated checksum. This is useful in checking slave error 
handling.

If a slave response is requested (a ID value with no data bytes), the checksum is not 
computed and the field is left blank.
The checksum returned by the slave will be displayed in the �Checksum� field of the 
Transaction window (see Section 3.3.5 �ChkSumType�.)

3.9 STATUS BAR
The status bar at the bottom of the Interface window displays:
� Currently selected baud rate of master messages
� Dynamic LIN network status
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Appendix A. LIN Serial Analyzer Technical Information

A.1 HIGHLIGHTS
This chapter discusses:
� LIN Serial Analyzer Schematic

A.2 LIN SERIAL ANALYZER SCHEMATIC
The LIN Serial Analyzer management hardware diagram is shown in Figure A-1.
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FIGURE A-1: LIN SERIAL ANALYZER SCHEMATIC 
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