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B Installing Arduino IDE

1

Vi.sit Arduino.cc and click . E
"
the Download tab at the top EEIIH

of the page Genuino
ARDUINO
Home Buy Download Pro Jucts + Learning +« Forum
WHAT IS ARDUINO?
2 Windows installer

.

Select Windows ZIP for non admin ~ ARDUINO 1.6.5

i i The open-source Arduino Software (IDE) makes It easy to

InSta”atlon write code and upload it to the board. It runs on Mo DS X 10.7 Lion or newer
Windows, Mac OS X, and Linux. The environment is
writzen in Java and based on Processing and other open- Linux 32 bits
source software
This software can be used with any Arduino board
Refer to the Cetting Started page for Installation
instructions

Linux 64 bits

Release Notes
Source Code
Checksums
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3.
After downloading, you will have

a ZIP file called
Arduino-1.6.5-r5-windows.zip

4,

Extract the folder arduino-1.6.5-r5 to
your root directory

(C:\\ for example)

5.
Open the folder arduino-1.6.5-r5

6.
Right click inside the folder window and
go to New > Folder
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@v[,L)Nm&)ﬂbMeb" Joads » arduino-16.5-15-windows.zip »

Organize v Extract all fi

9 Favorites Name Type
Ml Desktop
J. Downloads

5. Recent Places

4. arduino-16.5-15

File folder

4 Libraries
[¥ Documents
& Music
e Pictures
! Subversion
B videos

Date modified

Type

10/13/152:21PM  File folder

7/13/09 8:20 PM File folder

L. Recent Places ). Program Files 10/13/1510:36 AM  File folder

. Program Files (86) 10/13/15 204 PM File folder

4 Libraries ProgramData 7/8/15 239 PM File folder

[® Documents ) Users 7/5/158:27 PM File folder

& Music ). Windows 10/13/1510:35AM  File folder
= Pictures

) Subversion F
B videos

Disk (C) » arduino-165-15 »

Organze v Includein Sharewith v Bum
7 Favorites S N : Imodified Type Sze
Il Desktop b dist 0/13/15 2:20 PM File folder
)i Downloads ). drivers 10/13/15220PM  File folder
3 Recent Places . examples 10/13/15220PM  File folder
). hardware 10/13/15220PM  File folder
4 Libraries b java 10/13/15220PM  File folder
[5) Documents b iib 1013/15221PM  File folder
& Music L libraries 10/13/15221PM  File folder
= Pictures 1. reference 10/13/15221PM  File folder
) Subversion & ) tools 1071315 2:21 PM File folder
B Videos @ arduino.exe 8/28/15932AM  Application 393K
@) arduino Kjini 8/28/15932AM  Configuration sett 1KB
% Homegroup @ arduine_debug.exe 8/28/15932AM  Application 390 KB
{2 arduino_debug Kjini 8/28/15932AM  Configuration sett 1KB
1 Computer ) libusb0.dil 8/28/15932AM  Application extens. 43K8
& Local Disk (C) %] msvep100.dil 8/28/15932AM  Application extens. 412KB
). arduino-165-1 4] msver100.dit 8/28/15932AM  Application extens. 753 K8
)i Perflogs ] revisions.tt 8/28/15932AM  Text Document 67KB
B Donncacn Filas
] arduino_debug Mjini 8/28/159:32 AM Configuration sett.. 1k8
% Computer %) libusb0.dil 8/28/159:32 AM Application extens... 43KB
& Local Disk (C) %) msvep100.dil 8/28/159:32 AM Application extens... 412KB
) arduino-165-r %) msver100.dil 8/28/159:32 AM Application extens... 753 KB
b Perflogs | revisions.tet 8/28/159:32 AM Text Document 67KB
Ju Program Files
). Program Files ( View
J. ProgramData Sortby
b Users
Group by
4 Windows
€4 AdobeCameraRa _ LEa
) Customize this folder...
17 items
l " Paste

Paste shortcut
Undo Move .
Share with 2
% Rich Tet Document
& swcmm B Tetb
@ TortcksesVN *| i WinRARZIP archive
New » | @ Briefcase
Properties l
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7.
Name the new folder “portable”

8.

Launch Arduino.exe

B Installing Simblee Library

9.
With the ArduinolDE open, click on
File > Preferences

Simblee
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GU

). » Computer » Local Disk (C:) » arduino-16.5-r5 »

Organize v 7 Open  Includeinlibary v Sharewith v Bum  Newfolder
. 4 Neme : Date modified Type Size
B Desktop ) dist 10/13/15220PM  File folder
Ji Downloads i drivers 10/13/15220PM  File folder
% Recent Places )i examples 10/13/15220PM  File folder
10/13/15220PM  File folder
4 Libraries " java 10/13/15220PM  File folder
%) Document; ! lib File folder
& Music ). libraries 10/13/15 File folder
&) Pictun ) 10/13/15224PM  File folder
| Subvers) = J. reference 10/13/15 221 PM File folder
B videos 1 )i tools File folder
@ arduino.exe Application
«& Homegroup 29 Configuration sett.
@ arduino_debug.exe Application
% Computer & arduino_debug.Wj.ini Configuration sett...
& Local Disk (C) %) libusb0.dil Application extens
|, arduino-16.5-r %) msvep100.dil Application extens
Ji Perflogs %) msverl00.di Application extens
I, Program Files ] revisions.tat Text Document
). » Computer » Local Disk (C:) » arduino-16.5-15 »
Organize v [H) Open  Bum  Newfolder
X Favorites A Name . Date modified Type Size
B Desktop b dist File folder
J. Downloads ). drivers File folder
. Recent Places | examples File folder
. hardware File folder
A Libraries L java File folder
" Documents ) lib File folder
o Music . 10/13/15221PM  File folder
& Pictures portable 10/13/15 2:24 PM File folder
) Subversioy ). reference 10/13/15221PM  File folder
88 Videos )i tools 10/13/152:21PM  File folder
arduino.exe 8/28/159:32 AM Application 393 K8
«¥ Homegro 4 | arduino.Mjini 8 Configuration sett 1k8
@ arduino_debug.exe Application 390 KB
1% Computer arduino_debug. Configuration sett... 1K8
& Local Disk (C)) - Application exten 43K8
). arduino-165-r ) msvepl00.dil Application extens, 412K8
|, Perflogs ) msver100.dil Application extens. 753K
I\ Program Files ] revisions.bt Text Document 67KB
2 sketch_octl3a | Arduino 155
[File) et Sketch Tocks Help
New CrleN
Open... CleO
Open Recent »
Sketchbook » =
Eumples » Te, O run once
Close CerleW
Save CerdeS
Save As... Cirle ShifteS

Cerl+Comma

CuleQ
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10.

Copy and Paste the following link into
Additional Boards Manager URLs:
“https://www.simblee.com/package_sim-
bleebeta_index.json” then press “OK”

11.

Go to Tools > Board: > Boards Manager...

12.
Scroll down to Simblee Boards
by Simblee, and click on Install

13.

Confirm it is installed, as it should say
“INSTALLED" next to the board name

Simblee
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Sketchbook location:
shetchbook
Editor language: | System Default
Editor font size: |12
Show verbose cutput during: || compllation ukoad
Compler warnings:  None v
[7] Display ine rumbers
Enable Code Foldng
V] Verify code after upload
[7] Use external editor
[V] Check for updates on startup
[¥] Update sketch fles to new extension on save (.pde -> .ino)
V] Save when verifying or uploadng

v (requres restart of Arduino)

Manager URLs: | https://www.simblee. 3 _index.jso0| [g]
More preferences can be edted drectly i the fle
Cilarduing-1.6.5+5\portable preferences. tet
(edit only when Arduno is not running
o ] (Lcancal ]
2 sketch_oct13a | Arduino 165 [E=Ricn ===
File Edit Sketch Help
Auto Format Ctrl+ T
Archive Sketch
Skelth_oct133 b encoding & Reload
id setup() Serial Monitor Ctrl+Shift+M "
// put your
Board: "Arduino/Genuino Uno® ' Boards Manager...
} Port ! Arduino AVR Boards
toop() { Programmer: "AVRISP mkdI" ' knoie
put your Arduino/Genuino Uno

Bumn Bootloader

Arduino Duemilanove or Diecimila

2 Boards Manager

Type (A =) [Fter your seorch

Intel i686 Boards by Intel
Boards included in this package:
Edison.

More info

AMEL-Tech Boards by AMEL Technology
Boards included in this package:
SmartEverything Fox.

Qnline help

More info

Simblee Boards by Simblee
Boards included in this package:
Simblas.

More info.

2 Boards Manager

Tyve (AL v [Fiter your search

Intel 686 Boards by Intel
Boards included in this package:
Edison.

Mocg info

AMEL-Tach Boards by AMEL Technology
Boards included in this package:
SmartEverything Fox.

Qnline help

More info

Simblee Boards by Simblee version 0.0.153 INSTALLED
Boards included in this package:

Simblee.

QOnline help

More info
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1 4. @ sketch_octi3a gnoms [l o =4
File Edit Sketch [Tools| Help
Goto

Auto Format Ctrl-T
Tools > Board: > Click on Simblee ——
Fix Encoding & Reload
Serial Monitor Ctri+Shift+M .
Board: "Arduino/Genuino Uno" 1 Boards Manager...
) Port 1 Arduino AVR Boards
PO { Programmer: "AVRISP mkII* ' LT
put your ©  Arduino/Genuino Uno

Burn Bootloader

Arduino Duemilanove or Diecimila
Arduine Nano

Arduino/Genuino Mega or Mega 2560
Arduino Mega ADK

Arduine Leonardo
Arduino/Genuino Micro

Arduino Esplora

Arduino Mini

Arduine Ethemnet

Arduino Fio

Arduino BT

LilyPad Arduino USB

LilyPad Arduino

Arduino Pro or Pro Mini

Arduine NG or older

Arduino Robot Control

Arduino Robot Motor

Arduino Gemma
Simblee Boards

Simblee

1 5 . @ sketch_oct13a| Arduino 165 fol =

File Edit Sketch Tools Help

Bottom right of window should now say
Simblee on COM1 sketch_oct13a

Simbdles on COM1
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B Simblee USB Driver Installation on Windows

16.

Visit the following link:

http://www.ftdichip.com/Drivers/VCP.htm

Currently Supportted VCP Drivers

Operrating
system

Windows

Linux

Mac OS X 10.3
to 10.

Mac OS X 10.9
and above

Windows CE
4.2-5.2%%

Windows CE
6.0/7.0

(=]
0o

Windows CE 2013

-
N

2015-07-28

2009-05-14

2012-08-10

2015-04-15

2015-04-15

2012-01-06

2015-03-06

nn

2.12.06

2.2.18

1.1.0.20

mm—
No—

coo
Nk
5%

BETA

2.12.06

2.2.18

2.3

PPC

2.218

ARM

BETA

Download and install the latest drivers

for your system

18.

Simblee Hardware Setup

Using the RFD77201 (or RFD77203) and
RFD22121, stack the RFD77201 adapter on
top of the RFD22121 by aligning the pins

into the corresponding socket

19.

Plug in stacked assembly into available
USB port

Simblee
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Processor Architecture

Release Date x86 (32-bit) x64 (64-bit)

MIPSII MIPSIV SH4 Comments

2.12.06 WHQL Certified
Available as setup executable
Release Notes

Al FTDI devices now supported in Ubuntu 11.10,
kernel 3.0.0-19
Refer to TN-101 if you need a custom VCP VID/PID
in Linux

Refer to TN-105 if you need a custom VCP VID/PID
in MAC OS

This driver is signed by Apple

1.1.0.20 1.1.0.20 1.1.0.20

For use of the CAT files supplied for ARM and x86
AT builds refer to AN_319

BETA VCP Driver Support for WinCE2013

1601 Pacific Coast Hwy * Suite 290 « Hermosa Beach « CA « 90254
www.Simblee.com * Tel: 949.610.0008 * sales@simblee.com

Document - Copyright 2015 Simblee Corporation



B Selecting COM Port

20. 2 sketch_oct13s | Arduino 165 == Fo8 x|
. . File Edit Sketch (Tools) Help
With ArduinolDE open, go to Tools > Auto Format CuleT -
. Archive Sketch
Port and select COMXX (XX is the KOOI 34 i Encoding & Relosd
number of the COM port your Simblee oo yoes — o
is connected to) 1 por [ Setpons
oid locp() ; Programmer: "AVRISP mikll" o
9
PaE yous Burn Bootlosder

2 1 . @ sketch_oct13a | Arduino 165 o) e =]

File Edit Sketch Tools Help

After selecting the COM port, at the
bottom right of the Arduino IDE,
it should not say “Simblee on COMXX" RES

Simblee on COM10
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B Programming an example sketch

22. @ sketch_oct13a | Arduino 165 =3 8cE =)
[File) Edit Sketch Tools Help

Go to File > Examples > New  cuon i
SimbleeForMobile > Select Temperature e e 02.0igeal

Open Recent ! 03.Analog

Sketchbook L 04.Communication

Examples ' 05.Control

Close CtreW 06.5ensors

Save Ctrl+S 07.Display

Save As... Ctrl+ShifteS 08.5trings
09.Us8
10.StarterKit
ArduinolSP

vy v v v v v v v v w

Page Setup  Ctrl+Shift+P
Print Ctrl+P
Preferences  Ctrl-Comma

Bridge
Quit Ctil-Q Esplora
Ethernet
Firmata
GSM
LiquidCrystal
Robot Control
Robot Motor
S0
Stepper
TFT
WiFi

»
»
»
»
»
»
»
»
»
»
»
»

Servo

SimbleeAES
SimbleeAESCOM
SimbleeBLE
SimbleeCOM
SimbleeForMobile
SimbleeForMobileClient
SimbleeGZLL
SimbleeNonBLE
SimbleeRNG

SPl

ColorWheel
LedButton
Servo
Temperature

TwoScreens

v v v v O wimom o m - -

v

23. T Temperstur | Arduino 155 = en -
A new window will pop up called R

Temperature. Click on Upload E—

(insert Right Arrow Image here) e b sccept + Bsesonth tow Enercy ¢

Upload

m

oh COM10

1601 Pacific Coast Hwy * Suite 290 « Hermosa Beach « CA « 90254

] ™
S I m b I e e www.Simblee.com * Tel: 949.610.0008 * sales@simblee.com

Connecting Everyone and Everything Document - Copyright 2015 Simblee Corporation



24. D Temperature | Arduino 165 E=REcE
. . File Edit Sketch Tools Help

After uploading, the program will say

“SUCCESS" On the bOttom WIndOW Temperature

B Simblee For Mobile Installation and Use

Installing Simblee For Mobile

1. On your iOS device, open the AppStore
2. Search for “Simblee For Mobile”

3. Click on INSTALL

4. Simblee For Mobile should now be on
your home screen

Using Simblee For Mobile

1. Enable Bluetooth on your iOS device

2. Open Simblee For Mobile

3. Alist of “Found Simblees” will appear. If
you uploaded the Temperature sketch in
the previous steps, you can select it from
the list and it will generate an interface
based on the Temperature sketch.

4. The temperature sketch displays a dy-
namic graphic along with the temperature
reading of the Simblee internal sensor
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