
 

 

APPLICATION NOTE 

AT12616: Getting Started with ATSAMD10D14A 

     SMART ARM-Based Microcontrollers  

 

Objective 

 

 Get started with the ATSAMD10D14A 
(Atmel® | SMART ARM®

 Cortex®-M0+ based SAM D10 series). 

 

 Find the ATSAMD10D14A device related links in Atmel website (like 
documents, tools etc). 

 

 Get started with Atmel Studio 6.2 (project creation and demo program (GPIO 
input / output configuration) development on a step by step basis). All these 
steps are also described in Atmel Studio help system.   

  

Pre-requisites 

 

 ATSAM D10 Xplained Mini Kit 

 

 Atmel Studio 6.2 or later 
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1 Getting Started with ATSAMD10D14A 

1.1 Introduction 
 

The Atmel | SMART SAM D portfolio is architected beyond the core, using over two decades of Atmel 
microcontroller (MCU) experience to create unique, connected peripherals that work flawlessly with the ARM® 
Cortex®-M0+ CPU. These MCUs are easy-to-use and provide scalability and performance.  

 

The SAM D10 and SAM D11 are the smallest ARM Cortex-M0+ devices available from Atmel, expanding our 
product offering down to 8kB of Flash, 4kB of SRAM and 14-pin packages. All packages use only 2 pins for 
power, and the reset pin can be configured to as a GPIO, maximizing the functionality available. To help simplify 
the design process and reduce the Bill of Materials, these new Atmel families also integrate additional 
functionality, including Full Speed crystal-less USB(in SAMD11), peripheral touch controller that requires no 
external components, Event System, ADC with gain stage, DMA, timers/counters for control applications, and 
several other new features. From the SAM D10 to the SAM D21, these devices are code- and pin-compatible 
making it easy for designers to migrate up and down the family. 

 

SAMD10 and SAMD11 Device Details  
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1.2 ATSAMD10D14A Device Features  
 

 2.14 CoreMark / MHz 

 45 DMIPS (0.9375 DMIPS per MHz)  

 Flexible Clock System (8 clock sources) 

 ±  2% Calibrated Internal RC oscillator 

 Digital Frequency Locked Loop (DFLL48M) 

 Capacitor less internal regulator  

 Sleep Walking Peripherals (Asynchronous wakeup with event system) 

 High Speed bus matrix for concurrrent (bus) accesses 

 Dedicated flash area for EEPROM emulation 

 Peripheral Touch Controller (PTC) - Hardware Touch Acquistion 

 Atmel® QTouch® library support 

 
Note: For detailed information (like flash size, number of peripheral channels, module description etc) refer to the   
SAMD10 datasheet. 

1.3 Cortex M0+ Core Features 
 

 Von Neumann Architecture 

 2 Stage Pipelining 

 Micro trace buffer (Instruction trace buffer for fast debug) 

 Completely programmable in ‘C’ (even start-up code) 

 Simple memory map (Linear Addressing)  

 CMSIS (Cortex-M Software Interface Standard) - Portable Code 

1.4 Cortex M0+ Configuration for SAM D10 series devices 
 

 Single I/O Access 

 Little endian  

 SysTick Timer  

 Single Cycle 32 *32 Multiplier (Fast)  

 32 - bit Instruction Width 

 Vector Table Offset Register  

 Halting Debug  
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1.5 ATSAMD10D14A Block Diagram  

 
 

 Note: For detailed information (like module description) refer to the SAMD10 datasheet. 
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1.6 ATSAMD10D14A Device Related Website Links 
 

The ATSAMD10D14A product overview webpage (as shown below) is available at the following link 
http://www.atmel.com/devices/ATSAMD10D14A.aspx 

 

 
 

In ‘Parameters’ tab, we can find the configuration parameter details (like flash size, number of peripheral 
channels etc) for this device.  

http://www.atmel.com/devices/ATSAMD10D14A.aspx?tab=parameters 

 

In ‘Documents’ tab, we can find all the related documents (like datasheet, application notes) for this device  

http://www.atmel.com/devices/ATSAMD10D14A.aspx?tab=documents 

 

In the above link under ‘datasheet’ section there are two documents  
 
– Complete version (includes all peripheral descriptions and electrical characteristics) 

– Summary version (includes Ordering Information, pin out, and Packaging Information) 

 

http://www.atmel.com/devices/ATSAMD10D14A.aspx
http://www.atmel.com/devices/ATSAMD10D14A.aspx?tab=parameters
http://www.atmel.com/devices/ATSAMD10D14A.aspx?tab=documents
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The device related application notes (like getting started with SAMD10) and its associated firmware (if any) is 
also available in the above specified link. 

 

In ‘Applications’ tab, we can find the recommended application areas for (not limited to) for this device 

http://www.atmel.com/devices/ATSAMD10D14A.aspx?tab=applications  

In ‘Tools’ tab, we can find all the related tools (like IDE, debugger, evaluation kit) for this device 

http://www.atmel.com/devices/ATSAMD10D14A.aspx?tab=tools 

 

If we click ‘SAMD10 Xplained Mini’ from the above link then we can view the SAMD10 Xplained Mini kit’s 
overview webpage (as shown below)  

http://www.atmel.com/tools/ATSAMD10-XMINI.aspx 

1.7 SAMD10 Xplained Mini Kit 

  
 

If we click on ‘Buy Tool’ from the above link then we can purchase the same kit from our Atmel Store 

http://store.atmel.com/PartDetail.aspx?q=p:10500413 

 

http://www.atmel.com/devices/ATSAMD10D14A.aspx?tab=tools
http://www.atmel.com/tools/ATSAMD10-XMINI.aspx
http://store.atmel.com/PartDetail.aspx?q=p:10500413
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In ‘documents’ tab from the above link we can find the kit related documents like (schematic, user guide).  

http://www.atmel.com/tools/ATSAMD10-XMINI.aspx?tab=documents  

 Note: For detailed information like header and connections refer to the ATSAMD10 Xplained Mini User 
 Guide which is available at the above specified link.  

1.8 Atmel Studio  

1.8.1 Atmel Studio Webpage  
The Atmel Studio installer (free IDP) is available at the following (as shown below) link 

http://www.atmel.com/tools/ATMELSTUDIO.aspx 

1.8.2 Atmel Studio Microsite 
To learn more about Atmel Studio refer to the following micro site link 
http://www.atmel.com/microsite/atmel_studio6/ 

 

http://www.atmel.com/tools/ATSAMD10-XMINI.aspx?tab=documents
http://www.atmel.com/tools/ATMELSTUDIO.aspx
http://www.atmel.com/microsite/atmel_studio6/
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In ‘Software Library’ tab, we can find the details about Atmel Software Framework (software drivers and libraries) 
http://www.atmel.com/microsite/atmel_studio6/software.aspx 

 

In ‘Videos’ tab we can find the getting started videos (like editor, creating a new C (gcc) project, debugging AVR 
applications, debugging ARM applications etc)  

http://www.atmel.com/microsite/atmel_studio6/videos.aspx  

1.9 Connecting the ATSAMD10 Xplained Mini kit 
 
This section helps user to connect the ATSAMD10 Xplained Mini with Atmel Studio 6.2 
 

1. Download and install Atmel Studio version 6.2 or later. 

2. Launch Atmel Studio. 

3. Connect the ATSAMD10 Xplained Mini to the USB port and it will be visible in Atmel Studio.  

1.9.1 Auto board identification of ATSAMD10 Xplained Mini Kit  
 

1. Once the ATSAMD10 Xplained Mini kit is connected to the PC, the Windows® Task bar will pop-up a 
message as shown in figure.  

 Figure: ATSAMD10 Xplained Mini Driver Installation 

 

  

2. If the driver installation is proper, EDBG will be listed in the Device Manager as shown in figure. 

 Figure: Successful mEDBG Driver Installation 

 
 

http://www.atmel.com/microsite/atmel_studio6/software.aspx
http://www.atmel.com/microsite/atmel_studio6/videos.aspx
http://www.atmel.com/tools/ATMELSTUDIO.aspx
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3.  Open Atmel Studio 6.2, Go to ‘View’ -> ‘Available Atmel Tools’. The EDBG should get listed in the tools as 
 "EDBG" and the tool status should display as "Connected". This indicates that the tool is communicating 
 properly with Atmel Studio. 

 

     Figure: mEDBG under Available Atmel Tools 

 

  

1.9.2 Connect the ATSAMD10 Xplained Mini UART to the mEDBG COM Port 
 

1. Connect the mEDBG USB to the PC. 

2. Use the Device Manager to find the COM port number. 

3. Default COM port settings are 9600 baud N 8 1. The COM port settings can be changed using the Device 
Manager. 

1.10 Programming and Debugging 
 

This section helps to program and debug the ATSAMD10 Xplained Mini kit using mEDBG. 

1.10.1 Programming the ATSAMD10 Xplained Mini using mEDBG 
 

1. Connect the mEDBG USB to the PC. 

2. Go to Atmel Studio: Click Tools, select Device Programming, and select the connected mEDBG as Tool 
with Device = ATSAMD10D14AM and Interface = SWD, click Apply.  

3. Select "Memories" and locate the source hex or elf file and then click Program.  
 

1.10.2 Debugging the ATSAMD10 Xplained Mini using mEDBG 
 

1. Start Atmel Studio. 

2. Connect the mEDBG USB to the PC. 

3. Open your project. 

4. In the Project menu select the project properties page, select the Tools tab and select mEDBG as 
debugger and SWD as interface. 

5. In the Debug menu click Start Debugging and Break. 

6. A debug session is started with a break in main, debugging can start. 
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2 Creating an Example Application in Atmel Studio 
 

1. After connecting the board, to create a new project in Atmel Studio go to ‘File’ -> ‘New’ and click on 
‘Project…’ (as shown in figure 2-1) 

Figure 2-1: Creating New Project in Atmel Studio 

  
 

2. The New Project wizard will display as shown in figure 2-2 and select “GCC C executable Project” 
template and name the project as appropriately and click “OK” to get the device selection wizard. 

 

 Figure 2-2: New Project Wizard 

   
 

3. The Device Selection wizard will display as shown in figure 2-3 and select the ATSAMD10D14AM device 
from SAM D device family then click OK. 

 

Figure 2-3 Device Selection Wizard 
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4. The new project and .c file will be created as shown in figure 2-4. 

 
 Add the following code snippet (LED Control using push button) in .c file. 
   

  int main(void) 
  { 
  
   PORT->Group[0].DIRSET.reg = PORT_PA09; 
  
   while (1) 
   { 
    if (PORT->Group[0].IN.reg & PORT_PA25) 
    { 
     PORT->Group[0].OUTSET.reg = PORT_PA09; 
    } 
    else 
    { 
     PORT->Group[0].OUTCLR.reg = PORT_PA09; 
    } 
   } 
  } 
 

5. Code Explanation: 
 

 DIRSET register is used to set the port pin as output . 
 

 IN register is used to read the port pin status. 
 

 OUTSET register is used to drive the output pin as high 
 

 OUTCLR register is used to drive the output pin as low  
 

 In the above example code we use PA25 (Button) as input and PA09 (LED) as output.  
 

 We are controlling the LED based on the push button status.  
 

 As long the button is in pressed state (1) then the LED will not glow (1).  
 

 If we release the button (0) then the LED will glow (0 - default).  
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  Figure 2-4: Project Window 

 
    

6.  In order to debug this project, configure the Tool and Interface in the Project properties. To open the 
 project properties, go to ‘Project’ menu -> ‘Properties’. In the project properties, go to "Tool" tab -> Under 
 the Selected Debugger/Programmer, select the tool as "mEDBG" and interface as "SWD" as shown in 
 figure 2-5 Tool and Interface Settings. 

Figure 2-5: Tool and Interface Settings 
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7. To program and execute the application, we have two options. 
 

a. We can start a debug session on the board, where we will be able to break the code execution and 
follow the application flow. 
 

b. We can program the generated hex file into the controller and execute the application. In this case 
we will program the code with no debugging, so we select the green arrow for "Start without 
Debugging". 
 

Both these options can be done on ATSAMD10 Xplained Mini as shown in figure 2-6 and figure 2-7. 
 

Figure 2-6: Start without Debugging 

 

 

 

Figure 2-7: Start Debugging and Break 
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3 What’s Next? 
 
 Atmel Studio videos    

http://www.atmel.com/microsite/atmel_studio6/videos.aspx 
 

 Atmel Studio online help 
        http://www.atmel.com/webdoc/atmelstudio/ 
 
 Atmel Studio offline help (After installing Atmel Studio)  
 
 In Atmel Studio   

Help -> View Help (Ctrl+F1) -> Atmel Studio   
 

 ASF (Atmel Software framework) Getting Started and ASF Reference manual 
 http://www.atmel.com/tools/AVRSOFTWAREFRAMEWORK.aspx?tab=documents 
 
 ASF online documentation 
 http://asf.atmel.com/docs/latest/ 
 
 Technical documentation for various products 
 http://www.atmel.com/webdoc/ 
 
 Atmel Gallery 
 https://gallery.atmel.com/ 
 
 Production Selection Guide 
 Atmel MCU Selector on http://www.atmel.com/ 
 
 Ordering Samples 
 https://secure.atmel.com/forms/secure/verifylogin.aspx?target_url=samplestore 
 
 Buying evaluation board & kits 
 http://store.atmel.com/ 
 
 Technical Documentation 
 http://www.atmel.com/design-support/documentation/default.aspx 
 
 Knowledge Base and Technical Support/Design Support 

http://www.atmel.com/design-support/ 
 
 Collaborative workspace 
 http://spaces.atmel.com 
 
 AT91 SAM community  

http://www.at91.com / 
   

http://www.atmel.com/microsite/atmel_studio6/videos.aspx
http://www.atmel.com/webdoc/atmelstudio/
http://www.atmel.com/tools/AVRSOFTWAREFRAMEWORK.aspx?tab=documents
http://asf.atmel.com/docs/latest/
http://www.atmel.com/webdoc/
https://gallery.atmel.com/
http://www.atmel.com/
https://secure.atmel.com/forms/secure/verifylogin.aspx?target_url=samplestore
http://store.atmel.com/
http://www.atmel.com/design-support/documentation/default.aspx
http://www.atmel.com/design-support/
http://spaces.atmel.com/
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4 Revision History 
 

Doc. Rev. Date Comments 

42421A 03/2015 Initial document release  
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