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1.0 INTRODUCTION
The ENC624J600 Quick Start Guide provides a visual view of step-by-step procedures used when establishing a TCP/
IP connection between the Fast Ethernet PICtail board and the Explorer 8 development board. Detailed information is
included in the following sections: 
• Section 2.0, General Considerations
• Section 3.0, Creating a Project Using MCC and TCP/IP Lite Stack
• Section 4.0, Sending and Receiving UDP Packets
• Section 5.0, TCP Client Implementation
• Section 6.0, TCP Server Implementation
• Section 7.0, Conclusion

2.0 GENERAL CONSIDERATIONS

2.1 Required References
The ENC624J600 implementor should have the following documents on hand:
• ENC424J600/624J600 Stand-Alone 10/100 Ethernet Controller with SPI or Parallel Interface Data Sheet
• ENC424J600/624J600 ENC424J600/624J600 Silicon Errata and Data Sheet Clarification
• Fast 100 Mbps Ethernet PICtail Plus Daughter Board User’s Guide
• Explorer 8 Development Board User’s Guide
• ENC Board Schematics

2.2 Hardware Requirements and Setup
All the hardware devices mentioned in this quick start guide can be acquired using their part numbers from www.micro-
chipdirect.com. Below is a list of devices:
• Explorer 8 Development Board with power supply (DM160228)
• Fast 100 Mbps Ethernet PICtail Plus Daughter Board (AC164132)
• PIC18F87K22 PIM (MA180028)
• Ethernet cables (RJ45)
• Ethernet switch with a power supply 

2.3 Software Requirements
• MPLAB X IDE
• XC8 Compiler
• MPLAB Code Configurator (MCC)
• Wireshark Packet Analyzer 
• Microchip TCP/IP Lite Stack (AN1921 Source Code)

ENC624J600
Quick Start Guide

https://www.microchipdirect.com/
https://www.microchipdirect.com/
https://www.microchipdirect.com/
https://www.wireshark.org/#download
https://www.wireshark.org/#download
https://www.microchip.com/wwwAppNotes/AppNotes.aspx?appnote=en573940
https://www.microchip.com/wwwAppNotes/AppNotes.aspx?appnote=en573940
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2.4 Jumper Settings 

2.4.1 FOR THE EXPLORER 8 DEVELOPMENT BOARD:
• J14 – Connect to 5V power setting. 
• J2 – Move to supply 5V power to the board. 
• J7 – Connect to provide LED current path.
• J37 – Do not connect a jumper to any of the pins. 
• J45 – Connect the microcontroller SDO pin to the J32 mikroBUS MOSI.
• J46 – Connect the microcontroller SDI pin to the J32 mikroBUS MISO. 
• J47 – Connect the microcontroller SCK pin to the J32 mikroBUS SCK. 
• J31 – Configure RA4 as an I/O port. 
• J4 – Configure RA5 as an I/O port. 

2.4.2 FOR THE PICTAIL PLUS DAUGHTER BOARD:
• JP2 – Shorted by jumper shunt
• JP9 – Jumper between PSPCFG2 and GND
• JP10 – Jumper between 3V3 and PSPCFG3 
• JP11 – Jumper between PSPCFG1&4 and GND 
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3.0 CREATING A PROJECT USING MCC AND TCP/IP LITE STACK
This chapter demonstrates the generation of a basic project with the TCP/IP Lite library using MCC. 

3.1  General Procedure
Follow the steps below to start a basic project:
1. Open the MPLAB X IDE and create a new project.
2. Launch the MCC plug-in using the MCC icon in the top right corner in the MPLAB X IDE. Alternatively, MCC can 

be launched by selecting Tools>Embedded>MPLAB Code Configurator v3: Open/ Close.

3.2 System Module Configuration
1. In the Project Resources tab, select System Module. Go to Easy Setup view and change the “Oscillator Select”

to Internal RC oscillator, CLKOUT function on OSC2. (See Figure 3-1.)

FIGURE 3-1: SYSTEM MODULE 

2. Navigate to the Registers tab of the System Module in the MCC window. In the CONFIG1L register, disable the
“XINST” bit to disable the extended instruction set. (See Figure 3-2.)
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FIGURE 3-2: SYSTEM CONFIGURATION REGISTER 

3.3 Ethernet Configuration
1. Expand the Ethernet Library listed in the Device Resources tab. Double-click on the TCP/IP Lite library to add

it to the project. Similarly, add the MAC in the Ethernet library to the project. (See Figure 3-3.)

FIGURE 3-3: PROJECT RESOURCES TCIP MAC

2. In the Project Resources tab, select TCP/IP Lite module. This will display all the protocols supported by the
TCP/IP Stack. “UDP,” “DHCP,” “TCP,” and “ICMP” protocols must be checked. “IPV4” and “ARP” are always
required and are checked by default. (See Figure 3-4.)
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FIGURE 3-4: TCP/IP LITE SETUP

3. In the Project Resources tab, select MAC module. This gives the list of available MACs. Select the ENCx24J600 
and MSSP1. (See Figure 3-5.)

FIGURE 3-5: MAC SETUP
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3.4  SPI Configuration
The Master Synchronous Serial Port module (MSSP1) needs to be configured as SPI Master for accessing the
ENCx24J600. Configure the MSSP1 Easy Setup as follows:
1. Set “Mode” to SPI Master.
2. Set “Input Data Sampled” to End.
3. Set “Clock Edge” to Active to Idle.
4. Set “Clock Source” to Fosc/4.
See Figure 3-6.

FIGURE 3-6: SPI MASTER

3.5 Timer Configurations
Perform the following steps to set timer configurations: 
1. Go to Peripherals listed in the Device Resources tab. Expand Timer peripheral and double-click on TMR1 to

load the module. 
2. In the Project Resources tab, select TMR1 module. Configure the system time to 1s by doing the following:

a) Update the “Clock Source” to FOSC/4.
b) Update the “Timer Period” to 25 ms.
c) Tick “Enable Timer Interrupt.”
d) Update the “Callback Function Rate” to 40 times.

This results the timer configuration to interrupt for every 1 second. (See Figure 3-7.)

FIGURE 3-7: TMR1
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3.6 Pin Configuration
Follow these steps to configure the pins: 
1. Go to the Pin Manager: Grid [MCC] tab. Click on the pins stated in Table 3-1 as illustrated in Figure 3-8 for their

configuration.

FIGURE 3-8: PIN MANAGER GRID

2. Set the custom names for the pins as shown in the MPLAB Code Configurator tab. (See Figure 3-9.)

TABLE 3-1: PIN FUNCTION TABLE
Module in Pin 

Manager Pin Custom Name Function

MAC RB3 Not Configurable Chip select pin for the MAC
MSSP1 RC3 SCK1 Serial Clock 
MSSP1 RC4 SDI1 Serial Data In
MSSP1 RC5 SDO1 Serial Data Out 

Pin Module RB0 Button_Press Push button S1 on the Explorer 8 Board (Input)
Pin Module RD0 LED_D1 LED D1 on the Explorer 8 board (output)
Pin Module RD1 LED_D2 LED D2 on the Explorer 8 board (output)
Pin Module RD2 LED_D3 LED D3 on the Explorer 8 board (output)
Pin Module RD3 LED_D4 LED D4 on the Explorer 8 board (output)
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FIGURE 3-9: PIN MODULE CUSTOM NAME

4. Click on Generate to generate the code for the configured modules.

3.7 Programming and Wireshark
1. In the Projects tab, under sources file, double-click on “main.c”. In the file, enable global and peripheral inter-

rupts by removing the comment declaration “//”. 
(See Figure 3-10.)

FIGURE 3-10: GLOBAL AND PERIPHERAL INTERRUPTS 

2. In “main.c”, add Network_Manage() to the while(1) loop and the corresponding network.h header file. This
is required to handle the packets in the network. (See Figure 3-11.)

Note: Click on Generate even if the MPLAB X shows a warning. These warnings are handled later by modifying
the code.
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FIGURE 3-11: ADDING NETWORK MANAGE

3. Launch Wireshark. From the Capture menu, click on Options. Select an Interface from the list to which your
board and PC are connected. Click on Start for capturing the packet. (e.g. Ethernet)

4. In Wireshark, set the filter field as “Bootp I I arp I I icmp.” (See Figure 3-12.)

FIGURE 3-12: FILTER SETTINGS

5. In MPLAB X IDE, click on Clean and Build project. Select the PICkit Programmer. After a successful build, click
on Run project to program the code to the device.

6. In Wireshark, notice the DHCP packets handshake to get the device IP address and MAC address. (See
Figure 3-13.)

FIGURE 3-13: DHCP OFFER

7. In Wireshark, double-click on Offer packet. Expand Bootstrap protocol to get the device IP address. (See
Figure 3-14.)
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FIGURE 3-14: OFFER PACKET

8. On your PC, open the Command Prompt (cmd.exe) window and ping the device using its IP address with the
command. 

         ping IP Address 
         e.g.: ping 19.168.0.3
9. Check the Wireshark window to see the ICMP & ARP Request/Reply packets. (See Figure 3-15.)

FIGURE 3-15: ICMP & ARP REQUEST/REPLY PACKETS 
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4.0 SENDING AND RECEIVING UDP PACKETS
This chapter illustrates the following steps for implementing UDP packet communication:
1. Open the MPLAB X IDE and load the UDP_DEMO.X file (Refer to TCP/IP Lite Stack.).
2. Open the Windows Command Prompt on your PC and type “ipconfig” and press enter to find the IP address

of your PC.Se. (See Figure 4-1.)

FIGURE 4-1: IPCONFIG

3. Open and scroll down in the file udp_demo.c. In the UDP_DEMO_Initialization() API function, update destina-
tion IP address (value found in Step 2) and Port Number (custom value within Dynamic/Private range). (See
Figure 4-2.)

FIGURE 4-2: INITIALIZING UDP DEMO
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4. In the main.c file from the Project>Source Files, call UDP_DEMO_Initialize(). (See Figure 4-3.) 

FIGURE 4-3: CALL UDP INITIALIZE API

5. Open and scroll down the main.c file from Project>Source Files. Scroll down to while(1) loop, call the function
UDP_ DEMO_Send() to demonstrate the sending UDP packets.

6. Send the UDP packet through the following steps: 
a) Start the UDP packet.
b) Write the UDP packet. 
c) Send the UDP packet.

See Figure 4-4.

FIGURE 4-4: UDP START WRITE SEND 
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7. Navigate through the Projects>Source Files>MCC Generated Files>TCPIP Library>udpv4_port_han-

dler_table.c file. Add the “UDP_DEMO_Recv” handler to receive UDP packets on desired port, ‘65531,’
in the UDP_CallBackTable[]. (See Figure 4-5.)

FIGURE 4-5: UDP PORT NUMBER

In the same file include the UDP demo application header file udp_demo.h.
8. Open the udp_demo.c file. Scroll down to UDP_DEMO_Recv() function, add UDP library API to read the

receive UDP packet. (See Figure 4-6.)

FIGURE 4-6: UDP DEMO RECEIVE

9. Launch Wireshark. From the Capture menu, click on Options.
10. Select an interface from the list to which your board and PC are connected, click on Start for capturing the pack-

ets. e.g.: Ethernet
11. In Wireshark, set the filter field as “bootp||udp.port == 65531.” (See Figure 4-7.)

FIGURE 4-7: BOOTP_UDP_PORT_65531

12. In MPLAB IDE, from the Production menu, click on Clean and Build Project. After successful build, click on Run
from the tool bar to program the code to the board.

13. In Wireshark, notice the DHCP packets handshake to get the device IP address.
14. In Wireshark, double-click on Offer packet. Expand Bootstrap protocol to get the device IP address.
15. Open the Java application TCPIP_Demo GUI (Refer TCP/IP Lite Stack). 
16. Go to UDP tab and assign the same port number as “Port”, which was assigned in the UDP library (in step 4).

Click on the Listen button, and click on Allow Access if warning occurs. (See Figure 4-8.)

Note: Step 4 and Step 16 should use the same UDP port number. The board will be sending UDP packets to
Java application on that port.



ENC624J600

DS50002901A-page 14  2019 Microchip Technology Inc.

FIGURE 4-8: UDP GUI

17. Click the push button S1 on your board to send “Hello World” in the UDP packet. The first click issues an ARP
request to get the MAC Address of the PC. In Wireshark, open the filter field “arp,” and click on Apply to set the
filter.

18. The TCP/IP Demo GUI prints the received data. (See Figure 4-9.)

FIGURE 4-9: UDP SEND AND RECEIVE 

19. In TCP/IP Demo GUI, click on any LED buttons (1, 2, 3, or 4). Observe the corresponding LED's (D1, D2, D3, or
D4) toggle ON/OFF on the board. (See Figure 4-10.)

FIGURE 4-10: UDP LED DEMO

20. In Wireshark, observe the UDP packets sent on the port numbers from step 2 to 14. (See Figure 4-11.)

Note: Step 17 needs to be done more than twice. 
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FIGURE 4-11: UDP SENT PORT NUMBER 
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5.0 TCP CLIENT IMPLEMENTATION
This chapter shows how TCP Client communication can be implemented with the following procedure:
1. Open the MPLAB X IDE and load the TCPClientDemo.X file (Refer TCP/IP Lite Stack.). 
2. Open the Windows Command Prompt on your PC and type “ipconfig” and press <Enter> to find the IP address

of your PC.
3. Open and scroll down in the file tcp_client_demo.c. Scroll down in the source file to modify the

UDP_DEMO_Initialize() function. Update the server IP address (PC's) and port number. (See Figure 5-1.)

FIGURE 5-1: TCP CLIENT INITIALIZE

4. In the main.c file from Projects>Source Files, call UDP_DEMO_Initialize(). (See Figure 5-2.)

FIGURE 5-2: CALL TCP CLIENT INITIALIZE

5. Initialize socket by modifying function DEMO_TCP_Client() in file tcp_client_demo.c. (See Figure 5-3.)

FIGURE 5-3: INSERT SOCKET

6. Call TCP_Connect() server on port ‘65534’ once at least 2 seconds. (See Figure 5-4.)
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FIGURE 5-4: CLIENT CALL TCP SOCKET

7. In main.c, call the DEMO_TCO_Client() function to start the device as a TCP Client. (See Figure 5-5.)

FIGURE 5-5: CALL DEMO TCP CLIENT

8. From the Production menu, click on Clean and Build Project. After a successful build, click on Run from the tool
bar to program the device.

9. Open the Java application from the TCP/IP Demo GUI folder.
10. Go to the TCP Server Demo tab, assign the same port number as in Step 4; 65534. Click on the Listen button.

The status of the TCP connection is printed inside the “STATUS” text box.
11. After the connection is established, the Explorer board sends the status of the LED's in a TCP packet. Click on

the LED buttons (0, 1, 2, or 3). This will toggle LEDs (D1, D2, D3, or D4). Board STATUS can be observed on
the “Sent/Received Data” box in the GUI. 

12. Push the Disconnect button, to close the TCP Connection. A client disconnected message will appear on the
“STATUS” text box. (See Figure 5-6.)



ENC624J600

DS50002901A-page 18  2019 Microchip Technology Inc.

FIGURE 5-6: TCP CLIENT DEMO
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6.0 TCP SERVER IMPLEMENTATION
This chapter details the following steps for implementing TCP server communication:
1. Open the MPLAB X IDE and load the tcpServerDemo.X file (Refer TCP/IP Lite Stack.).
2. Insert and initialize the Socket in tcp_server_demo.c. (See Figure 6-1.)

FIGURE 6-1: TCP SERVER SOCKET INITIALIZE

3. Bind the local port of the TCP Server to Port 7. (See Figure 6-2.)

FIGURE 6-2: TCP SOCKET SERVER BIND

4. Start the TCP Server. (See Figure 6-3.)

FIGURE 6-3: TCP SERVER LISTEN

5. Call the DEMO_TCP_EchoServer() function within the while(1) loop in main.c. This allows the device to run as
a TCP Server. (See Figure 6-4.) 

FIGURE 6-4: CALL TCP ECHO SERVER

6. Launch Wireshark. From the Capture menu, click on Options.
7. Select an interface from the list to which your PC and the board are connected. Click on Start to capture packets.
8. In Wireshark, set the filter field as “bootp || tcp.port==7.” (See Figure 6-5.) 
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FIGURE 6-5: BOOTP TCP PORT 7

9. From the MPLAB IDE Production menu, click on Clean and Build Project. After successful build, click on Run
from the tool bar to program the code to device.

10. In Wireshark, notice the DHCP packet handshake to get the device IP address.
11. Double-click on Offer packet. Expand Bootstrap protocol to get the device IP address. (See Figure 6-6.)

FIGURE 6-6: TCP SERVER OFFER PACKET

12. Open the Java application from the TCP/IP Demo GUI folder.
13. Go to the TCP Client Demo tab, enter the IP address from step 12. Assign it as the Server IP address in the GUI.

Assign the same port number in step 4. Click on the Connect button.
14. The status of the TCP Connection is printed inside the “STATUS” text box. (See Figure 6-7.) 
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FIGURE 6-7: TCP CLIENT DEMO

15. After the connection is established, type text inside the “Send Text” box. Click on the Send button. The text will
be echoed and displayed inside the “Sent/Received Data” box. Notice the ECHO message is divided and sent
into 32 Bytes packets by the device.

16. Push the Disconnect button to close the TCP Connection. The “STATUS” text box indicates the connection mes-
sage.
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7.0 CONCLUSION
In summary, the basic steps for implementing UDP and TCP communication have been demonstrated in this guide. The
user can build upon this application to extend the capabilities of the ENC624J600 controller with the help of the driver
provided by the MCC.
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APPENDIX A: DOCUMENTATION CONVENTIONS
This quick start guide uses the following conventions: 

TABLE 7-1: DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial Font:
Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or dialog “Save project before build”
Underlined, italic text with right 
angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

N‘Rnnnn A number in verilog format, where N is 
the total number of digits, R is the 
radix and n is a digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New Font:
Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be any valid 
filename

Square brackets [ ] Optional arguments mcc18 [options] file [options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive argu-
ments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, var_name...]

Represents code supplied by user void main (void)
{ ...
}
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APPENDIX B: REVISION HISTORY

TABLE B-1: REVISION HISTORY
Revision Level & Date Section/Figure/Entry Correction

DS50002901A
(07-16-19)

Initial release
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THE MICROCHIP WEBSITE
Microchip provides online support via our WWW site at www.microchip.com. This website is used as a means to make
files and information easily available to customers. Accessible by using your favorite Internet browser, the website
contains the following information:
• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s 

guides and hardware support documents, latest software releases and archived software
• General Technical Support – Frequently Asked Questions (FAQ), technical support requests, online discussion 

groups, Microchip consultant program member listing
• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of 

seminars and events, listings of Microchip sales offices, distributors and factory representatives

CUSTOMER CHANGE NOTIFICATION SERVICE
Microchip’s customer notification service helps keep customers current on Microchip products. Subscribers will receive
e-mail notification whenever there are changes, updates, revisions or errata related to a specified product family or
development tool of interest.
To register, access the Microchip website at www.microchip.com. Under “Support”, click on “Customer Change Notifi-
cation” and follow the registration instructions.

CUSTOMER SUPPORT
Users of Microchip products can receive assistance through several channels:
• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support
Customers should contact their distributor, representative or Field Application Engineer (FAE) for support. Local sales
offices are also available to help customers. A listing of sales offices and locations is included in the back of this
document.
Technical support is available through the website at: http://microchip.com/support

http://www.microchip.com
http://www.microchip.com
http://www.microchip.com
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Information contained in this publication regarding device applications and the like is provided only for your convenience and may be
superseded by updates. It is your responsibility to ensure that your application meets with your specifications. MICROCHIP MAKES NO
REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR
OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE,
MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Micro-
chip devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend, indemnify and hold
harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or
otherwise, under any Microchip intellectual property rights unless otherwise stated.
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The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BesTime, BitCloud, chipKIT, chipKIT logo,
CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, HELDO, IGLOO, JukeBlox, KeeLoq, Kleer, LANCheck, LinkMD, maXStylus, maXTouch,
MediaLB, megaAVR, Microsemi, Microsemi logo, MOST, MOST logo, MPLAB, OptoLyzer, PackeTime, PIC, picoPower, PICSTART, PIC32 logo,
PolarFire, Prochip Designer, QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer, Tachyon,
TempTrackr, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip Technology Incorporated in the U.S.A. and
other countries.

APT, ClockWorks, The Embedded Control Solutions Company, EtherSynch, FlashTec, Hyper Speed Control, HyperLight Load, IntelliMOS, Libero,
motorBench, mTouch, Powermite 3, Precision Edge, ProASIC, ProASIC Plus, ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, Temux,
TimeCesium, TimeHub, TimePictra, TimeProvider, Vite, WinPath, and ZL are registered trademarks of Microchip Technology Incorporated in the
U.S.A.

Adjacent Key Suppression, AKS, Analog-for-the-Digital Age, Any Capacitor, AnyIn, AnyOut, BlueSky, BodyCom, CodeGuard,
CryptoAuthentication, CryptoAutomotive, CryptoCompanion, CryptoController, dsPICDEM, dsPICDEM.net, Dynamic Average Matching, DAM,
ECAN, EtherGREEN, In-Circuit Serial Programming, ICSP, INICnet, Inter-Chip Connectivity, JitterBlocker, KleerNet, KleerNet logo, memBrain,
Mindi, MiWi, MPASM, MPF, MPLAB Certified logo, MPLIB, MPLINK, MultiTRAK, NetDetach, Omniscient Code Generation, PICDEM, PICDEM.net,
PICkit, PICtail, PowerSmart, PureSilicon, QMatrix, REAL ICE, Ripple Blocker, SAM-ICE, Serial Quad I/O, SMART-I.S., SQI, SuperSwitcher,
SuperSwitcher II, Total Endurance, TSHARC, USBCheck, VariSense, ViewSpan, WiperLock, Wireless DNA, and ZENA are trademarks of
Microchip Technology Incorporated in the U.S.A. and other countries.

SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.
The Adaptec logo, Frequency on Demand, Silicon Storage Technology, and Symmcom are registered trademarks of Microchip Technology Inc. in
other countries.
GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip Technology Inc., in other
countries. 

All other trademarks mentioned herein are property of their respective companies.

© 2019, Microchip Technology Incorporated, All Rights Reserved.
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Note the following details of the code protection feature on Microchip devices:
• Microchip products meet the specification contained in their particular Microchip Data Sheet.

• Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the 
intended manner and under normal conditions.

• There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our 
knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data 
Sheets. Most likely, the person doing so is engaged in theft of intellectual property.

• Microchip is willing to work with the customer who is concerned about the integrity of their code.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not 
mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our
products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts
allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.

www.microchip.com/quality
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