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 AN4875
 Getting Started with the AVR® DD Family

Introduction

Author: Cristian Sabiuta, Microchip Technology Inc.

This application note outlines how to get started with the AVR® DD Family of microcontrollers.

Refer to the data sheet for further information on the differences between the AVR® DD Family devices.

Features Presented in this Document
• Getting Started with AVR® DD Family Microcontrollers and Tools
• Getting Started with AVR64DD32 Curiosity Nano and Microchip Studio 7.0
• Getting Started with AVR64DD32 Curiosity Nano and MPLAB® X
• Code Examples in GitHub
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1. Relevant Devices
This section lists the relevant devices for this document. The following figures show the different family devices,
laying out pin count variants and memory sizes:

• Vertical migration upwards is possible without code modification, as these devices are pin-compatible and
provide the same or more features

• Horizontal migration to the left reduces the pin count and, therefore, the available features
• Devices with different Flash memory sizes typically also have different SRAM and EEPROM

Figure 1-1. AVR® DD Family Overview
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2. Get the Device Data Sheet
Product pages

• AVR16DD14: www.microchip.com/en-us/product/avr16dd14
• AVR16DD20: www.microchip.com/en-us/product/avr16dd20
• AVR16DD28: www.microchip.com/en-us/product/avr16dd28
• AVR16DD32: www.microchip.com/en-us/product/avr16dd32
• AVR32DD14: www.microchip.com/en-us/product/avr32dd14
• AVR32DD20: www.microchip.com/en-us/product/avr32dd20
• AVR32DD28: www.microchip.com/en-us/product/avr32dd28
• AVR32DD32: www.microchip.com/en-us/product/avr32dd32
• AVR64DD14: www.microchip.com/en-us/product/avr64dd14
• AVR64DD20: www.microchip.com/en-us/product/avr64dd20
• AVR64DD28: www.microchip.com/en-us/product/avr64dd28
• AVR64DD32: www.microchip.com/en-us/product/avr64dd32

Documents

• AVR DD Product Brief (.pdf)
• AVR64DD28/32 Data Sheet (.pdf)
• AVR64DD28/32 Silicon Errata and Data Sheet Clarifications (.pdf)
• AVR64DD14/20 Data Sheet (.pdf)
• AVR64DD14/20 Silicon Errata and Data Sheet Clarifications (.pdf)
• AVR16/32DD28/32 Data Sheet (.pdf)
• AVR16/32DD28/32 Silicon Errata and Data Sheet Clarifications (.pdf)
• AVR16/32DD14/20 Data Sheet (.pdf)
• AVR16/32DD14/20 Silicon Errata and Data Sheet Clarifications (.pdf)

The documentation for the AVR® DD Family is split into two document types:

• Data sheet(1) (includes device description, number of peripherals, pinout and electrical characteristics)
• Errata (includes known errata for the device)

Note: 
1. For devices that are future products, the product brief is available instead of the data sheet.

https://www.microchip.com/en-us/product/avr16dd14
https://www.microchip.com/en-us/product/avr16dd20
https://www.microchip.com/en-us/product/avr16dd28
https://www.microchip.com/en-us/product/avr16dd32
https://www.microchip.com/en-us/product/avr32dd14
https://www.microchip.com/en-us/product/avr32dd20
https://www.microchip.com/en-us/product/avr32dd28
https://www.microchip.com/en-us/product/avr32dd32
https://www.microchip.com/en-us/product/avr64dd14
https://www.microchip.com/en-us/product/avr64dd20
https://www.microchip.com/en-us/product/avr64dd28
https://www.microchip.com/en-us/product/avr64dd32
https://ww1.microchip.com/downloads/en/DeviceDoc/AVR-DD-Product-Brief-DS40002215A.pdf
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/DataSheets/AVR64DD32-28-Prelim-DataSheet-DS40002315B.pdf
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/Errata/AVR64DD32-28-SilConErrataClarif-DS80001019A.pdf
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/DataSheets/AVR64DD-14-20-Prelim-DataSheet-DS40002444.pdf
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/Errata/AVR64DD14-20-SilConErrataClarif-DS80001052.pdf
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/DataSheets/AVR16-32DD28-32-DataSheet-DS40002441.pdf
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/Errata/AVR16-32DD28-32-SilConErrataClarif-DS80001050.pdf
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/DataSheets/AVR32-16DD20-14-Prel-DataSheet-DS40002413.pdf
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/Errata/AVR32-16DD20-14-SilConErrataClarif-DS80001026.pdf
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3. Relevant Documents
All relevant documents can be found under the documentation tab on the product page.

Below is a list of documents relevant to the AVR® DD Family Microcontrollers.

Table 3-1. Tech Briefs

Publication GitHub Code Examples

TB3287 - Getting Started with Multi Voltage I/O (MVIO) getting-started-with-mvio

TB3272 - Getting Started with High Frequency Crystal Oscillator (XOSCHF) getting-started-with-xoschf

Table 3-2. Code Examples

GitHub Code Example

Getting Started Applications

Curiosity Nano Out-of-the-Box Application

Quadrature Decoder

Button Matrix Driver

Pin Multiplexing Applications

Using USART in RS485 Mode

Neopixel Application

https://www.microchip.com/DS90003287
https://github.com/search?q=topic%3Aavr-db+topic%3Agetting-started-with-mvio+org%3Amicrochip-pic-avr-examples
https://www.microchip.com/DS90003272
https://github.com/search?q=topic%3Aavr-db+topic%3Agetting-started-with-xoschf+org%3Amicrochip-pic-avr-examples
https://github.com/orgs/microchip-pic-avr-examples/repositories?q=getting+started+avr+dd
https://github.com/microchip-pic-avr-examples/avr64dd32-cnano-out-of-the-box-code-mplab-mcc
https://github.com/microchip-pic-avr-examples/avr64dd32-quadrature-decoder-mplab-mcc
https://github.com/microchip-pic-avr-examples/avr64dd32-getting-started-with-button-matrix-mplabx-mcc
https://github.com/microchip-pic-avr-examples/avr64dd32-pin-multiplexing-mplab-mcc
https://github.com/microchip-pic-avr-examples/avr64dd32-usart-rs485-mplabx
https://github.com/microchip-pic-avr-examples/avr64dd32-cnano-neopixels-mplab-mcc
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4. Get the Tools
Microchip Studio 7.0, which uses the GCC compiler, can be utilized as an IDE to get started with AVR® DD Family.

MPLAB® X, which uses the GCC or XC8 compiler, can be utilized as an IDE to get started with AVR® DD Family.

4.1 Get the AVR64DD32 Curiosity Nano Evaluation Kit

Web page: www.microchip.com/en-us/development-tool/EV72Y42A

Get the kit: www.microchipdirect.com/dev-tools/EV72Y42A?allDevTools=true

Document/file:
• AVR64DD32 Curiosity Nano (.pdf)

Key Features

• AVR64DD32 Microcontroller
• One Yellow User LED
• One Mechanical User Switch
• Footprints for 32.768 kHz and 16.0 MHz Crystals
• On-Board Debugger:

– Board identification in Microchip Studio/ MPLAB® X
– One green power and status LED
– Programming and debugging
– Virtual COM port (CDC)
– Two logic analyzer channels (DGI GPIO)

• USB Powered
• Adjustable Target Voltage:

– MIC5353 LDO regulator controlled by the on-board debugger
– 1.8-5.1 V output voltage (limited by USB input voltage)
– 500 mA maximum output current (limited by ambient temperature and output voltage)

The AVR64DD32 Curiosity Nano user guide covers how to power the kit and the detailed information on-board
components, extension interface, and the hardware guide.

https://www.microchip.com/en-us/development-tool/EV72Y42A
https://www.microchipdirect.com/dev-tools/EV72Y42A?allDevTools=true
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4.2 Get Code Examples from GitHub
The code examples are available through GitHub, a web-based server that provides the application codes through a
Graphical User Interface (GUI). The code examples can be opened in both Microchip Studio and MPLAB X. To open
the Microchip Studio project in MPLAB X, select from the menu File → Import → Microchip Studio Project and
navigate to the .cproj file.

The GitHub webpage: GitHub.

Code Examples

Finding code examples for devices in the AVR DD Family can be done by searching for the device name, e.g.,
AVR64DD32, in the GitHub example browser.

View Code Examples on GitHub
Click to browse repositories

Download the code as a .zip file from the example page on GitHub by clicking the Clone or download button.

4.3 Get MPLAB® X
Webpage: MPLAB® X IDE

Document/file:
• MPLAB X

MPLAB X can be utilized as an IDE for developing and debugging firmware for the AVR® DD Family.

For device support, refer to 4.4.  Get Device Support for MPLAB X.

4.4 Get Device Support for MPLAB® X
MPLAB X: Support for new devices in MPLAB X can be added by using the MPLAB Pack Manager, which is found
under Tools → Packs.

For the AVR® DD Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For the AVR® DD Family, select the latest available version of AVR-Dx_DFP.
3. Click Install.

For offline installers, go to packs.download.microchip.com/. To install a package, double click on the installer file and
follow the instructions. Any open MPLAB X window will have to be closed for the installation to take effect.

4.5 Get MPLAB® Code Configurator
Webpage: MPLAB® Code Configurator

Document/file:
• MCC

MPLAB® Code Configurator can be utilized from within MPLAB® X IDE as a graphical programming interface that
generates peripherals and libraries code for the AVR® DD Family.

4.6 Get Microchip Studio 7.0
Webpage: Microchip Studio

https://github.com/
https://github.com/orgs/microchip-pic-avr-examples/repositories?q=avr+dd&type=all&language=&sort=
https://www.microchip.com/mplab/mplab-x-ide
https://packs.download.microchip.com/
https://www.microchip.com/mplab/mplab-code-configurator
https://www.microchip.com/en-us/development-tool/microchip-studio
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Document/file:
• Microchip Studio for AVR and SAM Devices 7.0 Installer (.exe)

Microchip Studio 7.0 1.0.18 or later is the preferred IDE for developing and debugging firmware for the AVR® DD
Family.

For device support, refer to 4.7.  Get Device Support for Microchip Studio.

4.7 Get Device Support for Microchip Studio
Microchip Studio: Support for new devices in Microchip Studio can be added by using the Device Pack Manager,
which is found under Tools → Device Pack Manager.

For the AVR® DD Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For AVR® DD Family, select the latest available version of AVR-Dx_DFP.
3. Click Install.

For offline installers, go to packs.download.atmel.com/. To install a package, double click on the installer file and
follow the instructions. Any open Microchip Studio window will have to be closed for the installation to take effect.

IAR™: Support for new devices in IAR Embedded Workbench can be added by installing the latest service pack.
The service pack is available at My Pages on https://iar.com (MyPages is available for users with registered IAR™

licenses, using the same email address that was used to register the license).

4.8 Get IAR Embedded Workbench® for AVR®
Webpage: https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR

Document/file: IAR Embedded Workbench installer for AVR®.

http://packs.download.atmel.com/
https://www.iar.com/
https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR
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5. MPLAB® X Users Getting Started

5.1 MPLAB® X with AVR64DD32 Curiosity Nano
Prerequisites

• MPLAB X installed

Workflow

1. Launch MPLAB X.
2. The page shown in Figure 5-1 will appear when AVR64DD32 Curiosity Nano is connected to MPLAB X.

Figure 5-1. AVR64DD32 Curiosity Nano Page in MPLAB® X

3. Start creating a new project by clicking File → New Project... or by using the Ctrl+Shift+N shortcut, as shown
in Figure 5-2.
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Figure 5-2. Create New Project in MPLAB® X

4. Select the Categories → Microchip Embedded and Projects → Standalone Project template from Figure
5-6, and click Next.
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Figure 5-3. New Project Window

5. Select AVR64DD32 (see Figure 5-4) and click Next.
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Figure 5-4. Device Selection Window

Then select the board and the desired compiler, if there are any.
6. Type in the name of the project (e.g., LED_TOGGLE) and the project location (e.g., C:\microchip), and click

Finish.
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Figure 5-5. Project Name and Location Selection Window

7. Create a new main.c file by clicking File → New File... or by using Ctrl+N shortcut, as shown in Figure 5-6.
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Figure 5-6. Create a New File in MPLAB® X

8. Select the Categories → C and File Types → C Main File template from Figure 5-7, and click Next.
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Figure 5-7. New File Window

9. Type in the name of the file (e.g., main) and click Finish.
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Figure 5-8. File Name Window

10. Replace the main.c file with the following code snippet:

int main (void)
{
  /* Configure SW0 as input */
  PORTF.DIRCLR = PIN6_bm;

  /* Configure LED0 pin as output */
  PORTF.DIRSET = PIN5_bm;

  /* Enable the internal pull-up for SW0 */
  PORTF.PIN6CTRL |= PORT_PULLUPEN_bm;
    
  while (1)
  {
    /* Check the status of SW0 */
    /* 0: Pressed */
    if (!(PORTF.IN & (PIN6_bm)))
    {
      /* LED0  on */
      PORTF.OUTCLR = PIN5_bm;
    }
    /* 1: Released */
    else
    {
      /* LED0 off */
      PORTF.OUTSET = PIN5_bm;
    }
  }
}

Add #inlude<avr/io.h> in main.c. In the code editor, the code will appear as shown in Figure 5-9.
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Figure 5-9. Code Editor Window

11. Build the code by clicking on Production → Clean and Build Main Project or by using the Shift + F11
shortcut.

12. Verify that LED0 is lit when SW0 is pushed on the AVR64DD32 Curiosity Nano.
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6. What's Next
For further information on related AVR products and IDE, refer to the links below:

Software:
• Microchip Studio
• Microchip Studio help: Help → View Help (shortcut CTRL+F1)
• Microchip Gallery
• MPLAB X
• IAR Embedded Workbench for AVR: Go to www.iar.com, search for "AVR".

Firmware:
• GitHub examples

Hardware:
• AN2519: AVR Microcontroller Hardware Design Considerations
• AVR IBIS files
• AVR BDSL files

• Atmel-ICE:
– User Guide
– Buy

• Power Debugger:
– User Guide
– Buy

• MPLAB Snap:
– Buy

• MPLAB PICkit® 4:
– Buy

Other:
• AVR Freaks®: www.avrfreaks.net/
• Application notes:

www.microchip.com/paramChartSearch/chart.aspx?branchID=30047

Find the preferred device and go to the product page. All relevant application notes can be found under the
documentation tab.

• AVR product selector:
www.microchip.com/paramChartSearch/chart.aspx?branchID=30047

• More online technical documentation concerning various products: onlinedocs.microchip.com/
• Microchip Technical Support: microchipsupport.force.com/s/

https://www.microchip.com/en-us/development-tool/microchip-studio
https://gallery.microchip.com/
https://www.microchip.com/mplab/mplab-x-ide
https://www.iar.com
https://github.com/search?q=attiny1627+user:microchiptech+user:microchip-pic-avr-examples&type=Repositories
https://www.microchip.com/DS00002519
http://www.microchip.com/doclisting/TechDoc.aspx?type=IBIS
http://www.microchip.com/doclisting/TechDoc.aspx?type=BSDL
http://www.microchip.com/DS50002999
https://www.microchipdirect.com/product/search/all/ATATMEL-ICE
https://www.microchip.com/DS40002201
https://www.microchipdirect.com/product/search/all/ATPOWERDEBUGGER
https://www.microchipdirect.com/dev-tools/PG164100
https://www.microchip.com/developmenttools/ProductDetails/PG164140
http://www.avrfreaks.net/
http://www.microchip.com/paramChartSearch/chart.aspx?branchID=30047
http://www.microchip.com/paramChartSearch/chart.aspx?branchID=30047
https://onlinedocs.microchip.com/
https://microchipsupport.force.com/s/
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7. Revision History
Doc. Rev. Date Comments

A 02/2023 Initial document release
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Microchip Information

The Microchip Website
Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service
Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support
Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature
Note the following details of the code protection feature on Microchip products:

• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner, within operating

specifications, and under normal conditions.
• Microchip values and aggressively protects its intellectual property rights. Attempts to breach the code

protection features of Microchip product is strictly prohibited and may violate the Digital Millennium Copyright
Act.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its code. Code
protection does not mean that we are guaranteeing the product is “unbreakable”. Code protection is constantly
evolving. Microchip is committed to continuously improving the code protection features of our products.

Legal Notice
This publication and the information herein may be used only with Microchip products, including to design, test,
and integrate Microchip products with your application. Use of this information in any other manner violates these
terms. Information regarding device applications is provided only for your convenience and may be superseded

https://www.microchip.com/
https://www.microchip.com/pcn
https://www.microchip.com/support
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by updates. It is your responsibility to ensure that your application meets with your specifications. Contact your
local Microchip sales office for additional support or, obtain additional support at www.microchip.com/en-us/support/
design-help/client-support-services.

THIS INFORMATION IS PROVIDED BY MICROCHIP "AS IS". MICROCHIP MAKES NO REPRESENTATIONS
OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY
OR OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR PURPOSE,
OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL, OR
CONSEQUENTIAL LOSS, DAMAGE, COST, OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP'S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR ITS USE
WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO MICROCHIP FOR
THE INFORMATION.

Use of Microchip devices in life support and/or safety applications is entirely at the buyer's risk, and the buyer agrees
to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting
from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights
unless otherwise stated.
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Quality Management System
For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.
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