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Introduction

Author: Martin Thomaz, Microchip Technology Inc.

This application note outlines how to get started with the AVR® DB Family of microcontrollers.

Refer to the data sheet for further information on the differences between the AVR® DB Family devices.

Features Presented in this Document
• Getting Started with AVR® DB Family Microcontrollers and Tools
• Getting Started with AVR128DB48 Curiosity Nano and Atmel Studio 7.0
• Getting Started with AVR128DB48 Curiosity Nano and MPLAB® X
• Code Examples in Atmel START and GitHub
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1. Relevant Devices
This section lists the relevant devices for this document. The following figures show the different family devices,
laying out pin count variants and memory sizes:

• Vertical migration upwards is possible without code modification, as these devices are pin-compatible and
provide the same or more features

• Horizontal migration to the left reduces the pin count and, therefore, the available features
• Devices with different Flash memory sizes typically also have different SRAM and EEPROM

Figure 1-1. AVR® DB Family Overview
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2. Get the Device Data Sheet
Product pages

• AVR32DB28: www.microchip.com/wwwproducts/en/AVR32DB28
• AVR32DB32: www.microchip.com/wwwproducts/en/AVR32DB32
• AVR32DB48: www.microchip.com/wwwproducts/en/AVR32DB48
• AVR64DB28: www.microchip.com/wwwproducts/en/AVR64DB28
• AVR64DB32: www.microchip.com/wwwproducts/en/AVR64DB32
• AVR64DB48: www.microchip.com/wwwproducts/en/AVR64DB48
• AVR64DB64: www.microchip.com/wwwproducts/en/AVR64DB64
• AVR128DB28: www.microchip.com/wwwproducts/en/AVR128DB28
• AVR128DB32: www.microchip.com/wwwproducts/en/AVR128DB32
• AVR128DB48: www.microchip.com/wwwproducts/en/AVR128DB48
• AVR128DB64: www.microchip.com/wwwproducts/en/AVR128DB64

Documents

• AVR DB Product Brief (.pdf)
• AVR128DB Data Sheet (.pdf)
• AVR128DB Silicon Errata and Data Sheet Clarifications (.pdf)

The documentation for the AVR® DB Family is split into two document types:

• Data sheet(1) (includes device description, number of peripherals, pinout and electrical characteristics)
• Errata (includes known errata for the device)

Note: 
1. For devices that are future products, the product brief is available instead of the data sheet.
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3. Relevant Documents
All relevant documents can be found under the documentation tab on the product page.

Below is a list of documents relevant to the AVR® DB Family Microcontrollers.

Table 3-1. Tech Briefs

Publication GitHub Code Examples

TB3286 - Getting Started with Analog Signal Conditioning (OPAMP) getting-started-with-opamp

TB3287 - Getting Started with Multi Voltage I/O (MVIO) getting-started-with-mvio

TB3272 - Getting Started with High Frequency Crystal Oscillator (XOSCHF) getting-started-with-xoschf

Table 3-2. Application Notes

Publication GitHub Code Examples

AN3636 - Using the Internal OPAMP as Regulated Power Supply for MVIO using-opamp-as-a-regulated-
power-supply

AN3633 - Gain and Offset Calibration of the Analog Signal Conditioning (OPAMP)
Peripheral

opamp-gain-and-offset-
calibration

AN3632 - Constant-Current Driver Using the Analog Signal Conditioning
(OPAMP) Peripheral

constant-current-driver-using-
opamp

AN3631 - Low-BOM Microphone Interface Using the Analog Signal Conditioning
(OPAMP) Peripheral

low-bom-mic-interface-using-
opamp

AVR128DB CNANO OPAMP demo Firmware cnano-opamp-demo-fw

Table 3-3. Opamp Model and MINDI Simulations

Opamp Models and MINDI® Schematics

avrdb-opamp-mindi-direct-connection

avrdb-opamp-mindi-voltage-follower

avrdb-opamp-mindi-non-inverting-pga

avrdb-opamp-mindi-inverting-pga

avrdb-opamp-mindi-integrator

avrdb-opamp-mindi-differential-amplifier

avrdb-opamp-mindi-dual-cascaded-non-inverting-pga

avrdb-opamp-mindi-dual-cascaded-inverting-pga

avrdb-opamp-mindi-triple-cascaded-non-inverting-pga

avrdb-opamp-mindi-triple-cascaded-inverting-pga

avrdb-opamp-mindi-instrumentation-amplifier
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4. Get the Tools
Atmel Studio 7.0, which uses the GCC compiler, can be utilized as an IDE to get started with AVR® DB Family.

MPLAB® X, which uses the GCC or XC8 compiler, can be utilized as an IDE to get started with AVR® DB Family.

4.1 Get the AVR128DB48 Curiosity Nano Evaluation Kit
User 

Switch
User LED

(LED0)
AVR128DB48

MCU
32.768 kHz 

Crystal
16.00 MHz

Crystal
DebuggerPower/

Status
Micro-USB
Connector

VDDIO2 MVIO 
Pins

Web page: www.microchip.com/developmenttools/productdetails.aspx?partno=EV35L43A

Get the kit: www.microchipdirect.com/ProductSearch.aspx?Keywords=EV35L43A

Document/file:
• AVR128DB48 Curiosity Nano (.pdf)

Key Features

• AVR128DB48 Microcontroller
• One Yellow User LED
• One Mechanical User Switch
• Footprints for 32.768 kHz and 16.0 MHz Crystals
• On-Board Debugger:

– Board identification in Atmel Studio/Microchip MPLAB® X
– One green power and status LED
– Programming and debugging
– Virtual COM port (CDC)
– Two logic analyzer channels (DGI GPIO)

• USB Powered
• Adjustable Target Voltage:

– MIC5353 LDO regulator controlled by the on-board debugger
– 1.8-5.1 V output voltage (limited by USB input voltage)
– 500 mA maximum output current (limited by ambient temperature and output voltage)

The AVR128DB48 Curiosity Nano user guide covers how to power the kit and the detailed information on-board
components, extension interface, and the hardware guide.

4.2 Get Code Examples from Atmel START
The code examples are available through Atmel START, which is a web-based tool that enables the configuration of
the application code through a Graphical User Interface (GUI). The code can be downloaded for Atmel Studio
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MPLAB X and IAR Embedded Workbench® via the direct example code link below or the Browse Examples button
on the Atmel START front page.

The Atmel START webpage: Atmel START.

Code Examples

Finding code examples for devices in the AVR DB Family can be done by searching for the device name, e.g.,
AVR128DB48, in the Atmel START example browser.

Click User Guide in Atmel START for details and information about example projects. The User Guide button can be
found in the example browser, and by clicking the project name in the dashboard view within the Atmel START
project configurator.

Atmel Studio

Download the code as a .atzip file for Atmel Studio from the example browser in Atmel START by clicking
Download Selected example. To download the file from within Atmel START, click Export project followed by
Download pack.

Double click the downloaded .atzip file, and the project will be imported to Atmel Studio 7.0.

MPLAB® X

Download the code as an .atzip file for MPLAB X IDE from within Atmel START by clicking Export project
followed by Download pack.

To open the Atmel START example in MPLAB X, select from the menu in MPLAB X, File > Import > START MPLAB
Project and navigate to the .atzip file.

IAR Embedded Workbench®

For information on how to import the project in IAR Embedded Workbench, open the Atmel START User Guide,
select Using Atmel Start Output in External Tools, and IAR Embedded Workbench. A link to the Atmel START
User Guide can be found by clicking Help from the Atmel START front page or Help And Support within the project
configurator, both located in the upper right corner of the page.

4.3 Get Code Examples from GitHub
The code examples are available through GitHub, which is a web-based server that provides the application codes
through a Graphical User Interface (GUI). The code examples can be opened in both Atmel Studio and MPLAB X. To
open the Atmel Studio project in MPLAB X, select from the menu in MPLAB X, File > Import > Atmel Studio Project
and navigate to .cproj file.

The GitHub webpage: GitHub.

Code Examples

Finding code examples for devices in the AVR DB Family can be done by searching for the device name, e.g.,
AVR128DB48, in the GitHub example browser.

View Code Examples on GitHub
Click to browse repositories

Download the code as a .zip file from the example page on GitHub by clicking the Clone or download button.

4.4 Get Atmel Studio 7.0
Webpage: www.microchip.com/development-tools/atmel-studio-7

Document/file:
• Atmel Studio 7.0 Installer (.exe)

 AN3634
Get the Tools

© 2020 Microchip Technology Inc.  Application Note DS00003634B-page 7

https://www.microchip.com/start
http://ww1.microchip.com/downloads/en/DeviceDoc/Atmel-START-User-Guide-DS50002793A.pdf
https://github.com/
https://github.com/search?q=topic%3Aavr-db+org%3Amicrochip-pic-avr-examples
https://www.microchip.com/development-tools/atmel-studio-7


Atmel Studio 7.0 1.0.18 or later is the preferred IDE for developing and debugging firmware for the AVR® DB Family.

For device support, refer to 4.5  Get Device Support for Atmel Studio.

4.5 Get Device Support for Atmel Studio
Atmel Studio: Support for new devices in Atmel Studio can be added by using the Device Pack Manager, which is
found under Tools → Device Pack Manager.

For the AVR® DB Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For AVR® DB Family, select the latest available version of AVR-Dx_DFP.
3. Click Install.

For offline installers, go to packs.download.atmel.com/. To install a package, double click on the installer file and
follow the instructions. Any open Atmel Studio window will have to be closed for the installation to take effect.

IAR™: Support for new devices in IAR Embedded Workbench can be added by installing the latest service package.
The service package is available at My Pages on https://iar.com.

4.6 Get MPLAB® X
Webpage: MPLAB® X IDE

Document/file:
• MPLAB X

MPLAB X can be utilized as an IDE for developing and debugging firmware for the AVR® DB Family.

For device support, refer to 4.7  Get Device Support for MPLAB X.

4.7 Get Device Support for MPLAB® X
MPLAB X: Support for new devices in MPLAB X can be added by using the MPLAB Pack Manager, which is found
under Tools → Packs.

For the AVR® DB Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For the AVR® DB Family, select the latest available version of AVR-Dx_DFP.
3. Click Install.

For offline installers, go to packs.download.microchip.com/. To install a package, double click on the installer file and
follow the instructions. Any open MPLAB X window will have to be closed for the installation to take effect.

4.8 Get MPLAB® Code Configurator
Webpage: MPLAB® Code Configurator

Document/file:
• MCC

MPLAB® Code Configurator can be utilized from within MPLAB® X IDE as a graphical programming interface that
generates peripherals and libraries code for the AVR® DB Family.

4.9 Get IAR Embedded Workbench® for AVR®
Webpage: https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR

Document/file: IAR Embedded Workbench installer for AVR®.
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5. Atmel Studio Users Getting Started

5.1 Atmel Studio with AVR128DB48 Curiosity Nano
Prerequisites

• Atmel Studio 7.0.2397 or later installed
• The AVR128DB48 Curiosity Nano Board connected to Atmel Studio 7.0 via the on-board USB connector, which

is connected to the embedded debugger. The kit will be powered by the USB, and the embedded debugger will
enable debugging and programming via the USB.

Workflow

1. Launch Atmel Studio 7.0.
2. The page shown below will appear when AVR128DB48 Curiosity Nano is connected to Atmel Studio 7.0.

Figure 5-1. AVR128DB48 Curiosity Nano Page in Atmel Studio

3. Start creating a new project by clicking New → Project... or by using Ctrl+Shift+N shortcut, as shown in 
Figure 5-2.
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Figure 5-2. Create New Project in Atmel Studio

4. Select the GCC C Executable Project template, as shown in Figure 5-3, type in the name of the solution and
project (e.g., GETTING_STARTED and LED_TOGGLE), and click OK.
Figure 5-3. New Project Wizard

5. Select AVR128DB48 as shown in Figure 5-4, and click OK.
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Figure 5-4. Device Selection Wizard

A new project with a main.c file associated will be generated in Atmel Studio.
6. Replace the main.c file with the following code snippet:

int main (void)
{
  /* Configure SW0 as input */
  PORTB.DIRCLR = PIN2_bm;

  /* Configure LED0 pin as output */
  PORTB.DIRSET = PIN3_bm;

  /* Enable the internal pull-up for SW0 */
  PORTB.PIN2CTRL |= PORT_PULLUPEN_bm;
    
  while (1)
  {
    /* Check the status of SW0 */
    /* 0: Pressed */
    if (!(PORTB.IN & (PIN2_bm)))
    {
      /* LED0  on */
      PORTB.OUTSET = PIN3_bm;
    }
    /* 1: Released */
    else
    {
      /* LED0 off */
      PORTB.OUTCLR = PIN3_bm;
    }
  }
}

In the code editor, the code will appear, as shown in Figure 5-5.
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Figure 5-5. Code Editor Window

7. Open project properties by clicking Project → Properties or by using the ALT+F7 shortcut.
8. In the Tool view (see Figure 5-6), set Selected debugger/programmer to nEDBG and Interface to UPDI.
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Figure 5-6. Debugger and Interface for AVR128DB48

9. Build the project by clicking Build → Build Solution or by using the F7 shortcut.
10. Program AVR128DB48 with the project code and start debugging by clicking Debug → Start debugging and

break or by using the ALT+F5 shortcut. The application is programmed onto the device, and program
execution will break in main() function.

11. Run the code by clicking Debug → Continue or by using the F5 shortcut .
12. Verify that LED0 is lit when SW0 is pushed on the AVR128DB48 Curiosity Nano.

 AN3634
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6. MPLAB® X Users Getting Started

6.1 MPLAB® X with AVR128DB48 Curiosity Nano
Prerequisites

• MPLAB X installed
• The AVR128DB48 Curiosity Nano Board connected to MPLAB X via the on-board USB connector, which is

connected to the embedded debugger. The kit will be powered by the USB, and the embedded debugger will
enable debugging and programming via the USB.

Workflow

1. Launch MPLAB X.
2. The page shown in Figure 6-1 will appear when AVR128DB48 Curiosity Nano is connected to MPLAB X.

Figure 6-1. AVR128DB48 Curiosity Nano Page in MPLAB® X

3. Start creating a new project by clicking File → New Project... or by using Ctrl+Shift+N shortcut, as shown in 
Figure 6-2.
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Figure 6-2. Create New Project in MPLAB® X

4. Select the Categories → Microchip Embedded and Projects → Standalone Project template from Figure
6-6, and click Next.
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Figure 6-3. New Project Window

5. Select AVR128DB48 (see Figure 6-4) and click Next.
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Figure 6-4. Device Selection Window

Then select the board and the desired compiler, if there are any.
6. Type in the name of the project (e.g., LED_TOGGLE) and the project location (e.g., C:\microchip), and click

Finish.
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Figure 6-5. Project Name and Location Selection Window

7. Create a new main.c file by clicking File → New File... or by using Ctrl+N shortcut, as shown in Figure 6-6.
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Figure 6-6. Create a New File in MPLAB® X

8. Select the Categories → C and File Types → C Main File template from Figure 6-7, and click Next.
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Figure 6-7. New File Window

9. Type in the name of the file (e.g., main) and click Finish.
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Figure 6-8. File Name Window

10. Replace the main.c file with the following code snippet:

int main (void)
{
  /* Configure SW0 as input */
  PORTB.DIRCLR = PIN2_bm;

  /* Configure LED0 pin as output */
  PORTB.DIRSET = PIN3_bm;

  /* Enable the internal pull-up for SW0 */
  PORTB.PIN2CTRL |= PORT_PULLUPEN_bm;
    
  while (1)
  {
    /* Check the status of SW0 */
    /* 0: Pressed */
    if (!(PORTB.IN & (PIN2_bm)))
    {
      /* LED0  on */
      PORTB.OUTSET = PIN3_bm;
    }
    /* 1: Released */
    else
    {
      /* LED0 off */
      PORTB.OUTCLR = PIN3_bm;
    }
  }
}

Add #inlude<avr/io.h> in main.c. In the code editor, the code will appear as shown in Figure 6-9.
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Figure 6-9. Code Editor Window

11. Build the code by clicking on Production → Clean and Build Main Project or by using the Shift + F11
shortcut.

12. Program AVR128DB48 with the project code and start debugging by clicking Debug → Debugging Main
Project.

13. Verify that LED0 is lit when SW0 is pushed on the AVR128DB48 Curiosity Nano.
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7. What's Next
For further information on related AVR products and IDE, refer to the links below:

Software:
• Atmel Studio
• Atmel Studio help: Help → View Help (shortcut CTRL+F1)
• Microchip Gallery
• MPLAB X

• IAR Embedded Workbench for AVR :www.iar.com/iar-embedded-workbench/#!?architecture=AVR

Firmware:
• Atmel START documentation
• Atmel START examples
• GitHub examples

Hardware:
• AVR042: AVR Hardware Design Considerations
• AVR IBIS files
• AVR BDSL files

Recommended Programming/Debugging Tools:
• Atmel-ICE:

– User Guide
– Buy

• Power Debugger:
– User Guide
– Buy

• MPALB Snap:
– Buy

• MPLAB PICkit® 4:
– Buy

Other:
• AVR Freaks®: www.avrfreaks.net/
• Application notes: www.microchip.com/paramChartSearch/chart.aspx?branchID=30047, find the preferred

device, and go to the product page. All relevant application notes can be found under the documentation tab.
• AVR product selector: www.microchip.com/paramChartSearch/chart.aspx?branchID=30047
• More technical documentation concerning various products: https://www.microchip.com/webdoc
• Microchip Technical Support: www.microchip.com/support/hottopics.aspx
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http://www.microchip.com/paramChartSearch/chart.aspx?branchID=30047
https://www.microchip.com/webdoc
http://www.microchip.com/support/hottopics.aspx
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The Microchip Website

Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner and under normal

conditions.
• There are dishonest and possibly illegal methods being used in attempts to breach the code protection features

of the Microchip devices. We believe that these methods require using the Microchip products in a manner
outside the operating specifications contained in Microchip’s Data Sheets. Attempts to breach these code
protection features, most likely, cannot be accomplished without violating Microchip’s intellectual property rights.

• Microchip is willing to work with any customer who is concerned about the integrity of its code.
• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its code. Code

protection does not mean that we are guaranteeing the product is “unbreakable.” Code protection is constantly
evolving. We at Microchip are committed to continuously improving the code protection features of our products.
Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act.
If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue
for relief under that Act.
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Legal Notice

Information contained in this publication is provided for the sole purpose of designing with and using Microchip
products. Information regarding device applications and the like is provided only for your convenience and may be
superseded by updates. It is your responsibility to ensure that your application meets with your specifications.

THIS INFORMATION IS PROVIDED BY MICROCHIP “AS IS”. MICROCHIP MAKES NO REPRESENTATIONS OR
WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR
OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR PURPOSE
OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL OR
CONSEQUENTIAL LOSS, DAMAGE, COST OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP'S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR ITS USE
WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO MICROCHIP FOR
THE INFORMATION. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk,
and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or
expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual
property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BesTime,
BitCloud, chipKIT, chipKIT logo, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, HELDO, IGLOO, JukeBlox,
KeeLoq, Kleer, LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo, MOST,
MOST logo, MPLAB, OptoLyzer, PackeTime, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip Designer,
QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer, Tachyon,
TempTrackr, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip Technology
Incorporated in the U.S.A. and other countries.

APT, ClockWorks, The Embedded Control Solutions Company, EtherSynch, FlashTec, Hyper Speed Control,
HyperLight Load, IntelliMOS, Libero, motorBench, mTouch, Powermite 3, Precision Edge, ProASIC, ProASIC Plus,
ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, Temux, TimeCesium, TimeHub, TimePictra, TimeProvider,
Vite, WinPath, and ZL are registered trademarks of Microchip Technology Incorporated in the U.S.A.

Adjacent Key Suppression, AKS, Analog-for-the-Digital Age, Any Capacitor, AnyIn, AnyOut, BlueSky, BodyCom,
CodeGuard, CryptoAuthentication, CryptoAutomotive, CryptoCompanion, CryptoController, dsPICDEM,
dsPICDEM.net, Dynamic Average Matching, DAM, ECAN, EtherGREEN, In-Circuit Serial Programming, ICSP,
INICnet, Inter-Chip Connectivity, JitterBlocker, KleerNet, KleerNet logo, memBrain, Mindi, MiWi, MPASM, MPF,
MPLAB Certified logo, MPLIB, MPLINK, MultiTRAK, NetDetach, Omniscient Code Generation, PICDEM,
PICDEM.net, PICkit, PICtail, PowerSmart, PureSilicon, QMatrix, REAL ICE, Ripple Blocker, SAM-ICE, Serial Quad
I/O, SMART-I.S., SQI, SuperSwitcher, SuperSwitcher II, Total Endurance, TSHARC, USBCheck, VariSense,
ViewSpan, WiperLock, Wireless DNA, and ZENA are trademarks of Microchip Technology Incorporated in the U.S.A.
and other countries.

SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

The Adaptec logo, Frequency on Demand, Silicon Storage Technology, and Symmcom are registered trademarks of
Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip
Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.
© 2020, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.

ISBN: 978-1-5224-6768-7
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Quality Management System
For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.
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2355 West Chandler Blvd.
Chandler, AZ 85224-6199
Tel: 480-792-7200
Fax: 480-792-7277
Technical Support:
www.microchip.com/support
Web Address:
www.microchip.com
Atlanta
Duluth, GA
Tel: 678-957-9614
Fax: 678-957-1455
Austin, TX
Tel: 512-257-3370
Boston
Westborough, MA
Tel: 774-760-0087
Fax: 774-760-0088
Chicago
Itasca, IL
Tel: 630-285-0071
Fax: 630-285-0075
Dallas
Addison, TX
Tel: 972-818-7423
Fax: 972-818-2924
Detroit
Novi, MI
Tel: 248-848-4000
Houston, TX
Tel: 281-894-5983
Indianapolis
Noblesville, IN
Tel: 317-773-8323
Fax: 317-773-5453
Tel: 317-536-2380
Los Angeles
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Tel: 949-462-9523
Fax: 949-462-9608
Tel: 951-273-7800
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Tel: 919-844-7510
New York, NY
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