
 Atmel AVR 8-bit Microcontroller

 AT08401: Getting Started with Atmel
ATmega328PB

 APPLICATION NOTE

Description

This application note aims at getting started with the Atmel® ATmega328PB
AVR® based microcontroller.

Features

• Getting started with the ATmega328PB microcontroller and tools
• Getting started with Atmel ATmega328PB Xplained Mini Kit and Atmel

Studio 6.2

This application note contains a list of all necessary tools required to start
the work and points to where to look for additional information.
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1. Getting Started with Atmel ATmega328PB

1.1. Key Features
• AVR (Harvard) architecture
• Single level pipelining
• In-system reprogrammable flash memory
• Separate EEPROM section available
• Optional boot code section with independent lock bits
• 20MIPS @ 20MHz
• Most single clock cycle execution
• Low power microcontroller with various sleep modes
• High code density (advanced RISC Instruction Set)
• On-chip hardware multiplier
• Short interrupt latency four clock cycles
• Factory calibrated internal RC oscillator
• Security with fuses and lock bits
• Atmel QTouch® Library support
• Compatibility between devices (portability)
• Peripheral touch controller
• Clock Failure Detection (CFD)

Note: For detailed information (like AVR architecture, flash size, number of pins, operating voltage range,
number of peripheral channels, module description, etc.) refer to the ATmega328PB datasheet.

1.2. Device Related Website Links
The ATmega328PB product overview webpage (as shown in the figure below) is available at:

http://www.atmel.com/devices/ATMEGA328PB.aspx
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Figure 1-1 Device Webpage

In the Parameters tab, the configuration parameter details (like flash size, number of peripheral channels,
number of I/O pins, etc.) for this device can be found.

http://www.atmel.com/devices/ATMEGA328PB.aspx?tab=parameters
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In the Documents tab, all the related documents (like datasheet and application notes) for this device
can be found.

http://www.atmel.com/devices/ATMEGA328PB.aspx?tab=documents

In the Datasheet section under the Documents tab today there are two documents:
1. Preliminary / Complete version (includes all peripheral descriptions and electrical characteristics).
2. Preliminary Summary / Summary version (includes Ordering Information, pin out, and Packaging

Information).

The device related application notes (like e.g. hardware design considerations) and its associated
firmware (if any) are also available under the Documents tab.

In the Applications tab, the recommended application areas (not limited to) for this device can be found.

http://www.atmel.com/devices/ATMEGA328PB.aspx?tab=applications

In the Tools tab, all the related tools (like IDE, programmer, debugger, evaluation kits, BSDL files) for this
device can be found.

http://www.atmel.com/devices/ATMEGA328PB.aspx?tab=tools

The ATmega328PB Xplained Mini kit’s webpage can be viewed by clicking the ATmega328PB Xplained
Mini available in the following link:

http://www.atmel.com/devices/ATMEGA328PB.aspx?tab=tools

1.3. ATmega328PB Xplained Mini Kit
The kit can be ordered online by clicking Add to Cart in the following link:

http://www.atmel.com/tools/MEGA328PB-XMINI.aspx
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Figure 1-2 ATmega328PB Xplained Mini Webpage

In the Documents tab, all the kit related documents like schematics and user guide can be found.
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http://www.atmel.com/tools/MEGA328PB-XMINI.aspx?tab=documents

Note: For detailed information like header and connections, refer to the ATmega328PB Xplained Mini
User Guide, which is available at the under the Documents tab.

1.4. Atmel Studio

1.4.1. Atmel Studio Webpage
The Atmel Studio installer (free IDE) is available at:

http://www.atmel.com/tools/ATMELSTUDIO.aspx

1.4.2. Atmel Studio Microsite
To learn more about Atmel Studio, refer to the following microsite:

http://www.atmel.com/microsite/atmel_studio6/

Figure 1-3 Atmel Studio Microsite Webpage
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In the Videos tab the getting started videos (like editor, creating a new C (GCC) project, debugging AVR
applications, debugging ARM® applications, etc.) can be found.

http://www.atmel.com/microsite/atmel_studio6/videos.aspx

1.5. Connecting the ATmega328PB Xplained Mini kit
This section helps the user to connect the ATmega328PB Xplained Mini with the Atmel Studio 6.2 SP2
(6.2.1563).

1. Download and install Atmel Studio version 6.2 SP2 (6.2.1563) or later versions.
2. ATmega328PB Part Pack for Atmel Studio 6.2 available in the Atmel Studio link has to be installed.

This bundle adds support for ATmega328PB device in Atmel Studio 6.2.SP2.
Note:  There is no need to install part pack for Atmel Studio future versions.

3. Launch the Atmel Studio.
4. Connect the ATmega328PB Xplained Mini to the USB port and it will be visible in the Atmel Studio.

1.5.1. Auto Board Identification of Xplained Mini Kit
• Once the ATmega328PB Xplained Mini kit is connected to the PC, the Windows® Task bar will pop-

up a message as shown in Figure 1-4 ATmega328PB Xplained Mini Driver Installation on page
8.
Figure 1-4 ATmega328PB Xplained Mini Driver Installation

• If the driver installation is proper, EDBG will be listed in the Device Manager as shown in Figure
1-5 Successful mEDBG Driver Installation on page 9
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Figure 1-5 Successful mEDBG Driver Installation

• Open Atmel Studio 6.2, go to View → Available Atmel Tools. The EDBG should get listed in the
tools as mEDBG and the tool status should display as "Connected". This indicates that the tool is
communicating properly with the Atmel Studio.

Figure 1-6 mEDBG under Available Atmel Tools

1.5.2. Connect the ATmega328PB Xplained Mini UART to the mEDBG COM Port
1. Connect the mEDBG USB to the PC.
2. Use the Device Manager to find the COM port number.
3. Default COM port settings are 9600 baud N 8 1. The COM port settings can be changed by using

the Device Manager.

1.6. Programming and Debugging
This section helps to program and debug the ATmega328PBXplained Mini kit by using mEDBG.

1.6.1. Programming the ATmega328PB Xplained Mini by using mEDBG
1. Connect the mEDBG USB to the PC.
2. Go to the Atmel Studio: Click Tools, select Device Programming, and then select the connected

mEDBG as Tool with Device as ATmega328PB and Interface as ISP, click Apply.
3. Select Memories and locate the source .hex or .elf file and then click Program.
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4. If the source contains fuse settings, go to Production file and upload the .elf file and program the
fuses.

Note:  If ISP programming fails it could be because the debugWIRE is enabled. See debugging section
on how to disable debugWIRE mode.

1.6.2. Debugging the ATmega328PB Xplained Mini by using mEDBG
1. Start Atmel Studio.
2. Connect the mEDBG USB to the PC.
3. Open your project.
4. In the Project menu select the project properties page. Select the Tools tab and select mEDBG as

debugger and debugWIRE as interface.
5. In the Debug menu click Start Debugging and Break.
6. Atmel Studio will display an error message if the DWEN fuse in the ATmega328PB is not enabled,

click YES to make Studio set the fuse using the ISP interface.
7. A debug session is started with a break in main. Debugging can start.
8. When exiting debug mode select Disable debugWIRE and Close in the Debug menu, this will

disable the DWEN fuse.

Note:  If the debug mode is not exited by selecting Disable debugWIRE and Close in the Debug menu,
the DWEN fuse will be enabled and the target will still be in debug mode, i.e. it will not be possible to
program the target by using the SPI (ISP) interface.
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2. Creating an Example Application in Atmel Studio
1. After connecting the board, to create a new project in Atmel Studio go to File → New and click on

Project (as shown in Figure 2-1 Creating New Project in Atmel Studio on page 11).
Figure 2-1 Creating New Project in Atmel Studio

2. The New Project wizard will display as shown in Figure 2-2 New Project Wizard on page 11.
Select the GCC C executable Project template, name the project and click OK to get the device
selection wizard.
Figure 2-2 New Project Wizard

3. The Device Selection wizard will display as shown in Figure 2-3 Device Selection Wizard on page
11. Select the ATmega328PB device from megaAVR® device family and click OK.
Figure 2-3 Device Selection Wizard

4. The new project and the .c file will be created as shown in Figure 2-4 Project Window on page
12.
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Add the following code snippet (LED control using push button) in the .c file.

int main(void) {
    /* configure LED pin as output */
    DDRB |= 1<<DDRB5; 
    while(1) {
        /* check the button status (press - 0 , release - 1 ) */
        if(!(PINB & (1<<PINB7))) {
        /*switch off (0) the LED until key is pressed */
            PORTB &= ~(1<<PORTB5); 
        } else {      
            /* switch on (1) the LED*/              
            PORTB |= 1<<PORTB5; 
        }
    }
}

5. Code explanation:
– Each PORT has three registers DDRx, PORTx, and PINx
– The DDRx register is used to configure the port pin direction. 1 - Output; 0 - Input.
– If one pin is configured as output pin and if the respective bit in PORTx is written logic one,

the respective port pin is driven high. If the same bit is written logic zero, the pin will be driven
low.

– The PINx register is used to return the logic level available on the port pin
– In this example code the PB7 Button is used as input and the PB5 LED0 as output
– Here the LED0 is controlled based on the pushbutton status
– As long the button is in pressed state (0) the LED0 will not glow (0)
– On releasing the button (1) the LED0 will glow (1 - default)

Figure 2-4 Project Window

6. In order to debug this project, configure the Tool and Interface in the Project properties. To open the
project properties, go to Project menu → Properties. In the project properties, go to Tool tab →
Under the Selected Debugger/Programmer, select the tool as mEDBG and interface as
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debugWIRE as shown in Figure 2-5 Tool and Interface Settings on page 13 Tool and Interface
Settings.
Figure 2-5 Tool and Interface Settings

7. To program and execute the application, there are two options:
– Start a debug session on the board, where the user will be able to program and debug
– Program the generated .hex file into the controller and execute the application

Both these options can be configured on ATmega328PB Xplained Mini as shown in Figure 2-6 
Start without Debugging on page 13 and Figure 2-7 Start Debugging and Break on page 13.

Figure 2-6 Start without Debugging

Figure 2-7 Start Debugging and Break

Note:  If the debug mode is not exited by selecting Disable debugWIRE and Close in the Debug menu,
the DWEN fuse will be enabled and the target will still be in debug mode, i.e. it will not be possible to
program the target by using the SPI .
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3. What’s next?
• Atmel Studio videos

http://www.atmel.com/microsite/atmel_studio6/videos.aspx

• Atmel Studio online help

http://www.atmel.com/webdoc/atmelstudio/

• Atmel Studio offline help (After installing Atmel Studio)

In Atmel Studio

Help → View Help (Ctrl+F1) → Atmel Studio

• ASF (Atmel Software framework) Getting Started and ASF Reference manual

http://www.atmel.com/tools/AVRSOFTWAREFRAMEWORK.aspx?tab=documents

• ASF online documentation

http://asf.atmel.com/docs/latest/

• Technical documentation for various products

http://www.atmel.com/webdoc/

• Atmel Gallery

https://gallery.atmel.com/

• Production Selection Guide

Atmel MCU Selector on http://www.atmel.com/

• Ordering Samples and Buying evaluation board and kits:

http://www.atmel.com/ → Buy → ‘Atmel store’

• Technical Documentation

http://www.atmel.com/design-support/documentation/default.aspx

• Knowledge Base and Technical Support/Design Support

http://www.atmel.com/design-support/

• Collaborative workspace

http://spaces.atmel.com

• AVR Freaks® community

http://www.avrfreaks.net/
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4. Revision History
Doc. Rev. Date Comments

42482A 08/2015 Initial document release
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