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AT09886: SAM L22 Getting Started Guide

APPLICATION NOTE

Introduction

This application note aims at helping the reader to get started with the
Atmel® SAM L22 ARM® Cortex®-M0+ based Ultra low-power segment LCD
microcontroller.

Atmel | SMART SAM L22 is a series of Ultra low-power segment LCD
microcontrollers using the 32-bit ARM Cortex-M0O+ processor, ranging from
48- to 100-pins with up to 256KB Flash and 32KB of SRAM and to drive up
to 320 LCD segments. The SAM L22 devices operate at a maximum
frequency of 32MHz and reach 2.14 Coremark/ MHz. With sophisticated
power management technologies the SAM L22 devices run below
50uA/MHz in active mode and below 600nA in ultra-low-power backup mode
with RTC.

SAM L22 is targeted for segment LCD and/or Battery powered applications,
like sport watches, personal healthcare devices, thermostat with user
interface, access control panels and metering (gas, water, energy metering,
and basic smart meter) applications.

Features

*  Getting started with Atmel SAM L22 microcontrollers

*  Getting started with Atmel SAM L22 tools (Atmel SAM L22 Xplained
PRO, Atmel Software Framework 3.26.10 or later, and Atmel Studio
6.2 or later)
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Configuration Summary

Table 1-1 Comparison Between SAM L22, SAM L21, and SAM D21 on page 3 shows the difference
between SAM L22, SAM L21, and SAM D21 features. For more details, refer to the datasheet of the
respective products.

Table 1-1 Comparison Between SAM L22, SAM L21, and SAM D21

Features ~ [SAML22N [SAML22J [SAML22G [SAML21J [SAML21G |SAM L21E SAM D21J SAMD21G  |SAM D21E
64 48 64 48 32 64 48 32

Pins 100

GPIO(s) 82 50 36 51 37 25 52 26 26

Flash 256/128/64KB 256/128/64KB 256/128/64KB 256/128/64KB 256/128/64KB 256/128/64/32KB 256/128/64/32KB 256/128/64/32KB 256/128/64/32KB

Flash RWW section 8/4/2KB 8/4/2KB 8/4/2KB 8/4/2KB 8/4/2KB 8/4/2/1KB 2KB/ 1KB in 2KB/ 1KB in 2KB/ 1KB in
32KB and 64KB | 32KB and 64KB 32KB and 64KB
Flash variants Flash variants Flash variants

System SRAM 32/16/8KB 32/16/8KB 32/16/8KB 32/16/8KB 32/16/8KB 32/16/8/4KB 32/16/8/4KB 32/16/8/4KB 32/16/8/4KB

Low Power SRAM - - - 8/8/4KB 8/8/4KB 8/8/4/2KB - - -

Segment LCD (SLCD) 48 31 23 - - - - - -

Pins

Timer Counter (TC) 4 4 4 5 3 3 5 3 3

Timer Counter for 3 3 3 3 3

Control (TCC)

DMA channels 16 16 16 16 16 16 12 12 12

USB interface 1 1 1 1 1 1 1 1 1

AES engine 1 1 1 - - -

Configurable Custom 4 4 4 4 4 4 - - -

Logic (CCL) (LUTs)

True Random Generator |1 1 1 1 1 1 - - -

(TRNG)

SERCOM 6 4 3 6 6 4 6 6 4

ADC channels 20 16 10 20 14 10 20 14 10

Analog Comparators 2 2 2 2 2 2 2 2 2

DAC Channels - - - 2 2 2

Op-Amp - - - 3 3 3 = = =

Tamper Input Pins 5) 3 2 - - -

RTC Yes Yes Yes Yes Yes Yes Yes Yes Yes

RTC alarms 1 1 1 1 1 1 1 1 1

External Interrupt lines 16 16 16 16 16 16 16 16 16

PTC channels for mutual 256 (16x16) |182 (13x14) 110 (10x11) | 12x16 16x12 |8x12 12x8 6x10 10x6 16x16 12x10 10x6

capacitance

PTC channels for self 24 19 13 16 12 10 16 16 6

capacitance

Maximum CPU 32MHz 32MHz 32MHz 48MHz 48MHz 48MHz 48MHz 48MHz 48MHz

frequency

Packages TQFP QFNTQFP QFNTQFP QFNTQFP QFNTQFP QFN TQFP QFN TQFP QFN TQFP QFN TQFP

Event System channels 8 8 8 12 12 12 12 12 12

SW Debug Interface Yes Yes Yes Yes Yes Yes Yes Yes Yes

WDT Yes Yes Yes Yes Yes Yes Yes Yes Yes

Atmel
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2. Getting the Device Datasheet

Web page: http://www.atmel.com/products/microcontrollers/arm/sam-l.aspx?tab=documents

Document: Atmel SAM L22 Datasheet (summary, complete) (.pdf)
Select the latest datasheet (.pdf file). There are two versions:

«  Complete version (includes all peripheral descriptions and electrical characteristics)
*  Summary version (includes Ordering Information, pinout and Packaging Information)

AtmeL Atmel AT09886: SAM L22 Getting Started Guide [APPLICATION NOTE] 4

Atmel-42494A-SAML22-Getting-Started-Guide_AT9886_Application Note-08/2015


http://www.atmel.com/products/microcontrollers/arm/sam-l.aspx?tab=documents

3. Get the SAM L22 Xplained Pro Evaluation Kit

Web page: http://www.atmel.com/products/microcontrollers/arm/sam-l.aspx?tab=tools
Get the kit: hitp://store.atmel.com
Figure 3-1 SAML22 Xplained Pro Picture

CURRENT MEASUREMENT SWO0 USER BUTTON
HEADER RESET BUTTON
TARGET USB DEBUG USB
%"
USER LEDO —= % i o0 L T
BACKUP 2l weasuee r HEADER
Ll CORTEX DEBUG
MCU CURRENT FOR EXTERNAL
MEASUREMENT DEBUGGER
SELECT JUMPER
I/O CURRENT
MEASUREMENT
SELECT JUMPER . EXTENSION 1
E i (scu) 015 | @ e = HEADER
PBO3/VBAT e 3 wE g s (SDA) D14 ,
SELECT JUMPER e ulg " i T AREF
P = GND
(SCK) D13
32kHz CRYSTAL S
(MOSI) D11 &
&3 D10 SAML22N18A
D9
D8
D7
Dé
SEGMENT LCD F =2 _ _ EXTENSION 2
CONNECTOR i) | - RS
02 . -
(TXD) D1
o ATAES132
CRYPT DEVICE
QTOUCH BUTTON ARDUINO UNO
COMPATIBLE
FOOTPRINT

EXTENSION 3
HEADER

Document:

*«  SAM L22 Xplained Pro User Guide application note (.pdf) available in http://www.atmel.com/tools/
ATSAML22-XPRO.aspx?tab=documents
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Key features:

Atmel

ATSAML22N18A microcontroller
One mechanical reset button
One user button (wake-up, bootloader entry or general purpose)
One Yellow user LED (LEDO)
USB Device interface function
One QTouch® Button
Segment LCD connector with additional lines for touch
ATAES132 Crypto Authentication
32.768kHz crystal
Standard Cortex Debug connector
3 Xplained Pro extension headers (EXT1, EXT2, and EXT3)
USB powered
Supported with application examples in Atmel Software Framework
Embedded Debugger
— Auto ID for board identification in Atmel Studio 6.2
— Programming/debugging of target via SWD
— Data gateway interface to target (SPI & TWI)
— Four GPIOs connected to target
— One yellow EDBG status LED
— One green board power LED (controlled by EDBG)
—  Virtual COM-port interface via UART

Embedded current measurement circuitry, with Atmel Data Visualizer support for data visualization

Arduino extension footprint

The SAM L22 Xplained Pro User Guide application note covers how to power the kit, the detailed
information of the on board components, extension interface and the hardware guide.

Atmel AT09886: SAM L22 Getting Started Guide [APPLICATION NOTE] 6
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41.

4.2.

4.3.

44,

4.5.

Get the Tools

Atmel Studio 6.2 is the preferred IDE to get started with the SAM L22 device and GCC compiler. Atmel
Software Framework (ASF) provides SAM L22 peripheral drivers and example projects. IAR™ compiler is
supported as well.

Get Atmel Studio 6

Web page: www.atmel.com/atmelstudio
Document/ file:
*  Atmel Studio 6.2 installer (.exe)

Atmel Studio 6.2 is the IDE for developing and debugging firmware for the SAM L22 microcontroller.

Get IAR Embedded Workbench for ARM
Web page: http://www.iar.com/en/Products/IAR-Embedded-Workbench/ARM/

Document/file:

. IAR installer for ARM

Get SAM L22 Xplained Pro Embedded Debugger Software (Segger J-Link)

Web page: http://www.segger.com/jlink-software.html
Document/file:
¢ J-Link software

This software is required to program/debug the SAM L22 Xplained Pro embedded debugger with IAR
IDE.

Get Atmel Software Framework (ASF)

Web page: www.atmel.com/asf
Document/file:

*  ASF update for Atmel Studio (.vsix) from ASF web page

*  ASF update through Atmel Gallery htips://gallery.atmel.com/ for version 3.26.10 and above

*  ASF update through Tools>Extension Manager from Atmel Studio

*  ASF standalone package for GCC makefile and IAR users

*  ASF: Getting started (.pdf)

*  ASF: Reference Manual (.pdf)

*  ASF online documentation for available APl and examples can be found at http://asf.atmel.com

Atmel Studio 6.2 Users Getting Started
Prerequisites:

AtmeL Atmel AT09886: SAM L22 Getting Started Guide [APPLICATION NOTE] 7
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Atmel Studio 6.2 SP2 or above installed

ASF version 3.26.10 or above installed

SAM L22 Xplained Pro board connected to PC through embedded debugger USB connector. The
kit is powered through USB.

Getting started with Atmel Studio 6.2, ASF, and SAM L22 Xplained Pro:

Atmel

Launch Atmel Studio 6.2
Connect the SAM L22 Xplained Pro board to the PC using a USB cable
A page on SAM L22 Xplained Pro description will open in Atmel Studio

This page contains external link to Device Technical Documentation, Datasheet, Kit user guide, and
Kit specific details like serial number and target name. Also, there will be an option to open ASF
example projects.

To open ASF examples, click File-> New -> then Example Project.
Figure 4-1 Creating New Example Project in Atmel Studio

# GETTING-STARTED1 - AtmelStudio (Administrator) .

| File | Edit View VAssistX ASF Project Build Debug Tools Window Help
i

| New » |3 Project.. Ctri+Shift«sN  |® |G

Open * ‘D File.. Ctrl+N
Add * | @] Example Project... Ctrl+Shift+E

Close

31 Close Solution
Import > N/A
&l Save Selected Items Ctrl+S

Save Selected Items As...

@ saveAl Ctrl+Shift+S .
Export Template...

L] Page Setup...

Print... Ctrl+P bination

L™

Recent Files >

Recent Projects and Solutions ’

Exit Alt+F4 Boot selection vBoot from Flash ~

Select ‘Getting started application-SAM L22 Xplained Pro’ as shown in Figure 4-2 SAML22 Getting
started Project Selection on page 9, press OK and accept the license agreement. Then the
project will be created and opened

Atmel AT09886: SAM L22 Getting Started Guide [APPLICATION NOTE] 8
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Atmel

Figure 4-2 SAML22 Getting started Project Selection

New Example Project from or

Device Family: [AII - ] Category: [AII v l 122 X et
Getting-Started
3 — Application -
All Projects 4 | Atmel - Atmel Corp. (117) (32519 « = L;’;Xphincd Pro
(&) C42412a Display LCD Glass Example - SAM L22 Xplained Pro E
S ad E‘JCLOCKF il . yDet ctor Exampl p-SAM 122 Xpl ip dp Y| The Getting Started example
Technology j a'_ e ) gl = will help new users get famil-
Addon (| Delay Service Example - SAM L22 Xplained Pro iar with SAM Xplained Pro.
& FatFS Example - SAM L22 Xplained Pro [Getting-Started Application
7] FreeRTOS demo using OLED1 Xplained Pro - SAM L22 Xplained Pro SAM 122 Xplained Pro -

5| FreeRTOS tickless demo with using OLED1 Xplained Pro - SAM L22 Xplained Pro ATSAME2NIZA]
|G| GFX Monochrome Spinner Widget Example - SAM L22 Xplained Pro

|G| GFX Monochrome System Font Example - SAM L22 Xplained Pro

&) 12C Slave Bootloader - SAM L22 Xplained Pro

|| LED Toggle Application - SAM L22 Xplained Pro

G| Quick Start for the AT30TSE75X Temperature Sensor Component - SAM L22 Xplained Pro
5] Quick Start for the SAM AC Driver (Callback) - SAM L22 Xplained Pro

/S| Quick Start for the SAM AC Driver (Polled) - SAM L22 Xplained Pro

|| Quick Start for the SAM ADC Driver (Callback) - SAM L22 Xplained Pro -
5| Quick Start for the SAM ADC Driver (Polled) - SAM L22 Xplained Pro

m

=l A Cae ot £kl s CARA AT Plee /e l) CARA A Vel o d Aae
< m » -

Project Name: GETTING-STARTED3

Location: Atmel Studio\6.2\GETTING-STARTED1

Solution: |Add to Solution zl

Solution name: | GETTING-STARTEDL
Device: ATSAML22N18A

Open project properties (Project -> Properties or shortcut Alt+f7)

In Tool view, set ‘Select debugger/programmer’ to XPRO-EDBG and interface to SWD as shown in
Figure 4-3 SAML22 Atmel Studio — Tools Configuration on page 9

Figure 4-3 SAML22 Atmel Studio — Tools Configuration

# GETTING-STARTED - AtmelStudio (Administrator) A S - - =aro)
File Edit View VAssistX ASF Project Build Debug Tools Window Help
P S4B 9 - -SR] D W [0ebug o[ (B [GetReport R - o R 083 #13al» R

o0 b | s SE(EE 2 T He |R@- i ) ) B o 85| o | SATSAMLZNIBA § SWD on EDBG (ATML2547020200000018)

HO NP

DS LWL
GETTING-STARTED3" |

- Solution Explorer

a|

ASFWizard  main.c

2 Xplained Pro - 0018

Build 8 Solution ‘GETTING-STARTEDL" (2 proje ~
/A NA 4y GETTING-STARTED1
Build Events @ Dependencies
s —_—— . 4 Output Files
jebugger/programmer  Libraries
Device EDBG + ATML2547020200000018 v Interface: |SWD ~| a5 Wyuc I
= = &3 ASF
Tool (3 config
asth
Adee SWD Clock i set
4 |1 GETTING-STARTED3
200MHz 4 Dependencies 4

‘The clock frequency should not exceed target CPU speed * 10.

Programming settings su BHE)
(Erase entire cip - |
Debug settings.

Override Vector Table Offset Register _ exception_table
9] Cache all flash memory except

Output
Show output from: | XDK Packaging BIFNERENE Y]

Build the project: Build -> Build solution or shortcut F7
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To load the code in the SAM L22 Xplained Pro and debug, select Debug -> Start debugging and
break (shortcut Alt + F5)

The application is programmed and the debugger breaks in main
To run the code, select Debug -> Continue (shortcut F5)

On the computer, open and configure a terminal application (e.g. HyperTerminal on Microsoft®
Windows® or Terminal application is available as an addon to Atmel Studio) with these settings:

Altmel

38400 bauds
8 bits of data
No parity

1 stop bit

No flow control

Start the application

The LED should start blinking on the board. In the terminal window, the following text should appear
(values depend on the board and chip used):

\code

»  Getting Started Example xxx --
* XXXXXX-XX
e Compiled: XXX XX XXXX XX:XX:XX --

\endcode

Figure 4-4 SAML22 Getting Started — Terminal Output

r

|

3 COM24:38400baud - Tera Term VT Lo | E S
File Edit Setup Control Window Help

—— Getting Started Example —— -
—— SAML22_XPLAINED_PRO --

== Compiled: Jul 17 20615 17:18:89 -~

-~ Pressing and release button SWO should make LED® on and off -~

he output is triggered by TC counter

he output is triggered by TC counter

he output is triggered by TC counter

Pressing and release button SWO0 should make LEDO on and off blinking.
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5. What’s Next?
*  Atmel Studio videos: www.atmel.com/atmelstudio
e Atmel Studio help: Help -> View Help (Ctrl+F1)
*  ASF Getting Started: www.atmel.com/asf
*  ASF online documentation: http://asf.atmel.com/docs/latest/

*  ASF Reference manual: http://www.atmel.com/tools/ AVRSOF TWAREFRAMEWORK aspx?
tab=documents

*  Technical Documentation for various products: www.atmel.no/webdoc
«  Technical Support: http://www.atmel.com/design-support/
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6. Revision History

Date Comments

42494A 08/2015 Initial document release.
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