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Introduction
Author: Phillip Olk, Microchip Technology Inc.

This application note outlines how to get started with the AVR® EA Family of microcontrollers.

Refer to the data sheet for further information on the differences between the AVR® EA Family devices.

Features Presented in this Document
• Getting Started with AVR® EA Family Microcontrollers and Tools
• Getting Started with AVR64EA48 Curiosity Nano and Microchip Studio 7.0
• Getting Started with AVR64EA48 Curiosity Nano and MPLAB® X
• Code Examples on MPLAB Discover and GitHub

 Getting Started with the AVR® EA Family
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1. Relevant Devices
This section lists the relevant devices for this document. The following figures show the different
family devices, laying out pin count variants and memory sizes:

• Vertical migration upwards is possible without code modification, as these devices are pin-
compatible and provide the same or more features

• Horizontal migration to the left reduces the pin count and, therefore, the available features
• Devices with different Flash memory sizes typically also have different SRAM and EEPROM

Figure 1-1. AVR® EA Family Overview
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2. Get the Device Data Sheet
Product pages

• AVR16EA28: www.microchip.com/wwwproducts/en/AVR16EA28
• AVR16EA32: www.microchip.com/wwwproducts/en/AVR16EA32
• AVR16EA48: www.microchip.com/wwwproducts/en/AVR16EA48
• AVR32EA28: www.microchip.com/wwwproducts/en/AVR32EA28
• AVR32EA32: www.microchip.com/wwwproducts/en/AVR32EA32
• AVR32EA48: www.microchip.com/wwwproducts/en/AVR32EA48
• AVR64EA28: www.microchip.com/wwwproducts/en/AVR64EA28
• AVR64EA32: www.microchip.com/wwwproducts/en/AVR64EA32
• AVR64EA48: www.microchip.com/wwwproducts/en/AVR64EA48

Documents

• AVR EA Product Brief (.pdf)
• AVR64EA Data Sheet (.pdf)
• AVR64EA Silicon Errata and Data Sheet Clarifications (.pdf)

The documentation for the AVR® EA Family is split into two document types:

• Data sheet(1) (includes device description, number of peripherals, pinout and electrical
characteristics)

• Errata (includes known errata for the device)

Note: 
1. For devices that are future products, the product brief is available instead of the data sheet.

https://www.microchip.com/wwwproducts/en/AVR16EA28
https://www.microchip.com/wwwproducts/en/AVR16EA32
https://www.microchip.com/wwwproducts/en/AVR16EA48
https://www.microchip.com/wwwproducts/en/AVR32EA28
https://www.microchip.com/wwwproducts/en/AVR32EA32
https://www.microchip.com/wwwproducts/en/AVR32EA48
https://www.microchip.com/wwwproducts/en/AVR64EA28
https://www.microchip.com/wwwproducts/en/AVR64EA32
https://www.microchip.com/wwwproducts/en/AVR64EA48
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3. Relevant Documents
All relevant documents can be found under the documentation tab on the product page.

Below is a list of documents relevant to the AVR® EA Family Microcontrollers.

Table 3-1. Application Notes and Example Code
Publication MPLAB Discover

AN4886 - Acquiring Analog Sensor Data in Low-Power Applications MPLAB X, Microchip Studio

AN4515 - Processing Analog Sensor Data with Digital Filtering MPLAB X, Microchip Studio

https://onlinedocs.microchip.com/oxy/GUID-C6697842-B1D3-4AE0-A955-755F1FC3B55F-en-US-2/index.html
https://mplab-discover.microchip.com/com.microchip.mcu8.mplabx.project.avr64ea48-lp-voltage-current-meas-mcc
https://mplab-discover.microchip.com/com.microchip.mcu8.studio.project.avr64ea48-lp-voltage-current-meas-studio
https://onlinedocs.microchip.com/pr/GUID-2607C185-2590-41FF-8911-0DAD5D1E3F69-en-US-5/index.html
https://mplab-discover.microchip.com/com.microchip.mcu8.mplabx.project.avr64ea48-digital-filters-mplab-mcc
https://mplab-discover.microchip.com/com.microchip.mcu8.studio.project.avr64ea48-digital-filters-studio
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4. Get the Tools
MPLAB® X, which uses the GCC or XC8 compiler, can be used as an IDE to start with AVR® EA Family.

4.1 Get the AVR64EA48 Curiosity Nano Evaluation Kit

Web page: www.microchip.com/developmenttools/productdetails.aspx?partno=EV66E56A

Get the kit: www.microchipdirect.com/ProductSearch.aspx?Keywords=EV66E56A

Document/file:
• AVR64EA48 Curiosity Nano Hardware User Guide: https://www.microchip.com/DS50003494

Key Features

• AVR64EA48 Microcontroller
• One Yellow User LED
• One Mechanical User Switch
• Footprints for 32.768 kHz and 16.0 MHz Crystals
• On-Board Debugger:

– Board identification in Atmel Studio/Microchip MPLAB® X
– One green power and status LED
– Programming and debugging
– Virtual COM port (CDC)
– Two logic analyzer channels (DGI GPIO)

• USB Powered
• Adjustable Target Voltage:

– MIC5353 LDO regulator controlled by the on-board debugger
– 1.8-5.1V output voltage (limited by USB input voltage)
– 500 mA maximum output current (limited by ambient temperature and output voltage)

The AVR64EA48 Curiosity Nano user guide covers how to power the kit and detailed information on
on-board components, extension interface, and hardware guide.

4.2 Get Code Examples from MPLAB Discover
MPLAB Discover bundles the available resources from multiple sources into one portal.

http://www.microchip.com/developmenttools/productdetails.aspx?partno=EV66E56A
http://www.microchipdirect.com/ProductSearch.aspx?Keywords=EV66E56A
https://ww1.microchip.com/downloads/aemDocuments/documents/MCU08/ProductDocuments/UserGuides/AVR64EA48-CNANO-HW-UserGuide-DS50003494.pdf
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The MPLAB Discover webpage: MPLAB Discover

Code Examples

Finding code examples for devices in the AVR EA Family can be done by searching for the device
name, e.g., AVR64EA48, in the search bar.

You can download code examples as a .zip file directly from MPLAB Discover. Repositories ending
with “studio” can be opened in Microchip Studio. Repositories ending with “mplab-mcc” can be
opened in MPLAB X.

When the code example is hosted on GitHub, MPLAB Discover provides a link “Open with Github”.
There you can download the example code or use the git tool on your PC to create a local
repository clone.

4.3 Get Microchip Studio 7.0
Webpage: Microchip Studio

Document/file:
• Microchip Studio for AVR and SAM Devices 7.0 Installer (.exe)

Microchip Studio 7.0 1.0.18 or later is the preferred IDE for developing and debugging firmware for
the AVR® EA Family.

For device support, refer to 4.4.  Get Device Support for Microchip Studio.

4.4 Get Device Support for Microchip Studio
Microchip Studio: Use the Device Pack Manager, found under Tools → Device Pack Manager, to add
support for new devices in Microchip Studio.

For the AVR® EA Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For AVR® EA Family, select the latest version of AVR-Ex_DFP.
3. Click Install.

For offline installers, go to packs.download.atmel.com/. Double click on the installer file and follow
the instructions to install a package. Any open Microchip Studio window must be closed for the
installation to take effect.

IAR™: Install the latest service pack to add support for new devices in IAR Embedded Workbench.
The service pack is available at My Pages on https://iar.com (MyPages is available for users with
registered IAR™ licenses using the same email address used to register the license).

https://mplab-discover.microchip.com/
https://mplab-discover.microchip.com/v2?dsl=avr64ea
https://github.com/
https://www.microchip.com/en-us/development-tool/microchip-studio
http://packs.download.atmel.com/
https://www.iar.com/
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4.5 Get MPLAB® X
Webpage: MPLAB® X IDE

Document/file:
• MPLAB X

MPLAB X can be utilized as an IDE for developing and debugging the firmware for the AVR® EA
Family.

For device support, refer to 4.6.  Get Device Support for MPLAB X.

4.6 Get Device Support for MPLAB® X
MPLAB X: Use the MPLAB Pack Manager, found under Tools → Packs, to add support for new
devices in MPLAB X.

For the AVR® EA Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For the AVR® EA Family, select the latest available version of AVR-Ex_DFP.
3. Click Install.

For offline installers, go to packs.download.microchip.com/. Double click on the installer file and
follow the instructions to install a package. Any open MPLAB X window must be closed for the
installation to take effect.

4.7 Get MPLAB® Code Configurator
Webpage: MPLAB® Code Configurator

Document/file:
• MCC Melody

MPLAB® Code Configurator (MCC) Melody can be utilized within MPLAB® X IDE as a graphical
programming interface that generates peripherals and library code for the AVR® EA Family.

https://www.microchip.com/mplab/mplab-x-ide
https://packs.download.microchip.com/
https://www.microchip.com/mplab/mplab-code-configurator
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5. Microchip Studio Users Getting Started
5.1 Microchip Studio with AVR64EA48 Curiosity Nano

Prerequisites

• Microchip Studio 7.0.2594 or later installed
• The AVR64EA48 Curiosity Nano Board is connected to Atmel Studio 7.0 via the on-board USB

connector, which is connected to the embedded debugger. The kit will be powered by the USB,
and the embedded debugger will enable debugging and programming via the USB.

Workflow

1. Launch Microchip Studio 7.0.
2. The page shown below will appear when AVR64EA48 Curiosity Nano is connected to Atmel

Studio 7.0.
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Figure 5-1. AVR64EA48 Curiosity Nano Page in Microchip Studio

3. Start creating a new project by clicking New → Project... or by using the Ctrl+Shift+N shortcut,
as shown in Figure 5-2.
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Figure 5-2. Create New Project in Microchip Studio

4. Select the GCC C Executable Project template, as shown in Figure 5-3, type in the name of the
solution and project (e.g., GETTING_STARTED and LED_TOGGLE), and click OK.

Figure 5-3. New Project Wizard

5. Select AVR64EA48 as shown in Figure 5-4, and click OK.
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Figure 5-4. Device Selection Wizard

A new project with a main.c file associated will be generated in Microchip Studio.

6. Replace the main.c file with the following code snippet:

int main (void)
{
 /* Configure SW0 as input */
 PORTB.DIRCLR = PIN2_bm;
 /* Configure LED0 pin as output */
 PORTB.DIRSET = PIN3_bm;
 /* Enable the internal pull-up for SW0 */
 PORTB.PIN2CTRL |= PORT_PULLUPEN_bm;

 while (1)
 {
 /* Check the status of SW0 */
 /* 0: Pressed */
 if (!(PORTB.IN & (PIN2_bm)))
 {
 /* LED0 on */
 PORTB.OUTCLR = PIN3_bm;
 }
 /* 1: Released */
 else
 {
 /* LED0 off */
 PORTB.OUTSET = PIN3_bm;
 }
 }
}

In the code editor, the code will appear, as shown in Figure 5-5.
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Figure 5-5. Code Editor Window

7. Open project properties by clicking Project → Properties or by using the ALT+F7 shortcut.
8. In the Tool view (see Figure 5-6), set Selected debugger/programmer to nEDBG and Interface to

UPDI.

Figure 5-6. Debugger and Interface for AVR64EA48

9. Build the project by clicking Build → Build Solution or by using the F7 shortcut.
10. Program AVR64EA48 with the project code and start debugging by clicking Debug → Start

debugging and break or by using the ALT+F5 shortcut. The application is programmed onto the
device, and program execution will break in the main() function.
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11. Run the code by clicking Debug → Continue or by using the F5 shortcut.
12. Verify that LED0 is lit when SW0 is pushed on the AVR64EA48 Curiosity Nano.
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6. MPLAB® X Users Getting Started
6.1 MPLAB® X with AVR64EA48 Curiosity Nano

Prerequisites

• MPLAB X installed
• The AVR64EA48 Curiosity Nano Board is connected to MPLAB X via the on-board USB connector

connected to the embedded debugger. The USB powers the kit, and the embedded debugger will
enable debugging and programming via the USB.

Workflow

1. Launch MPLAB X.
2. The page shown in Figure 6-1 will appear when AVR64EA48 Curiosity Nano is connected to

MPLAB X.

Figure 6-1. AVR64EA48 Curiosity Nano Page in MPLAB® X

3. Start creating a new project by clicking File → New Project... or using the Ctrl+Shift+N shortcut,
as shown in Figure 6-2.
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Figure 6-2. Create New Project in MPLAB® X

4. Select the Categories → Microchip Embedded and Projects → Standalone Project template
from Figure 6-7, and click Next.
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Figure 6-3. New Project Window

5. Select AVR64EA48 (see Figure 6-4) and click Next.

Figure 6-4. Device Selection Window

Then select the board and the desired compiler, if there are any.
6. Select an available compiler (e.g., XC8 (v.2.40)), and click Finish.
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Figure 6-5. Compiler Selection Window

7. Type in the name of the project (e.g., LED_TOGGLE) and the project location (e.g., C:\microchip),
and click Finish.
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Figure 6-6. Project Name and Location Selection Window

8. Create a new main.c file by clicking File → New File... or using the Ctrl+N shortcut, as shown in
Figure 6-7.
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Figure 6-7. Create a New File in MPLAB® X

9. Select the Categories → C and File Types → C Main File template from Figure 6-8, and click
Next.
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Figure 6-8. New File Window

10. Type in the file name (e.g., main) and click Finish.
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Figure 6-9. File Name Window

11. Replace the main.c file with the following code snippet:

int main (void)
{
 /* Configure SW0 as input */
 PORTB.DIRCLR = PIN2_bm;
 /* Configure LED0 pin as output */
 PORTB.DIRSET = PIN3_bm;
 /* Enable the internal pull-up for SW0 */
 PORTB.PIN2CTRL |= PORT_PULLUPEN_bm;

 while (1)
 {
 /* Check the status of SW0 */
 /* 0: Pressed */
 if (!(PORTB.IN & (PIN2_bm)))
 {
 /* LED0 on */
 PORTB.OUTCLR = PIN3_bm;
 }
 /* 1: Released */
 else
 {
 /* LED0 off */
 PORTB.OUTSET = PIN3_bm;
 }
 }
}

Add #inlude<avr/io.h> in main.c. In the code editor, the code will appear as shown in Figure
6-10.
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Figure 6-10. Code Editor Window

12. Build the code by clicking on Production → Clean and Build Main Project or using the Shift +
F11 shortcut.

13. Program AVR64EA48 with the project code and start debugging by clicking Debug → Debugging
Main Project.

14. Verify that LED0 is lit when SW0 is pushed on the AVR64EA48 Curiosity Nano.
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7. What's Next
For further information on related AVR products and IDE, refer to the links below:

Software:
• MPLAB X
• Microchip Studio
• Microchip Studio help: Help → View Help (shortcut CTRL+F1)
• Microchip Gallery
• IAR Embedded Workbench for AVR: Go to www.iar.com, and search for "AVR."

Firmware:
• MPLAB Discover examples
• GitHub examples

Hardware:
• AN2519: AVR Microcontroller Hardware Design Considerations
• AVR IBIS files
• AVR BDSL files

Recommended Programming/Debugging Tools:
• Atmel-ICE:

– User Guide
– Buy

• Power Debugger:
– User Guide
– Buy

• MPLAB Snap:
– Buy

• MPLAB PICkit® 5:
– Buy

Other:
• AVR Freaks®: www.avrfreaks.net/
• Product Selector and Application Notes:

www.microchip.com/en-us/products/microcontrollers-and-microprocessors/8-bit-mcus/avr-
mcus/avr-ea
Find the preferred device in the Family Offerings or Products list and go to the product page. All
relevant application notes can be found under the documentation tab.

• Overview of the tool ecosystem for AVR microcontrollers: www.microchip.com/en-us/products/
microcontrollers-and-microprocessors/8-bit-mcus/avr-mcus/get-started-now

• More online technical documentation concerning various products: onlinedocs.microchip.com/
• Microchip Technical Support: microchipsupport.force.com/s/

https://www.microchip.com/mplab/mplab-x-ide
https://www.microchip.com/en-us/development-tool/microchip-studio
https://gallery.microchip.com/
https://www.iar.com
https://mplab-discover.microchip.com/v2?dsl=avr64ea
https://github.com/search?q=avr64ea+user%3Amicrochiptech+user%3Amicrochip-pic-avr-examples&type=Repositories
https://www.microchip.com/DS00002519
http://www.microchip.com/doclisting/TechDoc.aspx?type=IBIS
http://www.microchip.com/doclisting/TechDoc.aspx?type=BSDL
http://www.microchip.com/DS50002999
https://www.microchipdirect.com/product/search/all/ATATMEL-ICE
https://www.microchip.com/DS40002201
https://www.microchipdirect.com/product/search/all/ATPOWERDEBUGGER
https://www.microchipdirect.com/dev-tools/PG164100
https://www.microchip.com/en-us/development-tool/PG164150
http://www.avrfreaks.net/
https://www.microchip.com/en-us/products/microcontrollers-and-microprocessors/8-bit-mcus/avr-mcus/avr-ea
https://www.microchip.com/en-us/products/microcontrollers-and-microprocessors/8-bit-mcus/avr-mcus/avr-ea
https://www.microchip.com/en-us/products/microcontrollers-and-microprocessors/8-bit-mcus/avr-mcus/get-started-now
https://www.microchip.com/en-us/products/microcontrollers-and-microprocessors/8-bit-mcus/avr-mcus/get-started-now
https://onlinedocs.microchip.com/
https://microchipsupport.force.com/s/
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8. Revision History
Doc. Rev. Date Comments

A 09/2023 Initial document release
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Microchip Information
The Microchip Website
Microchip provides online support via our website at www.microchip.com/. This website is used to
make files and information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design
resources, user’s guides and hardware support documents, latest software releases and archived
software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests,
online discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases,
listing of seminars and events, listings of Microchip sales offices, distributors and factory
representatives

Product Change Notification Service
Microchip’s product change notification service helps keep customers current on Microchip
products. Subscribers will receive email notification whenever there are changes, updates, revisions
or errata related to a specified product family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support
Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are
also available to help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature
Note the following details of the code protection feature on Microchip products:

• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner, within

operating specifications, and under normal conditions.
• Microchip values and aggressively protects its intellectual property rights. Attempts to breach the

code protection features of Microchip product is strictly prohibited and may violate the Digital
Millennium Copyright Act.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its
code. Code protection does not mean that we are guaranteeing the product is “unbreakable”.
Code protection is constantly evolving. Microchip is committed to continuously improving the
code protection features of our products.

Legal Notice
This publication and the information herein may be used only with Microchip products, including
to design, test, and integrate Microchip products with your application. Use of this information
in any other manner violates these terms. Information regarding device applications is provided
only for your convenience and may be superseded by updates. It is your responsibility to ensure

https://www.microchip.com/
https://www.microchip.com/pcn
https://www.microchip.com/support
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that your application meets with your specifications. Contact your local Microchip sales office for
additional support or, obtain additional support at www.microchip.com/en-us/support/design-help/
client-support-services.

THIS INFORMATION IS PROVIDED BY MICROCHIP "AS IS". MICROCHIP MAKES NO REPRESENTATIONS
OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY
OR OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR
PURPOSE, OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL, OR
CONSEQUENTIAL LOSS, DAMAGE, COST, OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP'S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR
ITS USE WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO
MICROCHIP FOR THE INFORMATION.

Use of Microchip devices in life support and/or safety applications is entirely at the buyer's risk,
and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages,
claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise,
under any Microchip intellectual property rights unless otherwise stated.

Trademarks
The Microchip name and logo, the Microchip logo, Adaptec, AVR, AVR logo, AVR Freaks, BesTime,
BitCloud, CryptoMemory, CryptoRF, dsPIC, flexPWR, HELDO, IGLOO, JukeBlox, KeeLoq, Kleer,
LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo, MOST,
MOST logo, MPLAB, OptoLyzer, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip Designer,
QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer,
Tachyon, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip
Technology Incorporated in the U.S.A. and other countries.

AgileSwitch, ClockWorks, The Embedded Control Solutions Company, EtherSynch, Flashtec, Hyper
Speed Control, HyperLight Load, Libero, motorBench, mTouch, Powermite 3, Precision Edge,
ProASIC, ProASIC Plus, ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, TimeCesium,
TimeHub, TimePictra, TimeProvider, and ZL are registered trademarks of Microchip Technology
Incorporated in the U.S.A.
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