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Introduction  (Ask a Question)

This document demonstrates how to implement basic PolarFire® SoC FPGA designs leveraging the Libero® SoC
design tool. The design targets the PolarFire SoC Discovery Kit.

After completing this demo, you will be familiar with the following:

• Creating a Libero SoC Project
• Compiling a Design
• Assigning simple I/O Pin constraints
• Programming the device
• Testing your design

Demo Requirements  (Ask a Question)

The following table lists the hardware and software requirements for the demo.

Table 1. Design Requirements
Requirements Version

Operating System Windows® 10

Hardware

PolarFire® SoC Discovery Kit (MPFS-DISCO-KIT) REV 1

Software

FlashPro® Express Available with Libero® SoC installation package.

Libero SoC

Prerequisites  (Ask a Question)

Before you start, download and install Libero SoC on the host PC. To evaluate the designs using the PolarFire
SoC Discovery Kit, use the free Libero SoC Silver license.
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https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-7BE44BDC-3677-4E6C-9A80-FA65CEE4332D&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Introduction
https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-7E1F4EA2-B6B1-4D96-B413-F7E0016E10AD&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Demo%20Requirements
https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-E778CE8F-A0BC-4D7D-9494-00D6FA179229&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Prerequisites
https://www.microchip.com/en-us/products/fpgas-and-plds/fpga-and-soc-design-tools/fpga/libero-software-later-versions
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1. Creating the Design  (Ask a Question)

The following steps describe how to create a design using SmartDesign.

1.1 Launching the Libero SoC Software  (Ask a Question)

Follow the instructions to launch the Libero SoC software:

1. To open the Libero SoC Project Manager, go to Start > Microchip Libero SoC v2023.2 > Libero
SoC v2023.2, or double-click the shortcut on the desktop.

2. Create a new project using one of the following options:
– Click New on the Start Page tab, as shown in the following figure
– Go to Project > New Project from the Libero SoC menu

Figure 1-1. Libero® SoC Project Manager

3. Enter the following information in the Project Details page of the New Project dialog box, as
shown in the following figure:

– Project Name: PolarFire_SoC_fabric
– Project Location: <C:, D:>/
– Preferred HDL Type: Verilog or VHDL

4. Click Next.

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-05FEB567-8C1C-4913-A769-042C5A5FE7C2&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Creating%20the%20Design
https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-0F0BFEAE-4B61-4A38-A4D0-410282709C0B&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Launching%20the%20Libero%20SoC%20Software
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Figure 1-2. Project Details

5. Enter the following information in the Device Selection page of the New Project dialog box and
click Next:

– Family: PolarFireSoC
– Die: MPFS095T
– Package: FCSG325
– Speed: -1
– Range: EXT

Figure 1-3. Device Selection Settings

6. Enter the following information in the Device Settings page of the New Project dialog box and
click Next:

– Core Voltage: 1.0 (default)



 AN5282
Creating the Design

 Application Note
© 2024 Microchip Technology Inc. and its subsidiaries

DS00005282B - 5

– Default I/O Technology: LVCMOS1.8V
– Reserve Pins for Probes: Checked (default)
– System Controller Suspend Mode: Un-checked (default)

Figure 1-4. Device I/O Settings

7. Click Finish.
8. Open the SmartDesign canvas by selecting File > New > SmartDesign, or by double-clicking

Create SmartDesign under Create Design in the Design Flow tab.

Figure 1-5. Opening the SmartDesign Canvas

9. Enter andgate in the Create New SmartDesign dialog box, and click OK. For Verilog designs, the
name is case sensitive.
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Figure 1-6. Entering SmartDesign Name

10. Expand Macro Library in the Libero SoC IP catalog.

Figure 1-7. Macro Library Category of the Libero SoC IP Catalog

11. Drag-and-drop an instance of AND2 in the SmartDesign Canvas.
12. In the SmartDesign canvas, select A, B, and Y pins. Right-click and select Promote to Top Level

from the menu, as shown in the following figure. This creates an external connection on the
device that can be connected to a switch.

Figure 1-8. Promoting Pins to Top Level



 AN5282
Creating the Design

 Application Note
© 2024 Microchip Technology Inc. and its subsidiaries

DS00005282B - 7

13. After making the connections, the SmartDesign canvas is displayed, as shown in the following
figure.

Figure 1-9. andgate SmartDesign Canvas

14. Save the design (File > Save top).
15. Generate the design by clicking SmartDesign > Generate Component, or Generate Component

on the SmartDesign toolbar.
16. Select the Design Hierarchy tab and click Build Hierarchy.

Figure 1-10. Build Hierarchy

17. Select andgate on the Design Hierarchy tab. Right-click and select Set As Root. andgate appears
in bold font on the Design Hierarchy tab indicating that it is the root level.

Figure 1-11. Set As Root
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2. Synthesize the Design  (Ask a Question)

To synthesize the design with Synplify Pro®, navigate to the Design Flow window, expand
Impelement Design, right-click Synthesize, and select Run, as shown in the following figure.

Figure 2-1. Design Flow—Synthesize

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-5B7982FC-B9C0-42F2-8259-C389C5DA6B06&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Synthesize%20the%20Design
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3. Pin Assignments  (Ask a Question)

Follow the instructions to assign the pins in the software:

1. Navigate to the Design Flow window, expand Constraints, right-click Manage Constraints, and
select Open Manage Constraints View.

Figure 3-1. Opening the I/O Editor

2. In the Constraint Manager window, select the I/O Attributes tab and click Edit with I/O Editor, see
the following figure.

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-0570A0A3-AB5B-404D-A902-3CB5DDA9A8F3&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Pin%20Assignments
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Figure 3-2. Constraint Manager Window

The I/O Editor page appears. See the following figure.
3. Select the Port View tab of the I/O Editor.

Figure 3-3. I/O Editor

4. Set the I/O Standard and Pin Number in this window. Confirm that LVCMOS18 is the I/O
Standard for each pin.

5. Navigate to the Pin Number column and click Unassigned in the Pin Number column to see the
available I/O pins in I/O Editor. Make the following assignments:

– A - T19
– B - U18
– Y - T18

You can type the pin number in the field or use the pull-down menu to select the pin.
6. Select File > Commit and Check from the I/O Attribute Editor menu. Ensure that the I/O Editor

Log window has no errors and the connections match as shown in the following figure.
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Figure 3-4. Pin Assignments

7. Close the I/O Attribute Editor using File > Exit.

3.1 Push Button Switches  (Ask a Question)

The PolarFire SoC Discovery Kit comes with two debug push-button switches that are connected to
the PolarFire SoC FPGA. The following table lists the onboard push-button switches.

Table 3-1. PolarFire SoC Discovery Kit Pin Number and Pin Name
PolarFire® SoC Discovery Board PolarFire SoC FPGA Pin Number PolarFire SoC FPGA Pin Name

SWITCH1 T19 HSIO12NB0

SWITCH2 U18 HSIO15NB0/DQS

The following figure shows the schematics of Push Button.

Figure 3-5. Push Button Schematics

3.2 User LEDs  (Ask a Question)

The board provides the access to eight active low LEDs, which are connected to the PolarFire SoC
FPGA for debugging applications. The following table lists the onboard debugging LEDs.

Table 3-2. User LEDs
PolarFire® SoC Discovery Board PolarFire SoC FPGA Pin Number PolarFire Pin Name

LED1 T18 HSIO12PB0/CLKIN_N_9/CCC_NE_CLKIN_N_9

The following figure shows the user LED schematics.

Figure 3-6. User LED Schematics

If you click on the green arrow button at the top of the Design Flow window, you can run the design
all the way through Place and Route.

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-F66CFEC9-547B-4157-A9CC-1423088EA9A8&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Push%20Button%20Switches
https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-932CE1B7-784D-4A0F-B82C-60FA0A7404B5&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=User%20LEDs
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Figure 3-7. Running the Design Flow
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4. Setting up the Demo Design  (Ask a Question)

The following figure shows the PolarFire SoC Discovery Kit board.

Figure 4-1. PolarFire SoC Discovery Kit Board

PolarFire SoC 
MPFS095T Switch 1 and 2

LED 1

The following steps describe how to setup the PolarFire SoC Discovery Kit to run the demo design:

1. Ensure that the board is powered OFF.
2. Before programming and powering up the PolarFire SoC Discovery board, ensure that the

jumpers are positioned, as listed in the following table.

Table 4-1. Jumper Settings
Jumper Location Purpose Settings

J45 Near the Raspberry Pi
connector

Select the voltage for I/O bank 5 (Pin 1–2 for 3.3V) 1–2 installed

J46 Near the Raspberry Pi
connector

Select the VDDAUX1 voltage
• Pin 1–2 for 3.3V

• Pin 2–3 for 2.5V

1–2 installed

J47 Near the power block Select the power source for the board
Pin 1–2 for board powered by USB Type C connector J4

1–2 installed

J49 Near the RJ45 connector Jumper to select the voltage for the external 8-digit 7-segment display
• Pin 1–2 installed for 3.3V

• Pin 2–3 installed for 5.0V

1–2 installed

3. Connect the USB type-C cable between the J4 USB connector and the host PC.

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-74B6469C-9F3B-4864-BA5D-CDCB265F8260&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Setting%20up%20the%20Demo%20Design
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5. Programming the Device  (Ask a Question)

The FlashPro Express runs in batch mode to program the PolarFire SoC MPFS095T on the PolarFire
SoC Discovery Kit board.

To program the device, follow these steps:

1. Install the FlashPro5 drivers if prompted. The drivers are in the <Libero SoC v20232.2
Installation Directory>\Designer\fp_drivers folder.

2. To generate the programming file and begin programming, expand Program Design in the
Design Flow window, right-click Run PROGRAM Action and select Run.

FlashPro Express runs in batch mode and programs the device. Programming messages are visible
in the Libero® SoC log window (programmer number may differ).

Important: Do not interrupt the programming sequence.

The following message must be visible in the Reports View under Run PROGRAM Action
when the device is programmed successfully (programmer number may differ): programmer
'E2007ZZUNS': Chain programming PASSED.

Figure 5-1. Program Report

A green check mark appears next to the Program Design and Run PROGRAM Action in the Design
Flow window to indicate programming completed successfully.

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-E19D65CC-22A2-4274-BD24-ABCFCD8D885B&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Programming%20the%20Device
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Figure 5-2. Design Flow Window
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6. Running the Design  (Ask a Question)

Follow the instructions to run the application:

1. Release Switch 1 and Switch 2 and observe the pattern of LED 1. LED1 must illuminate.
2. Press Switch 1 and observe the behavior of LED 1. It turns OFF.
3. Press Switch 2 and observe the behavior of LED 1. It turns OFF.
4. Press both the switches and LED 1 turns OFF.
5. Releasing the switch generates a logic one, which illuminates the LED. Invert the input signals to

illuminate the LED when both switches are pressed.

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-99090A5A-AF80-403E-ADA2-C94EBA21FF3D&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Running%20the%20Design
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7. Design Iterations in Libero SoC (Ask a Question)

Follow the instructions to iterate the design:

1. Reopen the SmartDesign Canvas by double-clicking andgate on the Design Hierarchy tab.
2. Select the andgate tab.
3. To bring up the menu, hold the CTRL key and select input ports A and B of AND2_0, and click

the right mouse button. Select Invert to invert the signals. This is built into the SmartDesign
capabilities to invert or Tie off any I/O.

4. Generate the Component. This resets the rest of the compilation functions but keeps the I/O
constraints.

5. To run all the steps in between and reprogram the device, right-click Run PROGRAM Action on
the Design Flow window and select Update and Run. If it seems to be taking a while, check to
see if the Warning dialog box about running in non-Timing-driven mode is behind your active
window.

Observe the correct behavior on the board by pressing both switches simultaneously to illuminate
LED1.

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-67C835CF-83F1-4900-8117-BACBB6316501&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Design%20Iterations%20in%20Libero%20SoC
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8. Revision History  (Ask a Question)

The revision history describes the changes that were implemented in the document. The changes
are listed by revision, starting with the most current publication.

Revision Date Description

B 07/2024 Updated the I/O Standard to "LVCMOS18" from "LVCMOS33" in step 3 of 3.  Pin Assignments section

A 01/2024 Initial Revision

https://microchipsupport.force.com/s/newcase?pub_guid=GUID-0F3D50F1-09FD-4BE3-82A2-82A0B60E89D2&pub_lang=en-US&pub_ver=2&pub_type=Application%20Note&bu=fpga&tpc_guid=GUID-84A65868-52F1-4112-A9E4-9C779485A707&cover_title=PolarFire%20SoC%20Design%20Flow%20&tech_support_link=NA&revision_letter=B&source=PDF&title=Revision%20History
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Microchip FPGA Support
Microchip FPGA products group backs its products with various support services, including
Customer Service, Customer Technical Support Center, a website, and worldwide sales offices.
Customers are suggested to visit Microchip online resources prior to contacting support as it is
very likely that their queries have been already answered.

Contact Technical Support Center through the website at www.microchip.com/support. Mention the
FPGA Device Part number, select appropriate case category, and upload design files while creating a
technical support case.

Contact Customer Service for non-technical product support, such as product pricing, product
upgrades, update information, order status, and authorization.

• From North America, call 800.262.1060
• From the rest of the world, call 650.318.4460
• Fax, from anywhere in the world, 650.318.8044

Microchip Information
The Microchip Website
Microchip provides online support via our website at www.microchip.com/. This website is used to
make files and information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design
resources, user’s guides and hardware support documents, latest software releases and archived
software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests,
online discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases,
listing of seminars and events, listings of Microchip sales offices, distributors and factory
representatives

Product Change Notification Service
Microchip’s product change notification service helps keep customers current on Microchip
products. Subscribers will receive email notification whenever there are changes, updates, revisions
or errata related to a specified product family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support
Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are
also available to help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature
Note the following details of the code protection feature on Microchip products:

http://www.microchip.com/support
https://www.microchip.com/
https://www.microchip.com/pcn
https://www.microchip.com/support
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• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner, within

operating specifications, and under normal conditions.
• Microchip values and aggressively protects its intellectual property rights. Attempts to breach the

code protection features of Microchip product is strictly prohibited and may violate the Digital
Millennium Copyright Act.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its
code. Code protection does not mean that we are guaranteeing the product is “unbreakable”.
Code protection is constantly evolving. Microchip is committed to continuously improving the
code protection features of our products.

Legal Notice
This publication and the information herein may be used only with Microchip products, including
to design, test, and integrate Microchip products with your application. Use of this information
in any other manner violates these terms. Information regarding device applications is provided
only for your convenience and may be superseded by updates. It is your responsibility to ensure
that your application meets with your specifications. Contact your local Microchip sales office for
additional support or, obtain additional support at www.microchip.com/en-us/support/design-help/
client-support-services.

THIS INFORMATION IS PROVIDED BY MICROCHIP “AS IS”. MICROCHIP MAKES NO REPRESENTATIONS
OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY
OR OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR
PURPOSE, OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL, OR
CONSEQUENTIAL LOSS, DAMAGE, COST, OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP’S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR
ITS USE WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO
MICROCHIP FOR THE INFORMATION.

Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk,
and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages,
claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise,
under any Microchip intellectual property rights unless otherwise stated.

Trademarks
The Microchip name and logo, the Microchip logo, Adaptec, AVR, AVR logo, AVR Freaks, BesTime,
BitCloud, CryptoMemory, CryptoRF, dsPIC, flexPWR, HELDO, IGLOO, JukeBlox, KeeLoq, Kleer,
LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo, MOST,
MOST logo, MPLAB, OptoLyzer, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip Designer,
QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer,
Tachyon, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip
Technology Incorporated in the U.S.A. and other countries.

AgileSwitch, ClockWorks, The Embedded Control Solutions Company, EtherSynch, Flashtec, Hyper
Speed Control, HyperLight Load, Libero, motorBench, mTouch, Powermite 3, Precision Edge,
ProASIC, ProASIC Plus, ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, TimeCesium,
TimeHub, TimePictra, TimeProvider, and ZL are registered trademarks of Microchip Technology
Incorporated in the U.S.A.

Adjacent Key Suppression, AKS, Analog-for-the-Digital Age, Any Capacitor, AnyIn, AnyOut,
Augmented Switching, BlueSky, BodyCom, Clockstudio, CodeGuard, CryptoAuthentication,
CryptoAutomotive, CryptoCompanion, CryptoController, dsPICDEM, dsPICDEM.net, Dynamic

https://www.microchip.com/en-us/support/design-help/client-support-services
https://www.microchip.com/en-us/support/design-help/client-support-services
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