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Introduction

Author: Rupali Honrao, Microchip Technology Inc.

This application note outlines how to get started with the tinyAVR® 2 Family devices.

Refer to the data sheet for further information on the differences between the tinyAVR® 2 Family devices.

Features presented in this document
• Getting Started with tinyAVR® 2 Family Microcontrollers and Tools
• Getting Started with ATtiny1627 Curiosity Nano and Atmel Studio 7.0
• Getting Started with ATtiny1627 Curiosity Nano and MPLAB® X
• Code examples in Atmel START and Github
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1. Relevant Devices
This section lists the relevant devices for this document. The following figures show the different family devices,
laying out pin count variants and memory sizes:

• Vertical migration upwards is possible without code modification, as these devices are pin-compatible and
provide the same or more features

• Horizontal migration to the left reduces the pin count and, therefore, the available features
• Devices with different Flash memory sizes typically also have different SRAM and EEPROM

Figure 1-1. tinyAVR® 2 Family Overview
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2. Get the Device Data Sheet
Product pages

• https://www.microchip.com/wwwproducts/en/ATtiny1624
• https://www.microchip.com/wwwproducts/en/ATtiny1626
• https://www.microchip.com/wwwproducts/en/ATtiny1627

Documents

• tinyAVR 2 Data Sheet (.pdf)
• tinyAVR 2 Errata (.pdf)

The documentation for the tinyAVR® 2 Family is split into two document types:

• Data sheet(1) (includes device description, number of peripherals, pinout and electrical characteristics)
• Errata (includes known errata for the device)

Note: 
1. For devices that are future products, the product brief is available instead of the data sheet.
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3. Relevant Documents
All relevant documents can be found under the documentation tab on the product page.

Below is list of documents relevant to tinyAVR® 2 Family Microcontrollers.

• Tech Briefs:
– How to use the 12-Bit Differential ADC with PGA in Single Mode
– How to use the 12-Bit Differential ADC with PGA in Series Accumulation Mode
– How to use the 12-Bit Differential ADC with PGA in Burst Accumulation Mode

• Application Notes:
– How to use Force Sensitive Resistor with 12-Bit ADC
– How to use Sensor PIR with 12-bit ADC with PGA
– Using Matrix Keypad With AVR® Devices

• Training Manual:
– Getting Started with tinyAVR 2 Family ADC Hands-on
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4. Get the Tools
Atmel Studio 7.0, which uses the GCC compiler, can be utilized as an IDE to get started with tinyAVR® 2 Family.

MPLAB® X, which uses the GCC or XC8 compiler, can be utilized as an IDE to get started with tinyAVR® 2 Family.

4.1 Get the ATtiny1627 Curiosity Nano Evaluation Kit

Web page: www.microchip.com/developmenttools/productdetails.aspx?partno=DM080104

Get the kit: www.microchipdirect.com/ProductSearch.aspx?Keywords=DM080104

Document/file:
• ATtiny1627 Curiosity Nano (.pdf)

Key Features

• ATtiny1627 Microcontroller
• One Yellow User LED
• One Mechanical User Switch
• Footprint for 32.768 kHz Crystal
• On-Board Debugger:

– Board identification in Atmel Studio/Microchip MPLAB® X

 AN3456
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– One green power and status LED
– Programming and debugging
– Virtual COM port (CDC)
– Two logic analyzer channels (DGI GPIO)

• USB Powered
• Adjustable Target Voltage:

– MIC5353 LDO regulator controlled by the on-board debugger
– 1.8-5.1 V output voltage (limited by USB input voltage)
– 500 mA maximum output current (limited by ambient temperature and output voltage)

The ATtiny1627 Curiosity Nano user guide covers how to power the kit and the detailed information on board
components, extension interface, and the hardware guide.

4.2 Get the STK600 Starter Kit
Figure 4-1. STK600 Starter Kit

Table 4-1. STK600 Device Support for tinyAVR® 2 Family

Device Routing Card Socket Card

ATtiny1624 STK600-RC020T-104 STK600-SOIC

ATtiny1626 STK600-RC020T-104 STK600-SOIC

ATtiny1627 STK600-RC024T-103 STK600-QFN24

For device support for other devices, refer to: http://www.microchip.com/STK600_Starter_Kit-Users_Guide

Web page: http://www.microchip.com/ATSTK600

Get the kit: https://www.microchipdirect.com/product/ATSTK600

Document/file:
• STK600 User Guide (.pdf)

Key features
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• Atmel Studio/AVR® Studio 5/AVR Studio 4/AVR32 Studio
• USB Interface to PC for Programming and Control
• Powered from the USB Bus or an External 10-15V DC Power Supply
• Adjustable Target VCC (0-5.5V)
• Two Adjustable Reference Voltages with High Accuracy (0-5.0V, 10 mV res.)
• Clock Oscillator, Adjustable On-The-Fly from Atmel Studio (0-50 MHz, 0.1% res.)
• Serial In-System Programming (ISP) of tinyAVR and megaAVR® Devices
• PDI Programming of AVR XMEGA® Devices
• JTAG Programming of megaAVR, AVR XMEGA, and AVR UC3 Devices
• aWire Programming of AVR UC3 Devices
• ISP and JTAG Programming of AVR Devices in External Target Systems
• Flexible Routing and Socket Card System for Easy Mounting of all Supported Devices
• Eight Push Buttons for General Use
• Eight LEDs for General Use
• All AVR I/O Ports are Easily Accessible through Pin Header Connectors
• Expansion Connectors for Plug-In Modules and Prototyping Area
• On-Board 4 Mb DataFlash for Nonvolatile Data
• USB mini-AB (On-The-Go) Connector for AVR Devices with USB
• PHY and DSUB-9 Connector for RS-232 Interface
• PHY and DSUB-9 Connector for CAN Bus
• PHY and Header for LIN Bus
• Device Board with an ATmega2560 AVR Microcontroller Included

The STK600 User Guide describes how to power the kit and includes detailed information about board components,
extension interface, and the hardware description.

4.3 Get Code Examples from Atmel START
The code examples are available through Atmel START, which is a web-based tool that enables the configuration of
the application code through a Graphical User Interface (GUI). The code can be downloaded for Atmel Studio
MPLAB X and IAR Embedded Workbench® via the direct example code link below or the Browse Examples button
on the Atmel START front page.

The Atmel START webpage: Atmel START.

Code Examples

Finding code examples for devices in the tinyAVR 2 family can be done by searching for the device name (e.g.,
ATtiny1627), in the Atmel | START example browser.

Click User Guide in Atmel START for details and information about example projects. The User Guide button can be
found in the example browser, and by clicking the project name in the dashboard view within the Atmel START
project configurator.

Atmel Studio

Download the code as an .atzip file for Atmel Studio from the example browser in Atmel START by clicking
Download Selected example. To download the file from within Atmel START, click Export project followed by
Download pack.

Double click the downloaded .atzip file, and the project will be imported to Atmel Studio 7.0.

MPLAB X

Download the code as an .atzip file for MPLAB X IDE from within Atmel START by clicking Export project
followed by Download pack.

To open the Atmel START example in MPLAB X, select from the menu in MPLAB X, File > Import > START MPLAB
Project and navigate to the .atzip file.
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IAR Embedded Workbench

For information on how to import the project in IAR Embedded Workbench, open the Atmel START User Guide,
select Using Atmel Start Output in External Tools, and IAR Embedded Workbench. A link to the Atmel START
User Guide can be found by clicking Help from the Atmel START front page or Help And Support within the project
configurator, both located in the upper right corner of the page.

4.4 Get Code Examples from GitHub
The code examples are available through GitHub, which is a web-based server that provides the application codes
through a Graphical User Interface (GUI). The code examples can be opened in both Atmel Studio and MPLAB X. To
open the Atmel Studio project in MPLAB X, select from the menu in MPLAB X, File > Import > Atmel Studio Project
and navigate to .cproj file.

The GitHub webpage: GitHub.

Code Examples

Finding code examples for devices in the tinyAVR 2 Family can be done by searching for the device name (e.g.,
ATtiny1627), in the GitHub example browser.

View Code Examples on GitHub
Click to browse repositories

Download the code as a .zip file from the example page on GitHub by clicking the Clone or download button.

4.5 Get Atmel Studio 7.0
Webpage: www.microchip.com/development-tools/atmel-studio-7

Document/file:
• Atmel Studio 7.0 Installer (.exe)

Atmel Studio 7.0 or later is the preferred IDE for developing and debugging firmware for the tinyAVR® 2 Family.

For device support, refer to 4.8  Get Device Support for Atmel Studio.

4.6 Get MPLAB® X
Webpage: MPLAB® X IDE

Document/file:
• MPLAB X

MPLAB X can be utilized as an IDE for developing and debugging firmware for the tinyAVR® 2 Family.

For device support, refer to 4.9  Get Device Support for MPLAB X.

4.7 Get IAR Embedded Workbench® for AVR®
Webpage: https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR

Document/file: IAR Embedded Workbench installer for AVR®.

4.8 Get Device Support for Atmel Studio
Atmel Studio: Support for new devices in Atmel Studio can be added by using the Device Pack Manager, which is
found under Tools → Device Pack Manager.
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For tinyAVR® 2 Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For tinyAVR® 2 Family, select the latest available version of ATtiny_DFP.
3. Click Install.

For offline installers, go to packs.download.atmel.com/. To install a package, double click on the installer file and
follow the instructions. Any open Atmel Studio window will have to be closed for the installation to take effect.

IAR™: Support for new devices in IAR Embedded Workbench can be added by installing the latest service package.
The service package is available at My Pages on https://iar.com.

4.9 Get Device Support for MPLAB® X
MPLAB X: Support for new devices in MPLAB X can be added by using the MPLAB Pack Manager, which is found
under Tools → Packs.

For the tinyAVR® 2 Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For the tinyAVR® 2 Family, select the latest available version of ATtiny_DFP.
3. Click Install.

For offline installers, go to packs.download.microchip.com/. To install a package, double click on the installer file and
follow the instructions. Any open MPLAB X window will have to be closed for the installation to take effect.
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5. Atmel Studio Users Getting Started

5.1 Atmel Studio with ATtiny1627 Curiosity Nano
Prerequisites

• Atmel Studio 7.0.2397 or later installed
• The ATtiny1627 Curiosity Nano Board connected to Atmel Studio 7.0 via the on-board USB connector, which is

connected to the embedded debugger. The kit will be powered by the USB, and the embedded debugger will
enable debugging and programming via the USB.

Workflow

1. Launch Atmel Studio 7.0.
2. The page shown below will appear when ATtiny1627 Curiosity Nano is connected to Atmel Studio 7.0.

Figure 5-1. ATtiny1627 Curiosity Nano Page in Atmel Studio

3. Start creating a new project by clicking New → Project... or by using Ctrl+Shift+N shortcut, as shown in 
Figure 5-2.
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Figure 5-2. Create New Project in Atmel Studio

4. Select the GCC C Executable Project template, as shown in Figure 5-3, type in the name of the solution and
project (e.g., GETTING_STARTED and LED_TOGGLE), and click OK.
Figure 5-3. New Project Wizard

5. Select ATtiny1627 from Figure 5-4, and click OK.
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Figure 5-4. Device Selection Wizard

A new project with a main.c file associated with it will be generated in Atmel Studio.
6. Replace the main.c file with the following code snippet:

int main (void)
{
  /* Configure SW0 as input */
  PORTC.DIRCLR = PIN4_bm;
  /*Enable internal pull up for SW0*/
  PORTC.PIN4CTRL  = PORT_PULLUPEN_bm; 
  /* Configure LED0 pin as output */
  PORTB.DIRSET = PIN7_bm;
    
  while (1)
  {
    /* Check the status of SW0 */
    /* 0: Pressed */
    if (!(PORTC.IN & (PIN4_bm)))
    {
      /* LED0  off */
      PORTB.OUTSET = PIN7_bm;
    }
    /* 1: Released */
    else
    {
      /* LED0 on */
      PORTB.OUTCLR = PIN7_bm;
    }
  }
}

In the code editor, the code will appear, as shown in Figure 5-5.
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Figure 5-5. Code Editor Window

7. Open project properties by clicking Project → Properties or by using ALT+F7 shortcut.
8. In the Tool view (see Figure 5-6), set Selected debugger/programmer to nEDBG and Interface to UPDI.
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Figure 5-6. Debugger and Interface for ATtiny1627

9. Build the project by clicking Build → Build Solution or by using F7 shortcut.
10. Program ATtiny1627 with the project code and start debugging by clicking Debug → Start debugging and

break or by using ALT+F5 shortcut . The application is programmed onto the device, and program execution
will break in main() function.

11. Run the code by clicking Debug → Continue or by using F5 shortcut .
12. Verify that LED0 is lit when SW0 is pushed on the ATtiny1627 Curiosity Nano.

5.2 Atmel Studio with STK600
Prerequisites

• Atmel Studio 7.0 2397 or later installed
• The STK600 board connected to Atmel Studio 7.0 via the on-board USB connector.

Workflow

1. Launch Atmel Studio 7.0.
2. Start creating a new project by clicking New → Project... or by using the shortcut Ctrl+Shift+N, as shown in the

figure below.
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Figure 5-7. Create New Project in Atmel Studio

3. Select the GCC C Executable Project template from the new project wizard shown in the following figure, type
in the name of the solution and project (e.g., GETTING_STARTED and LED_TOGGLE), and click OK.
Figure 5-8. New Project Wizard

4. Select ATtiny1627 from the device selection wizard as shown in the figure below, and click OK.
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Figure 5-9. Device Selection Wizard

A new project with a main.c file associated with it will be generated in Atmel Studio.
5. Replace the ‘main’ function in the main.c file with the following code snippet:

int main (void)
{
  /* STK600 have eight User Buttons and eight User LEDs which can be connected to any IO 
pin using cables */
  /* Configure PB0 as input (remember to connect SW0 to PB0 using a cable */
  PORTB.DIRCLR = PIN0_bm;

  /* Configure PB1 as output (remember to connect LED0 to PB1 using a cable*/
  PORTB.DIRSET = PIN1_bm;
    
  while (1)
  {
    /* Check the status of SW0 */
    /* 0: Pressed */
    if (!(PORTB.IN & (PIN0_bm)))
    {
      /* LED0 on */
      PORTB.OUTCLR = PIN1_bm;
    }
    /* 1: Released */
    else
    {
      /* LED0 off */
      PORTB.OUTSET = PIN1_bm;
    }
  }
}

In the code editor, the code may appear as shown in the figure below.
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Figure 5-10. Code Editor Window

6. Open project properties by clicking Project → Properties or by using the shortcut ALT+F7.
7. In Tool view (figure below), set Selected debugger/programmer to STK600 and Interface to UPDI.
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Figure 5-11. Debugger and Interface for ATtiny1627

8. Build the project by clicking Build → Build Solution or using the shortcut F7.
9. Connect the embedded debugger on STK600 to ATtiny1627 by connecting a cable between the ISP/PDI

headers, as shown in the figure below.
Figure 5-12. UPDI Connection on STK600

10. Connect PC4 to SW0, and PB7 to LED0 by using cables.
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11. Load the code onto the STK600 and start debugging by clicking Debug → Start debugging and break or by
using the shortcut ALT+F5. The application is programmed onto the device and the program execution should
break in main.

12. Run the code by clicking Debug → Continue or by using the shortcut F5.
13. Verify that LED0 is lit when SW0 is pushed on STK600.

 AN3456
Atmel Studio Users Getting Started

© 2020 Microchip Technology Inc.  Application Note DS00003456A-page 20



6. MPLAB® X Users Getting Started

6.1 MPLAB® X with ATtiny1627 Curiosity Nano
Prerequisites

• MPLAB X installed
• The ATtiny1627 Curiosity Nano Board connected to MPLAB X via the on-board USB connector, which is

connected to the embedded debugger. The kit will be powered by the USB, and the embedded debugger will
enable debugging and programming via the USB.

Workflow

1. Launch MPLAB X.
2. The page shown in Figure 6-1 will appear when ATtiny1627 Curiosity Nano is connected to MPLAB X.

Figure 6-1. ATtiny1627 Curiosity Nano Page in MPLAB® X

3. Start creating a new project by clicking File → New Project... or by using Ctrl+Shift+N shortcut, as shown in 
Figure 6-2.
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Figure 6-2. Create New Project in MPLAB® X

4. Select the Categories → Microchip Embedded and Projects → Standalone Project template from Figure
6-6, and click Next.
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Figure 6-3. New Project Window

5. Select ATtiny1627 from Figure 6-4, and click Next.
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Figure 6-4. Device Selection Window

Then select the board and the desired compiler, if there are any.
6. Type in the name of the project (e.g., LED_TOGGLE) and the project location (e.g., C:\microchip), and click

Finish.
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Figure 6-5. Project Name and Location Selection Window

7. Create a new main.c file by clicking File → New File... or by using Ctrl+N shortcut, as shown in Figure 6-6.
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Figure 6-6. Create a New File in MPLAB® X

8. Select the Categories → C and File Types → C Main File template from Figure 6-7, and click Next.
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Figure 6-7. New File Window

9. Type in the name of the file (e.g., main) and click Finish.
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Figure 6-8. File Name Window

10. Replace the main.c file with the following code snippet:

int main (void)
{
  /* Configure SW0 as input */
  PORTC.DIRCLR = PIN4_bm;
  /*Enable internal pull up for SW0*/
  PORTC.PIN4CTRL  = PORT_PULLUPEN_bm; 
  /* Configure LED0 pin as output */
  PORTB.DIRSET = PIN7_bm;
    
  while (1)
  {
    /* Check the status of SW0 */
    /* 0: Pressed */
    if (!(PORTC.IN & (PIN4_bm)))
    {
      /* LED0  off */
      PORTB.OUTSET = PIN7_bm;
    }
    /* 1: Released */
    else
    {
      /* LED0 on */
      PORTB.OUTCLR = PIN7_bm;
    }
  }
}

Add #inlude<avr/io.h> in main.c. In the code editor, the code will appear as shown in Figure 6-9.
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Figure 6-9. Code Editor Window

11. Build the code by clicking on Production → Clean and Build Main Project or by using Shift + F11 shortcut.
12. Program ATtiny1627 with the project code and start debugging by clicking Debug → Debugging Main

Project.
13. Verify that LED0 is lit when SW0 is pushed on the ATtiny1627 Curiosity Nano.
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7. What's Next
For further information on related AVR products and IDE, refer to the links below:

Software:
• Atmel Studio: www.microchip.com/avr-support/atmel-studio-7
• Atmel Studio help: Help → View Help (shortcut CTRL+F1)
• Atmel Gallery: gallery.microchip.com/
• MPLAB X: https://www.microchip.com/mplab/mplab-x-ide
• IAR Embedded Workbench for AVR :www.iar.com/iar-embedded-workbench/#!?architecture=AVR

Firmware:
• Atmel START documentation: http://start.atmel.com
• Atmel START examples: microchip.com/start/#examples
• GitHub examples: https://github.com/search?q=microchip-pic-avr-examples%2F

Hardware:
• AVR042: AVR Hardware Design Considerations:ww1.microchip.com/downloads/en/appnotes/atmel-2521-avr-

hardware-design-considerations_applicationnote_avr042.pdf
• AVR IBIS files: www.microchip.com/doclisting/TechDoc.aspx?type=IBIS
• AVR BDSL files: www.microchip.com/doclisting/TechDoc.aspx?type=BSDL

Recommended Programming/Debugging Tools:
• Atmel-ICE:

– Documentation: http://www.microchip.com/Atmel-ICE_Debugger_User_Guide
– Buy: https://www.microchip.com/Development-Tools/atatmel-ice

• Power debugger:
– Documentation: http://www.microchip.com/42696D_Power_Debugger_User_Guide
– Buy: https://www.microchip.com/Development-Tools/atpowerdebugger

• MPALB Snap:
– www.microchip.com/developmenttools/ProductDetails/PartNO/PG164100

• MPLAB PICkit4:
– www.microchip.com/developmenttools/ProductDetails/PG164140

Other:
• AVR Freaks®: www.avrfreaks.net/
• Application notes: www.microchip.com/paramChartSearch/chart.aspx?branchID=30047, find the preferred

device and go to the product page. All relevant application notes can be found under the documentation tab.
• AVR product selector: www.microchip.com/paramChartSearch/chart.aspx?branchID=30047
• More technical documentation concerning various products: https://www.microchip.com/webdoc
• Microchip Technical Support: www.microchip.com/support/hottopics.aspx

 AN3456
What's Next

© 2020 Microchip Technology Inc.  Application Note DS00003456A-page 30

http://www.microchip.com/avr-support/atmel-studio-7
https://gallery.microchip.com/
https://www.microchip.com/mplab/mplab-x-ide
https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR
http://start.atmel.com
http://microchip.com/start/#examples
https://github.com/search?q=microchip-pic-avr-examples%2F
http://ww1.microchip.com/downloads/en/appnotes/atmel-2521-avr-hardware-design-considerations_applicationnote_avr042.pdf
http://ww1.microchip.com/downloads/en/appnotes/atmel-2521-avr-hardware-design-considerations_applicationnote_avr042.pdf
http://www.microchip.com/doclisting/TechDoc.aspx?type=IBIS
http://www.microchip.com/doclisting/TechDoc.aspx?type=BSDL
http://www.microchip.com/mymicrochip/filehandler.aspx?ddocname=en604412
https://www.microchip.com/Development-Tools/atatmel-ice
http://www.microchip.com/mymicrochip/filehandler.aspx?ddocname=en604415
https://www.microchip.com/Development-Tools/atpowerdebugger
https://www.microchip.com/developmenttools/ProductDetails/PartNO/PG164100
https://www.microchip.com/developmenttools/ProductDetails/PG164140
http://www.avrfreaks.net/
http://www.microchip.com/paramChartSearch/chart.aspx?branchID=30047
http://www.microchip.com/paramChartSearch/chart.aspx?branchID=30047
https://www.microchip.com/webdoc
http://www.microchip.com/support/hottopics.aspx


8. Revision History
Doc. Rev. Date Comments

A 07/2020 Initial document release

 AN3456
Revision History

© 2020 Microchip Technology Inc.  Application Note DS00003456A-page 31



The Microchip Website
Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service
Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support
Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature
Note the following details of the code protection feature on Microchip devices:

• Microchip products meet the specification contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is one of the most secure families of its kind on the market today,

when used in the intended manner and under normal conditions.
• There are dishonest and possibly illegal methods used to breach the code protection feature. All of these

methods, to our knowledge, require using the Microchip products in a manner outside the operating
specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of
intellectual property.

• Microchip is willing to work with the customer who is concerned about the integrity of their code.
• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code

protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection
features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital
Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you
may have a right to sue for relief under that Act.

Legal Notice
Information contained in this publication regarding device applications and the like is provided only for your
convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with
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your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER
EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION,
INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR
FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip
devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend,
indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such
use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless
otherwise stated.

Trademarks
The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BesTime,
BitCloud, chipKIT, chipKIT logo, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, HELDO, IGLOO, JukeBlox,
KeeLoq, Kleer, LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo, MOST,
MOST logo, MPLAB, OptoLyzer, PackeTime, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip Designer,
QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer, Tachyon,
TempTrackr, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip Technology
Incorporated in the U.S.A. and other countries.

APT, ClockWorks, The Embedded Control Solutions Company, EtherSynch, FlashTec, Hyper Speed Control,
HyperLight Load, IntelliMOS, Libero, motorBench, mTouch, Powermite 3, Precision Edge, ProASIC, ProASIC Plus,
ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, Temux, TimeCesium, TimeHub, TimePictra, TimeProvider,
Vite, WinPath, and ZL are registered trademarks of Microchip Technology Incorporated in the U.S.A.

Adjacent Key Suppression, AKS, Analog-for-the-Digital Age, Any Capacitor, AnyIn, AnyOut, BlueSky, BodyCom,
CodeGuard, CryptoAuthentication, CryptoAutomotive, CryptoCompanion, CryptoController, dsPICDEM,
dsPICDEM.net, Dynamic Average Matching, DAM, ECAN, EtherGREEN, In-Circuit Serial Programming, ICSP,
INICnet, Inter-Chip Connectivity, JitterBlocker, KleerNet, KleerNet logo, memBrain, Mindi, MiWi, MPASM, MPF,
MPLAB Certified logo, MPLIB, MPLINK, MultiTRAK, NetDetach, Omniscient Code Generation, PICDEM,
PICDEM.net, PICkit, PICtail, PowerSmart, PureSilicon, QMatrix, REAL ICE, Ripple Blocker, SAM-ICE, Serial Quad
I/O, SMART-I.S., SQI, SuperSwitcher, SuperSwitcher II, Total Endurance, TSHARC, USBCheck, VariSense,
ViewSpan, WiperLock, Wireless DNA, and ZENA are trademarks of Microchip Technology Incorporated in the U.S.A.
and other countries.

SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

The Adaptec logo, Frequency on Demand, Silicon Storage Technology, and Symmcom are registered trademarks of
Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip
Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.
© 2020, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.

ISBN: 978-1-5224-6465-5

Quality Management System
For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.
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AMERICAS ASIA/PACIFIC ASIA/PACIFIC EUROPE
Corporate Office
2355 West Chandler Blvd.
Chandler, AZ 85224-6199
Tel: 480-792-7200
Fax: 480-792-7277
Technical Support:
www.microchip.com/support
Web Address:
www.microchip.com
Atlanta
Duluth, GA
Tel: 678-957-9614
Fax: 678-957-1455
Austin, TX
Tel: 512-257-3370
Boston
Westborough, MA
Tel: 774-760-0087
Fax: 774-760-0088
Chicago
Itasca, IL
Tel: 630-285-0071
Fax: 630-285-0075
Dallas
Addison, TX
Tel: 972-818-7423
Fax: 972-818-2924
Detroit
Novi, MI
Tel: 248-848-4000
Houston, TX
Tel: 281-894-5983
Indianapolis
Noblesville, IN
Tel: 317-773-8323
Fax: 317-773-5453
Tel: 317-536-2380
Los Angeles
Mission Viejo, CA
Tel: 949-462-9523
Fax: 949-462-9608
Tel: 951-273-7800
Raleigh, NC
Tel: 919-844-7510
New York, NY
Tel: 631-435-6000
San Jose, CA
Tel: 408-735-9110
Tel: 408-436-4270
Canada - Toronto
Tel: 905-695-1980
Fax: 905-695-2078

Australia - Sydney
Tel: 61-2-9868-6733
China - Beijing
Tel: 86-10-8569-7000
China - Chengdu
Tel: 86-28-8665-5511
China - Chongqing
Tel: 86-23-8980-9588
China - Dongguan
Tel: 86-769-8702-9880
China - Guangzhou
Tel: 86-20-8755-8029
China - Hangzhou
Tel: 86-571-8792-8115
China - Hong Kong SAR
Tel: 852-2943-5100
China - Nanjing
Tel: 86-25-8473-2460
China - Qingdao
Tel: 86-532-8502-7355
China - Shanghai
Tel: 86-21-3326-8000
China - Shenyang
Tel: 86-24-2334-2829
China - Shenzhen
Tel: 86-755-8864-2200
China - Suzhou
Tel: 86-186-6233-1526
China - Wuhan
Tel: 86-27-5980-5300
China - Xian
Tel: 86-29-8833-7252
China - Xiamen
Tel: 86-592-2388138
China - Zhuhai
Tel: 86-756-3210040

India - Bangalore
Tel: 91-80-3090-4444
India - New Delhi
Tel: 91-11-4160-8631
India - Pune
Tel: 91-20-4121-0141
Japan - Osaka
Tel: 81-6-6152-7160
Japan - Tokyo
Tel: 81-3-6880- 3770
Korea - Daegu
Tel: 82-53-744-4301
Korea - Seoul
Tel: 82-2-554-7200
Malaysia - Kuala Lumpur
Tel: 60-3-7651-7906
Malaysia - Penang
Tel: 60-4-227-8870
Philippines - Manila
Tel: 63-2-634-9065
Singapore
Tel: 65-6334-8870
Taiwan - Hsin Chu
Tel: 886-3-577-8366
Taiwan - Kaohsiung
Tel: 886-7-213-7830
Taiwan - Taipei
Tel: 886-2-2508-8600
Thailand - Bangkok
Tel: 66-2-694-1351
Vietnam - Ho Chi Minh
Tel: 84-28-5448-2100

Austria - Wels
Tel: 43-7242-2244-39
Fax: 43-7242-2244-393
Denmark - Copenhagen
Tel: 45-4485-5910
Fax: 45-4485-2829
Finland - Espoo
Tel: 358-9-4520-820
France - Paris
Tel: 33-1-69-53-63-20
Fax: 33-1-69-30-90-79
Germany - Garching
Tel: 49-8931-9700
Germany - Haan
Tel: 49-2129-3766400
Germany - Heilbronn
Tel: 49-7131-72400
Germany - Karlsruhe
Tel: 49-721-625370
Germany - Munich
Tel: 49-89-627-144-0
Fax: 49-89-627-144-44
Germany - Rosenheim
Tel: 49-8031-354-560
Israel - Ra’anana
Tel: 972-9-744-7705
Italy - Milan
Tel: 39-0331-742611
Fax: 39-0331-466781
Italy - Padova
Tel: 39-049-7625286
Netherlands - Drunen
Tel: 31-416-690399
Fax: 31-416-690340
Norway - Trondheim
Tel: 47-72884388
Poland - Warsaw
Tel: 48-22-3325737
Romania - Bucharest
Tel: 40-21-407-87-50
Spain - Madrid
Tel: 34-91-708-08-90
Fax: 34-91-708-08-91
Sweden - Gothenberg
Tel: 46-31-704-60-40
Sweden - Stockholm
Tel: 46-8-5090-4654
UK - Wokingham
Tel: 44-118-921-5800
Fax: 44-118-921-5820

Worldwide Sales and Service
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