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Preface

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and
documentation are constantly evolving to meet customer needs, so some actual dialogs
and/or tool descriptions may differ from those in this document. Please refer to our web site
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each
page, in front of the page number. The numbering convention for the DS number is
“DSXXXXXXXXA”, where “XXXXXXXX” is the document number and “A” is the revision level
of the document.

For the most up-to-date information on development tools, see the MPLAB® IDE online help.
Select the Help menu, and then Topics, to open a list of available online help files.

INTRODUCTION

This chapter contains general information that will be useful to know before using the
Getting started with MPLAB® MINDI™ Analog Simulator Tool. Items discussed in this
chapter include:

* Document Layout

» Conventions Used in this Guide

» Warranty Registration

* Recommended Reading

* The Microchip Web Site

» Customer Support

* Document Revision History

DOCUMENT LAYOUT

This document describes how to use the Getting started with MPLAB® MINDI™
Analog Simulator Tool as a development tool to emulate and debug firmware on a
target board. The manual layout is as follows:

* Introduction

* Running MPLAB® MINDI™ Simulator

» Welcome Page overview and navigation
» Creating a new schematic

* Running the simulation

+ Simulation results

© 2016 Microchip Technology Inc. DS50000000A-page 4
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description

Represents

Examples

Arial font:

Italic characters

Referenced books

MPLAB® IDE User’s Guide

Emphasized text

...Is the only compiler...

Initial caps A window the Output window
A dialog the Settings dialog
A menu selection select Enable Programmer
Quotes A field name in a window or | “Save project before build”
dialog
Underlined, italic text with A menu path File>Save
right angle bracket
Bold characters A dialog button Click OK

A tab

Click the Power tab

N‘Rnnnn

A number in verilog format,
where N is the total number of
digits, Ris theradixand nis a
digit.

4'b0010, 2'hF1

Text in angle brackets < >

A key on the keyboard

Press <Enter>, <F1>

Courier New font:

Plain Courier New

Sample source code

#define START

Filenames autoexec.bat

File paths c:\mccl18\h

Keywords _asm, _endasm, static
Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New

A variable argument

file.o, where file can be
any valid filename

Square brackets [ ]

Optional arguments

mccl8 [options] file

[options]

Curly brackets and pipe
character: { | }

Choice of mutually exclusive
arguments; an OR selection

errorlevel {0]1}

Ellipses... Replaces repeated text var_name [,
var name...]
Represents code supplied by [void main (void)
user {
}
WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly.
Sending in the Warranty Registration Card entitles users to receive new product
updates. Interim software releases are available at the Microchip web site.
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Preface

RECOMMENDED READING

This user’s guide describes how to use the Getting started with MPLAB® MINDI™
Analog Simulator Tool. Other useful documents are listed below. The following Micro-
chip document is available and recommended as a supplemental reference resource:

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This

web site is used as a means to make files and information easily available to

customers. Accessible by using your favorite Internet browser, the web site contains

the following information:

* Product Support — Data sheets and errata, application notes and sample
programs, design resources, user’s guides and hardware support documents,
latest software releases and archived software

» General Technical Support — Frequently Asked Questions (FAQs), technical
support requests, online discussion groups, Microchip consultant program
member listing

* Business of Microchip — Product selector and ordering guides, latest Microchip
press releases, listing of seminars and events, listings of Microchip sales offices,
distributors and factory representatives

PRODUCT CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip
products. Subscribers will receive e-mail notifications whenever there are changes,
updates, revisions or errata related to a specified product family or development tool of
interest.

To register, access the Microchip web site at www.microchip.com, click on Product
Change Notification and follow the registration instructions.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

« Distributor or Representative

* Local Sales Office

 Field Application Engineer (FAE)
» Technical Support

Customers should contact their distributor, representative or field application engineer
(FAE) for support. Local sales offices are also available to help customers. A listing of
sales offices and locations is included in the back of this document.

Technical support is available through the web site at:
http://www.microchip.com/support.

DOCUMENT REVISION HISTORY
Revision A (December 2016)

* |nitial Release of this Document.

© 2016 Microchip Technology Inc. DS50000000A-page 6
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Getting started with MPLAB® MINDI™ Analog Simulator Tool

1.1 INTRODUCTION

MPLAB® MINDI™ Analog Simulator Tool is a comprehensive tool for circuit analysis. It
consists of:

» SIMPLIS (SIMulation of Piecewise Linear Systems): is a circuit simulator specifi-
cally designed to handle the simulation challenges of switching power systems.
Like SPICE, SIMPLIS works at the component level but typically can perform a
transient analysis of a switching circuit 10 to 50 times faster. For switching power
systems, the piecewise linear (PWL) modeling and simulation techniques
employed by SIMPLIS result in qualitatively superior convergence behavior com-
pared to SPICE.

» SlMetrix: is a general analog and mixed-signal simulator. It includes an enhanced
SPICE simulator, schematic editor and waveform viewer in a unified environment.
It is easy to use, offers good accuracy and performance, and rapid convergence
for a broad range of analog and mixed-signal design applications.

1.2 RUNNING MPLAB® MINDI™ SIMULATOR

To start MPLAB® MINDI™ Simulator, double click on the desktop shortcut after instal-
lation, or select Start>All Programs>Mindi 8.00. A splash screen will display the
MPLAB® MINDI™ Simulator logo followed by the MPLAB® MINDI™ Simulator desk-
top.

MPLAE Mindi

MINDI

ANALOG STMULATOR

-

Powered by SIMetrix/SIMPLIS

MPLAB® Mindi™ is a spedal edition of SIMetrig/SIMPLIS, induding
the same elements as the full release of SIMetriogf SIMPLIS but with a
limitation on the size of the drcuits that can be simulated. Models and
application schematics for many of Microchip's analog products are
provided to support customer designs by providing a starting point and
speeding up drouit development.

© 2016 Microchip Technology Inc. DS50000000A-page 8



Getting started with MPLAB® MINDI™ Analog Simulator Tool

MPLAE Mindi Main Windo

File View Help

(Webvew [7]
ME- N -1
File View Welcome to MPLAB® Mindi™ Analog Simulator w3
[add Diectory
. Examples-80

ﬁ'\ MICROCHIP

‘Welcome Page

Create New / Open
._LI New SIMetrix Schematic
+* New SIMPLIS Schematic
._LI New Symbol

k¥ Open File...

I" Part Selector I Command

MPLAB® Mindi™ Support
B2 Getting Started
A Getting Help

3 Getting More Models/Schematics

Application Schematics

shell | File view |

Recent Schematics

MPLAB Mindi

Battery Management
[M] Linear Amplifiers

MOSFET and Motor Drivers
k' Power Management

Power Switches

Powered by SIMetrix/SIMPLIS

NOTICE

matics.

Update Schedule to Monthly.

It is strongly recommended that the user lets MPLAB® Mindi™ periodically check for
updates to ensure that the simulator always has the latest models and example sche-

The user can do this by clicking on Help>Check for updates... and set the Automatic

Fe

4 Update Settings

)

Chedk Updates Maow

Automatic Update Schedule |Monthly - |

[

(8]3

H Cancel ‘

DS50000000A-page 9
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Getting started with MPLAB® MINDI™ Analog Simulator Tool

1.3 WELCOME PAGE OVERVIEW AND NAVIGATION

After MPLAB® MINDI™ Simulator startup, the Welcome Page will be shown. It has
quick links for the following actions:

» Create New/Open: open or create a new schematic for SIMPLIS or SIMetrix from
scratch.

 Application Schematics: browse existing application schematics by category.

* Recent Schematics: open recent schematics.

« MPLAB® MINDI™ Support: get help or more application schematics from Micro-
chip Technology Inc.

The existing directory structure containing application schematics can also be visual-
ized in the left frame by clicking on the File View tab.

File view

Add Directory

4 Examples-80 o
SIMetrix
4 SIMPLIS
: Advanced SIMPLIS Training
Analog Functions
Analysis Modes

Boost_Converter
Digital
DVM Tutorial
Manual_Examples
4 Microchip
4 Power Management

m

Controllers

LED Drivers

Modules

4 Switching Regulators
4 MCP1623

{8 MCP1623_AC Load Transient.sxsch:
[N MCP1623_Startup.sxsch
MCP1624
MCP1640
MCP1642
MCP1643
MCP16251
MCP16252 =

| Part Selector I Command Shell | File View |

The user can also easily navigate through this directory structure using the Welcome
Page breadcrumbs by clicking on one directory in the Application Schematics frame.

Application Schematics

Battery Management

E"_'ﬂ Linear Amplifiers
MOSFET and Motor Drivers
ik Power Management

Power Switches

© 2016 Microchip Technology Inc. DS50000000A-page 10



Getting started with MPLAB® MINDI™ Analog Simulator Tool

During navigation, the breadcrumb area will indicate the current path in the directory
hierarchy.

| Welcome Page |

|Welc0me Page > Application Schematics > MOSFET and Mator Drivers |

Note: The directory-type icon v means that the user can go down in the hierarchy.
The Mindi™ @ icon represents folders that are at the bottom level. In those
you can find the application schematic that you want. The faded icons
means empty directory.

MINDI

FMALOGE SIMULATOR

.

|Welc0me Page > Application Schematics = Power Management = Controllers ‘

@ MICROCHIP

m

MCP1632
-_A (MCP1632-AA) Boost example, start up
-_A (MCP1632-AA) Boost example, transient load step
-_A (MCP1632-BA) Boost example, start up
-_A (MCP1632-BA) Boost example, transient load step

MCP19035
-_,d (MCP19035-AAAA) Synchronous buck example, start up
._A (MCP19035-AAAA) Synchronous buck example, transient load step
._A (MCP19035-BAAA) Synchronous buck example, start up
._A (MCP19035-BAAA) Synchronous buck example, transient load step

MIC2101

«* Synchronous buck example, AC transient load step

+* Synchronous buck example, start up

MIC2102

The schematic files have two types of icons. SIMetrix files are marked with 1 icon and
SIMPLIS schematics are marked with < icon.

NOTICE

It is highly recommended that if the example schematics require modifications, the
user should save the modified schematics in a different location by using
File>Save Schematic As... to avoid any potential conflicts.

DS50000000A-page 11 © 2016 Microchip Technology Inc.




Getting started with MPLAB® MINDI™ Analog Simulator Tool

1.4 CREATING A NEW SCHEMATIC

The user can create a new schematic from File>New=>SIMetrix/SIMPLIS Schematic or
by using the Create New/Open quick link from the Welcome Page.

By pressing the Cirl + G key combination the user can see all models installed.

Microchip Technology Inc. models are available from Place>From Microchip Library.
The user will find here only the models that are compatible with the schematic type
(SIMetrix or SIMPLIS).

Place | Probe Probe AC/Moise Hierarchy Monte Carlo  Tools  Help
Repeat Last Place... Alt+R ﬁ Qe\@\@\ / b- “ ﬁ [:] * L @ $ !
From Model Library... Ctrl+G  pntitled™
From Symbol Library...
I From Microchip Library PI l ;ﬂlw‘-'p“.ﬁeés. o p
SEIEILinEn o miIn g Power Management  * Controllers  # MCP1632-AA
search Part.. MCP1632-BA
Hierarchy N MCP19035-AAAA
Create Model » MCPlQUBSEAAA
Magnetics »
Passives L
Connectors L
Probe »
Voltage Sources L
Current Sources *
Controlled Sources L
Bias Annotation L
Semiconductors »
Digital L
Digital Generic L
i Analog Behavioural L
Analog Functions L
! Worksheets 4
[ B B — & | TTT

© 2016 Microchip Technology Inc. DS50000000A-page 12



Getting started with MPLAB® MINDI™ Analog Simulator Tool

1.5 RUNNING THE SIMULATION

After opening an Microchip Technology Inc. application schematic, the user can run the
default analysis by pressing the F9 key or by clicking on Simulator>Run schematic.

File Edit View Place Probe Probe AC/Moise Hierarchy Monte C:
- ll"_l,' x h nalveic F& E Q
File View Run Schematic Fa e
Abort
|
Show SIMPLIS Status Window Ctrl+5Space
4 | Examples-i
.1 SIMetri Initial Conditions 4
4
¢ SIMPL Setup Multi-step...
» L Ad
5 an Run Multi-step
i .:n Find Smallest Time Constant
» . Bo
» [l Dig Graph Time Constants
- DV Debug Simulation
* 8 M) Manage Data G
4 L Mi anage Data Groups...
“ Edit Metlist (before preprocess) SATT -
Edit Metlist (after preprocess) o
4 Open/Close Command (F11) Window Fl11
Switch to SIMetrix Mode

The default analysis type is highlighted in the application schematic's file name (e.g.
MCP1623_AC_Load_Transient) and its parameters can be altered after opening the
Choose Analysis window which is available by pressing the F8 key of by clicking on
Simulator>Choose Analysis. If the user wants to run a user-made schematic, the anal-
ysis type and its parameters must be chosen first.

J Choose SIMPLIS Analysis [
Periodic Operating Point I AC | Transient .
Select analysis
Analysis parameters D POP
Stop time 2.5m ] [ ac
7 b
Start saving data att= 0 % ] Default Transient
Plot data output Save options r
Mumber of plot points ik % [7] Default @ Al
() Voltages Only L
() Probes Only "
1 L
[ Mo Forced Output Data
Force New Analysis
Ok ][ Run ][ Cancel ][ Help ]

DS50000000A-page 13 © 2016 Microchip Technology Inc.



Getting started with MPLAB® MINDI™ Analog Simulator Tool

The analysis options for SIMPLIS and SIMetrix are different and the models are not
compatible from one tool to the other. If the user wants to run a SIMPLIS schematic
using the SIMetrix tool (or vice versa) the MPLAB® MINDI™ Simulator will issue a
warning and will highlight the non-compatible parts.

- N
L1 (e VW
K\.;/j . . } .
L1 MCP1623
IVIN VIN. . . .vouT IVOUuT . 10UT VouT
' 'COUTTT' ' T pi3.3.015)
f'. Message: &J\
l The highlighted component may not function in SIMetrix mode
l- EN I VFB ' Deleting and re-placing the device may resclve the problem
N P T, . Mote: You can set the 'SIMULATOR' symbol property
_ _VE_N ) GND to declare which simulators are supported by a device
+
&)

© 2016 Microchip Technology Inc. DS50000000A-page 14
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1.6 SIMULATION RESULTS

The user can check the state of analysis in the Simulation Status window.

J SIMPLIS Status [

Analysis status

Analysis Transient Data Group | simplis_tran2
Run status | Finished Step

Run Progress | 0%

POP Status  Pass 4 Convergence 5.826541795e-12%
Time 400u Topologies Mew topology #466
Elapsed Time Current Ohr Omin 24 sec Total Ohr Omin 51 sec
CPU time Current Ohr Omin 12.74sec  Total Ohr 0min 35.97 sec
81 82 83 84 BS B& BF 8B B9 30 ~
91 92 93 94 95 96 97 98 99 100
Elapsed time : 0 hr O min z24 sec
CPU time i 0 hr 0 min 12.74 sec
I Simulation time: 4.000000000000e-004 sec

writing pertinent data files ...
Leaving SIMPLIS.

=x* Thank you for trying MPLAE Mindi *=#=
For add'l tional support, please visit www. m1cr0ch1p com

[ Abort ] [Clear Messages] [ Close ] [7] close on completion

After the simulation is finished, the results will pop up.

Note: The schematic must have signal probes that are consistent with the analy-
sis type.

MPLAB® MINDI™ Simulator can do time-domain (waveforms) and frequency-domain
(Bode plots) analysis.

A time-domain simulation shows characteristics such as response time and overshoot.

W [CJvour W [ve W [ 10Ut

1OUT / mA

12 I N,
> 12 NN
R / AN et
g A —
NIY 4
R |
117N

o AN
EEAN

“;
\
?

02 04 08 08 12 14 16

time/mSecs 200uSecs/div
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Getting started with MPLAB® MINDI™ Analog Simulator Tool

While time-domain analysis shows how a signal changes over time, frequency-domain
analysis shows how the signal's energy is distributed over a range of frequencies.

W [ Phase W [ Gain
Phase Margin 40.841277degrees Gain Crossover Frequency 3.8511045KkHz

Phase / degrees

Gain f dB

2 4 1 20 40 100 200 400 1 2k 4k 1Mk 20k 40k 100k 200k 400k il

freq / Hertz

This frequency-domain analysis produces the Bode plots. These plots include critical
information regarding the circuit's closed loop stability such as gain and phase margins.
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NOTES:
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Fax: 886-2-2508-0102

Thailand - Bangkok
Tel: 66-2-694-1351
Fax: 66-2-694-1350

EUROPE

Austria - Wels

Tel: 43-7242-2244-39
Fax: 43-7242-2244-393
Denmark - Copenhagen
Tel: 45-4450-2828

Fax: 45-4485-2829

Finland - Espoo
Tel: 358-9-4520-820

France - Paris

Tel: 33-1-69-53-63-20
Fax: 33-1-69-30-90-79
France - Saint Cloud
Tel: 33-1-30-60-70-00
Germany - Garching
Tel: 49-8931-9700
Germany - Haan

Tel: 49-2129-3766400
Germany - Heilbronn
Tel: 49-7131-67-3636
Germany - Karlsruhe
Tel: 49-721-625370
Germany - Munich
Tel: 49-89-627-144-0
Fax: 49-89-627-144-44
Germany - Rosenheim
Tel: 49-8031-354-560

Israel - Ra’anana
Tel: 972-9-744-7705

Italy - Milan
Tel: 39-0331-742611
Fax: 39-0331-466781

Italy - Padova
Tel: 39-049-7625286

Netherlands - Drunen
Tel: 31-416-690399
Fax: 31-416-690340
Norway - Trondheim
Tel: 47-7289-7561
Poland - Warsaw

Tel: 48-22-3325737

Romania - Bucharest
Tel: 40-21-407-87-50
Spain - Madrid

Tel: 34-91-708-08-90
Fax: 34-91-708-08-91
Sweden - Gothenberg
Tel: 46-31-704-60-40
Sweden - Stockholm
Tel: 46-8-5090-4654

UK - Wokingham
Tel: 44-118-921-5800
Fax: 44-118-921-5820
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